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WiseImage Document 
Brief description: This lesson is devoted to WiseImage documents 
and document properties. You will learn how to customize a 
document and set a user coordinate system. This lesson also 
demonstrates the main dialogs – the Inspector, the Image Manager, 
the Layer Manager, and the Block Manager. 

WiseImage Document 
A WiseImage document can contain both raster images and vector 
objects at the same time; its workspace is unlimited. You can load an 
unlimited number of color, grayscale and monochrome raster images 
(Of course, capacity and working speed depend on your computer 
resources.).  WiseImage supports the multi-document interface 
(MDI), i.e. the program can have several documents loaded, and you 
can simultaneously run different operations on all of them. 
WiseImage document files have a CWS extension. 

How are raster images stored in the document? 
There are two different ways to store raster images in WiseImage: 
1. Linked raster images – are stored separately from the document 

file 
2. Embedded raster images– are stored in the WiseImage 

document file 

WiseImage Document Properties 
If you start working with a new WiseImage document, then you can 
set its properties. The tuned document can be saved as template for 
further use.  (To create a new file, choose File/New from the main 
menu. 

See the section Customizing Program Parameters on page 73 for 
information on template selection 

You can set up font type and height, color, current layer; line type 
and width, etc. as properties of a document. 
The properties of WiseImage objects may be set By layer (In this 
case the properties of created objects inherit the properties of the 
layer they belong to.); or By block (In this case, the objects 
comprised in the block inherit this block’s properties.). 

See the section on the The Layer Manager on page 7 for 
information on setting layer properties. 

How to set up document properties 
• Open the Inspector (choose Inspector from the Tools menu) 
• Make sure, that no object is selected – otherwise the Inspector 

displays its properties.  
To unselect all objects you can press the UnSelect All button that 
is located on the Select toolbar (utmost right). 
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• Make sure that no command is being 
executed; otherwise the Inspector 
displays its parameters. Press Esc to 
cancel all commands. 

• Select desired values from the 
combo-box or enter them in the 
corresponding fields of the 
Inspector. 

Tip: You can save the tuned document 
as a template for further use. 

Document Coordinate System 
You can work in World Coordinate System or set up a User 
Coordinate System (UCS). 
How to set up a UCS 
1. Choose Coordinate System from the Tools menu. 

 

• In the Units tab, specify linear 
and angle measurement units 
and their accuracy 

Note: You can specify units for 
measuring line width separately 
in the User field of the Units tab. 
• In the Coordinate System 

tab, choose User Coordinate 
System radio button. 

• Choose the UCS axis’s direction 
using one of the five 
corresponding radio buttons. 

• Define UCS parameters – 
origin, skew angle relative to 
Х-axis, and scale. 

Note: You can switch between coordinate systems in the Settings 
toolbar. 
2. Set up the UCS.  This is done either by entering origin and scale or 
by using several known reference points. 

a. Enter origin and scale. 

• press the button  to the right of the Origin field, 

• specify a point with known coordinates on the image, and 

• enter the values of these coordinates to the To field. 
To set scale relative to a specific image: 
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• press the button  to the right of the On Page field, 

• specify a distance (with two  points on the image), 

• set the value in the Actual field, and 

• in the Units tab set Units (linear or angular) with Precision. 
or   
b. Enter origin and scale. 

You can specify the origin relative to another point which 
coordinates are known to you, for example – points with 
known coordinates on a map. In the Advanced tab you can 
set a coordinate system based on several control points 
which coordinates are known. This method allows for your 
image to be referenced to the User Coordinate system you 
need. 

 

• Press the Add point button , then specify a point on 
the image – the coordinate of this point will appear in 
the Source column;  

• Enter the actual (known) coordinates of this point in 
the Destination field; 

• To change a control point select it from the table, 

press the Move point button , and then specify a 
new position for this point in the image; 

• To delete a point press the Delete point button ; 

• Once all points are set press the OK button. 

The Inspector 
Using the Inspector you can view and edit the following information: 
• WiseImage document settings 

See page 4 for detailed information on setting document 
properties. 
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• Properties of selected object(s) 
• Run command parameters 

How to open the Inspector 

Choose Inspector from the Tools menu or press the Inspector 

button, located on the Properties toolbar 
  
  

The Image Manager 
Using the Image Manager you can 
• view all images loaded in the document, 
• get information on image properties and edit some of them, 
• save, delete and create new raster images, 
• turn on/off visibility and lock (unlock) raster images, 
• change the way of storing raster images in the document (in a 

separate file – linked, or in the document file - embedded), and 
• change the page order in a multi-page TIFF file. 

How to open the Image Manager 
 Choose Images from the Tools menu  

 
Or press the Image Manager button located on the 
Properties toolbar  

By pressing the Details button of the Images dialog you will get all 
information on the selected image properties, some of which can be 
edited. 
By pressing the Details button of the Images dialog you will get all 
information on the selected image properties, some of which can be 
edited. 
Important Commands: 

 

To embed a raster image currently saved in a separate file 
into the document, select this image from the Image 
Manager list, and then press the Embedded button 
To save the embedded raster image in a separate file, select 
this image from the Image Manager list, and then press 
either Save or Save as button 

 

To change the page order in the multi-page TIFF file, select 
the image and move it up or down using Move  Up or 
Move Down button 

 

The Layer Manager  
A WiseImage document consists of layers on which all objects are 
placed. Layers have properties (color, line type and line width, font, 
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etc.). Objects can have their own properties or inherit properties from 
the layer on which they are placed. 
Using the Layer Manager you can 
• view and edit information on layer properties, 
• set the current layer – on which new objects will be placed, 
• create new layers and delete existing ones, and  
• turn on/off layer visibility; allows or prevents the selection or 

modification of objects that belong to a certain layer. 
Note: You can only delete a layer if it does not contain any object 
and it is not current. 
How to open Layer Manager 
 Choose Layer from the Tools menu. 

 
Or press the Layer Manager button located on the 
Properties toolbar. 

By pressing Details of the Layers dialog box you get full information 
on the selected layer properties, some of which can be edited. 

The Block Manager  
Using the Block Manager, you can 
• get information on all blocks and their insertions in a document, 
• view blocks in the Preview window, 
• edit block properties (if a block has only one insertion), and 
• save blocks as separate files. 
How to open Block Manager 
 Choose Blocks from the Tools menu  

 
Or press the Blocks Manager button located on the 
Properties toolbar  
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Getting started 
Brief description: This lesson provides you with a basic knowledge 
of WiseImage – opening, saving, file export and import, navigating in 
document, drawing with precision, clipping raster images and 
printing. You will also learn how to create and work with WiseImage 
Сlipbooks. 

Opening Files 
Using the Open command of the File menu you can load 
• WiseImage documents(*.cws), 
• AutoCAD files (*.dwg, *.dxf; including hybrids, which contain 

raster images–only for versions AutoCAD R14 and higher), 
• Raster images (TIF (include Multi-page Tagged Image File); RLC; 

BMP; IPG; IPEG2000; MrSID; PCX; C4; CAL; TG4), and 
Multi-page TIFF files , and 

• Hybrid and vector files (*.ws, *.aws, *.vc5, *.vc4 created by 
earlier versions). 

Note: If you open raster images using the Open command of the 
File menu, then each of them is loaded in a new document. If 
you want to open raster images in the current document, then 
use the Image command of the Insert menu.  
If you need to load several pages from a multi-page TIFF file, 
use the Image command of the Insert menu. You can view 
and load only the desired pages using the Load Page dialog 
box. 

Saving Files 

Saving WiseImage Documents 
• Specify in the Image Manager the way you want to store raster 

images contained in the document – either in separate files or 
embedded in the document file. 

See the section  The Image Manager on page 7 for detailed 
information on the ways to store raster images in the document 
file. 

• Choose Save As from the File menu. Specify the document name, 
choose extension *.cws from the Save as type list. 

Saving document in AutoCAD format 
• Choose Save As from the File menu. Specify the document name, 

choose extension *.dwg (*.dxf) from the Save as type list. 
• Press the Options button and specify AutoCAD version for the 

saved document. 
 
Note:  
If you save data 
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in format of 
AutoCAD R14 
(AutoCAD LT 97) 
versions and 
higher. 

Then the program saves the hybrid 
document, which contains vector objects and 
raster images. 
If the document contains embedded raster 
images, then the program suggests saving 
them in separate files (as AutoCAD hybrid 
document is always linked). 

in format of 
AutoCAD R13  
versions and lower. 

Then the program saves vector data only. 

Saving a raster image 
If you want to save only a raster image, then 
• Open the Image Manager by choosing Images from the Tools 

menu and 
• Select a raster image to save and press the Save or Save As 

button. Specify the image name, format, and additional options for 
the specified format. 

Saving multi-page raster TIFF file 
• Select images to save in multipage raster TIFF file. 

See page 27 for detailed information on raster image selection. 
• Choose Save As from the File menu. Set the file type to Multi-

page TIFF; specify the name and additional options for TIFF 
format. 

Import and Export 
To import a file, choose Import from the File menu. Specify the 
vector file and press Open. 
Table of import formats and imported objects. 

Import format Imported object 

• Microstation format (*.dgn). 
• HPGL/2 format 
• ESRI Shape format 

Vector objects 

• Adobe PDF format Raster Images 
To export in the specified formats: 

• Select data, if you want to export only selected objects. 

See page 26 for detailed information on raster and vector 
selection. 

• Choose Export from the File menu. Specify the name and 
additional options for the specified format. 

• If you want to export only selected objects, then check the 
Selection Only checkbox.  

• Press Save. 
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Table of export formats and exported objects. 
Export format Exported object 

• WiseImage format (*.cws) 
• AutoCAD format (*.dwg, *.dxf) of R14 

(AutoCAD LT 97) versions and higher  

Vector objects 
and/or raster 
images 

• AutoCAD format (*.dwg, *.dxf) of R13 
(AutoCAD LT 95) versions and lower.  

• MapInfo format (*.mid). 
• HPGL/2 format 
• ESRI format 

Vector objects 

• Adobe PDF format Raster Images 

Navigating in a Document 
Navigation tools are designed to help you work within a document. 
You can choose navigation tools from the View menu or from the 
Main toolbar. 

Standard navigation tools 

 Zoom All – displays a whole document. 

 Zoom Previous – returns to the previous display. 

 Zoom Selected – displays selected objects. 

 
Zoom Window – increases a fragment selected with window, to 
full screen size. 

 Zoom In – doubles an image size. 

 Zoom Out – decreases an image size by half. 

 Zoom 1:1 – displays the document in real scale. 

 
Pan – moves a document within program window in specified 
direction. 

 

Zoom Dynamic – turns on the mode in which you can increase 
scale by moving the mouse up and decrease scale by moving the 
mouse down. 

Birds Eye 

 

When working with a large document you can use the overall 
window to display an entire document and the border(s) of 
current views.  

To open the Birds Eye window, choose Birds Eye from the View 
menu. 

Turning on/off visibility of vector object width 
You can toggle the visibility of vector object widths. If turned off, 
then all vector objects are displayed with zero width (i.e. one pixel of 
display resolution). To turn on/off visibility of vector object widths 
choose Show Width of the View menu turned on/off.  



12 

Turning on/off visibility of raster and vector graphics 
For convenient work you can turn toggle the visibility of all vector 
objects or raster images in the document. The buttons are located in 
the View menu and on the Main toolbar. 

 
To turn off (on) the vector visibility press (release) the Hide Vectors 
button   

 
To turn off (on) the raster visibility press (release) the Hide Raster 
button  

Note: With these press buttons the illustrated functionality is on when 
the button is shown as pressed down. 

Changing object display order 
You can change the object display order (vector objects and raster 
images), moving selected objects to front and back, or backward and 
forward. 
Select objects and use the corresponding command from the Display 
Order list of the View menu. 

See page 26 for detailed information on raster and vector 
selection. 

Named views 
You can specify views of different fragments of your document and 
save them with specified names. The program remembers the current 
document scale and position on the screen. 
To create a new named view: 
• Locate a desired image fragment on the screen using the 

navigation tools described above. 
• Enter the view name in the field, located in the right part of the 

Properties toolbar.  
 

 

• Press the  button, located next to the Named new field. 

To delete a named view, select it from the list and press the  
button. 

Precise Drawing Tools 
The following drawing tools are available to aid precise drawing: snap 
to characteristic points of vector and raster objects, polar snap, grid 
display, snap to grip nodes and orthogonal drawing mode. 

 
To turn on/off a tool you can 
use the buttons located in the 



13 

lower-right part of the screen. 

Object Snap 
WiseImage allows you to snap to characteristic points of vector and 
raster objects. Furthermore, you can snap to vector and raster 
objects at the same time. You can also use running snap and snap on 
demand. 
You can choose snap on demand by right-clicking with the Ctrl key 
pressed. 
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Tuning of Object Snap 
Choose Snap Setup from the Tools menu  
In the Snap Setup dialog box: 

• Choose snap option – raster and/or 
vector 

 

• Choose snap type(s) 

 
• Set snap on demand – type of objects 

to snap to. 
If you have not selected any checkbox in 
Snap On Demand, then the program 
will execute snap to the data selected in 
the Object Snap option. 

 

Tuning of Raster Snap  
Note: Raster snap quality is influenced by your image geometry. 
You can tune raster snap using the R2V Conversion Options dialog 
box or Raster Properties toolbar. 
Choose Conversion Options from the Convert menu, and then go 
to the Options tab. 
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Specify the following values: 
 
Max Width – maximum width 
of a raster object. Specify this 
parameter’s value as slightly 
greater than the maximum 
width of the raster line. 
 
Accuracy – parameter 
corresponding to your raster 
image accuracy. Use greater 
values for images of good 
quality and smaller values for 
images of poor quality. 

Polar Snap 
Choose Snap Setup from the Tools 
menu. Select the checkbox in the 
Polar Snap field of the Snap Setup 
dialog box, and then specify angle for 
polar snap. 

 

Grid Snap 
Choose Grid Setup from the Tools menu. 
In the open Grid Setup dialog, specify the grid size in horizontal and 
vertical directions. Select (clear) the checkboxes for display of grid 
and grid nodes. 

Orthogonal Drawing Mode 
You can switch to the orthogonal drawing mode by pressing the 
ORTHO button, located in the lower-right part of the screen. 
Note: The direction for the ORTHO mode is defined in 
correspondence with the document coordinate system axis’s 
direction. 

Image Clip 
You can set a clip area for a raster image. Setting a clip area saves 
computer resources, speeding up command execution and preventing 
modification of the image part located outside of the clip. There are 
two types of clip – rectangular and polygonal. You can set only one 
clip area on the same image. 

How to set or reset clip 
• If there are several images in your document, then select one to 

clip. 

See page 27 for information on raster image selection 
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• Choose Image Clip from the Image menu, and then 
Rectangular (for rectangular clip) or Polygonal (for arbitrary 
shaped clip). 

• To reset the clip choose Image Clip from the menu Image, and 
then Reset. 

WiseImage Clipbooks 
You can store raster, vector and hybrid objects in WiseImage 
Clipbook. You can copy any unit contained in the Clipbook and place 
it anywhere in your document. 
Clipbooks are stored in separate files; their component units can be 
used in different documents. You can open several clipbooks at the 
same time. 
To open a new clipbook choose Clipbook from the Tools menu. 
To open an existing clipbook choose Clipbook from the Tools menu 

and then press the Open button  which is located in the clipbook 
window. Find the file of the desired clipbook, and then press the 
Open button. 
To add a new unit to the clipbook: 

§ Choose raster, vector or hybrid unit 

See the section Selection on page 24 for information on raster, 
vector and hybrid selection methods. 
§ Drag the selected objects to the clipbook 

or copy the selected object using the Copy command of the 
Edit menu or with the Ctrl+C acceleration keys. Then place 
cursor on the clipbook field and right-click; choose Paste from 
the appeared context menu. 

§ To save a new or modified clipbook press the  Save 
or Save as button. 
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Print 
To open the Print dialog, choose Print from the File menu. 

 

• Using the Printer field you can 
select the printing device 
installed on your computer and 
change its current parameters. 

• Using the Area field you can 
specify the print area: the 
whole document or the visible 
document part or rectangular 
window, which can be specified 
on the screen or by corners’ 
coordinates. 

• You can also specify scale, 
margins and paper alignment. 

• Specify the pages to print. 
• You can preview printing 

results on the screen. 
 

Tip: By turning off visibility of layers in the Layer Manager you can 
print only specified layers. 
If raster images and vector objects are located one over another, 
then before printing you should set up raster images visibility in 
Image Manager and the object display order using the Display 
order command of the View menu. 

Note: With these press buttons the illustrated functionality is 
on when the button is shown as pressed down. 
Changing object display order on page 12 for information on 
object display order. 
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WiseImage Objects 
Brief description: This section illustrates the different objects with 
which WiseImage works – raster images and vector objects. The 
operations introduced are the following: Scanning, loading existing 
and creating new raster images; Creating vector objects, assigning 
and editing their properties and Creating user markers and symbols 
for floodfilling. 
WiseImage can simultaneously work with vector objects, raster 
images, and selected fragments of raster and hybrid graphics. 

Raster Images 
You can scan raster images directly from the program, load existing 
images and create new raster images. 

Scanning with WiseImage 
You can scan directly from WiseImage, if you use a scanner provided 
with TWAIN-driver or a CONTEX scanner.  
If several supported scanners are installed, then choose one with the 
Select Source command of the File menu. Then start the Acquire 
command. The displayed dialog depends on the scanner and driver 
version. After scanning is finished, a new document with scanned 
images will be created. 
Note: If you want to scan an image and load it to the current 
document, then use the New Image from Scanner command of the 
Insert menu.  

Inserting Raster Images 
To insert a raster image to a new document, choose Open from the 
File menu. 
To insert a raster image into the current document, choose Image 
from the Insert menu.  

Creating New Raster Images 
You can create a new raster image in the current document. Choose 
New Image from the Insert menu. Specify type, size, resolution 
and other properties for the new image in the New Image dialog. 
Press OK. 

Vector Objects 

Creating Vector Objects 
With WiseImage you can create different types of vector objects. The 
draw vector commands are located in the Draw menu and on the 
Draw toolbar. 
You can specify points (by coordinates), angles and distances when 
you create vector objects on the screen or enter their values in the 
corresponding fields of the Inspector window. While vector objects 
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are being drawn the program status line (on lower-left corner) 
displays tooltips. 

Vector Object Properties 
Every vector object has a set of properties (belonging to a certain 
layer; color, line width and line type; markers, etc.) and geometry; 
which can be specified, viewed and modified in the Inspector. 
• Default properties of newly created vector objects are set 

according to the document’s properties. 

For information on setting document properties see page 4 
• After creation, vector object properties can be changed in the 

Inspector (or the Properties toolbar).  
The next created object inherits the properties of the previous one. 

Note: A created object will have the 
properties of the previously created 
one – if the Document Transparent 
radio button of the Properties mode 
section of the Inspector is on. 

The next created object will have the default document properties, if 
the Command sensitive radio button is chosen. 
Note: The created vector object can inherit properties of the layer, 
on which it is created, if you specify By Layer in the corresponding 
fields. 

See the section The Layer Manager  on page 7 for information on 
layers. 

Note: Vector objects included in a block can inherit the block 
properties, if you specify By Block in the corresponding fields.  

Basic Vector Objects 
The commands used for creating vector objects are located in the 
Draw menu or in the Draw toolbar. 
Point – is created by specifying on the screen or entering its 
coordinates in the corresponding fields of the Inspector  
Line – is created by specifying two points or angle and length 
Arc – is created by specifying three points; or center, start and 
angle, or by center, angle and radius 
Circle – is created by specifying center and radius; or diameter; or 
three points 
Ellipse – is created by specifying center and radiuses; or diameter 
and radius; or elliptic arc 
Elliptic arc - is created by specifying center, radiuses and angles 
Rectangle – is created by specifying three points or two opposite 
corners 
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Polyline 

You can create a polyline, which consists of straight line and arc 
segments. To draw an arc segment press the SHIFT key. To complete 
drawing a polyline choose the command End Polyline from the 
context menu, which appears if you right-click when drawing a 
polyline. The commands of the context menu also allow closing 
polyline and undo the latest drawn segment. 

See the section Editing Vector Polyline on page 35 for 
information on editing polylines. 

Spline 

A spline is defined by a starting point, one or more points for fitting, 
and start and end tangents (vectors which determine the direction of 
splines at the start and end).. You can edit the length and direction of 
tangents in the Inspector (Start Tangent and End Tangent) or using 
‘grips’. 

Hatch  

A hatch is created in a closed 
area, limited by vector entities 
(entity). The program hatches 
inward from the outer boundary. 
If it encounters an internal 
intersection, then it turns off 
hatching until it encounters 
another intersection. 
Thus, areas separated from the outside of the hatched area by an 
odd number of intersections are hatched, and areas separated by 
an even number are not. 
How to create a hatch: Select objects – hatch boundary and 
start the Hatch command of the Draw menu. 
Hatch types:  

    

Hatch Fill Cross Fill Shape Fill Solid Fill 
Hatch Fill and Cross Fill are characterized by line width, step (distance 
between lines) and skew angle. 
Shape Fill is characterized by the shape, distance between shapes (or 
hatch step) and skew angle of lines, along which hatch shapes are 
placed. 
You can set the hatch type in the Inspector. 
Note: A closed vector object (rectangle, circle, closed polyline) can 
have the Fill property.  
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How to fill a closed vector object 
Select a closed vector object and in the Inspector set Fill to True, 
after that you can choose a fill type and properties in the 
corresponding fields that will appear. 

Text 

How to enter text 
Choose the Text command from the Draw menu. Texts are entered 
from the keyboard. The entered text string is completed by pressing 
ENTER. 
The entered text parameters correspond to the default, set up in the 
document. 
You can also edit text parameters in the Inspector or the Font 
dialog. 

 

You can open the Font dialog by 

pressing the  button, which 
appears if you click in the Text Font 
field of the Inspector. 

Multiline Text 

You can create, import and save multiline texts. 
How to create multiline text 
Choose the Multiline Text command from the Draw menu. Enter 
text in the window. Press OK. Insert the text in the document by 
specifying the insertion point. 
How to import multiline text 

Press Load  of the Edit multiline text window. Select and open 
the *.txt text file. Specify an insertion point for this text in the 
document on the screen or in the Base Point field of the Inspector. 
How to export multiline text 
Choose Multiline Text. Open the Edit multiline text dialog. Press the 

Save  button. 

Text Styles  

You can create a new text style or edit an existing one. For this 
choose the Text Style command from the Tools menu. In the Text 
Style dialog:  

• Select a style you want to edit from the combo-box. 

• Press the New button to create a new style. 

• In the Name field set a name for the style you create. 
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• Enter the values of the following parameters or select them 
from the corresponding pull-down lists:  

Text Font 

Text Height 

Text Width Factor 

 Text Oblique (deviation from 90°).   

Dimensions 

 

With WiseImage you can create the 
following dimensions: linear – vertical, 
horizontal and aligned; angular, radial 
and diametric  

You can create a dimension object to specify distance and angle, 
radius and diameter of vector and raster objects. 

How to create dimensions 

Method 1 
1. Select an object to create dimension. 
2. Choose a corresponding button in the Dimension toolbar. 
3. You can tune the dimension parameters in the Inspector – while 

a rubber line for specifying dimension position is displayed. 
4. Specify the dimension position on the screen by left-mouse click. 
5. If necessary, then edit the position of dimension lines and text 

using grips. 
Method 2 
(You can use this method to specify all dimensions except angular 
dimensions between two lines.) 
1. Choose the corresponding button from the Dimension toolbar. 
2. Follow below the instructions in the table: 
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For 
Dimension: 

Specify on 
screen by click:  

Specify on screen 
by click: 

Linear – 
Vertical, 
Horizontal and 
Aligned 

Two points to 
measure distance 
between them 

Dimension line 
position  

Angular 
Vertex angle and 
its two sides 

Angle – outer or 
inner and 
dimension arc 
position 

Radial and 
Diametric 

Arc center or 
circle center E
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Point on the arc 
(circle)  

Tip: When specifying points you can use object snap to raster and 
vector objects. 

See page 13 for information on object snap 
3. If needed, then edit the position of dimension lines and text by 

using the grips. 

Blocks 

Block – is a named group of vector objects (block definition). 
An unlimited number of blocks can be inserted in the document. 
When inserting, you can rotate a block and change its scale. The 
program supports unlimited block nesting (However, a block can not 
include itself.). When exploded, a block is broken into its component 
objects. If you want to change all block insertion in the document, 
then create a new block definition with the same name. 
How to create a block 
• Open the Inspector toolbar. 
• Select vector objects. 

See page 26 for information on vector selection 
• Choose Create Block from the Draw menu. 
• Enter a name for the block in the Block Name field of the 

Inspector. 
• Enter the insertion point coordinates in the Base Point field or 

specify it on the screen. 
How to insert block 
• Choose Block from the Insert menu. 
• Open the Inspector. Choose the block name from Block Name 

list of the Inspector. 
• Enter the insertion point coordinates in the Base Point field or 

specify them on the screen. 
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Creating User Markers 

You can create your own markers, which will be placed on the 
endpoints of such vector objects as lines, arcs and polylines. 
How to create a new marker 
• Draw a marker of the desired shape. You can fill it with solid 

floodfill. 
• Select the marker’s elements. 
• Choose the Create Marker command from the Tools menu. 

• Press the button  in the open dialog box and specify a point to 
connect the marker to the line. 

• Specify a name for the marker and save it by pressing Save or 
Save As button. 

• The created marker appears in the lists of Start Marker and 
End Marker of the Inspector. It can be assigned to selected or 
created vector objects. 

Creating shapes for floodfilling 

You can create your own shape to floodfill closed vector objects or 
Hatch objects. 
How to create a symbol for floodfilling 
• Draw a shape for floodfilling. You can use solid floodfill to fill it. 
• Select the shape. 
• Choose the Create Fill Shape command from the Tools menu. 
• Save the shape with name using Save or Save As button. 
• The created shape appears in the Hatch Shape of the Inspector. 

You can select it from the list when creating hatch or Shape Fill. 

Raster Drawing Mode 
The Raster drawing mode enables you to draw raster representations 
of vector objects.  

 

To turn on the raster drawing 
mode choose the RDRAW button, 
located in the right-lower screen 
corner. 

IMPORTANT: There should be a raster image under the objects that 
you draw in raster drawing mode; otherwise the created objects will 
disappear. 
 



24 

Selection 
Brief description: To perform different operations – such as edit, 
modify an object’s properties with the Inspector, and others – you 
need to select data to apply commands to. In this section we consider 
raster and vector data selection technology. You will learn about 
different selection modes, methods of data selection, and tuning of 
raster selection. 
You can select raster, vector and hybrid (both raster and vector) data 
in WiseImage. Selection technology and data selection methods for 
all data types are extremely close to vector object selection 
technology. WiseImage allows selection of the following data and 
their combinations: 
• Vector objects (raster images are included) 
• Raster data: 

§ Raster objects (raster lines, arcs, circles, selected with object 
selection methods, which have ‘grips’, properties and precise 
geometry). 

§ Area fragments of the raster image. 
§ Selected with window or polygon.  
§ Raster line segments of arbitrary shape. (A segment 

represents part of a raster line of arbitrary shape, 
limited by points of intersection with other raster lines 
or endpoints). 

§ Isolated raster fragments. 
• Hybrid data (both raster and vector data selected). 

You can use the Selection, More Selection and WiseObject 
Selection toolbars to select data. 
When selecting data, you need to define three parameters: 
• Type of data to select– raster, vector or hybrid 

See the section Type of data selected on page 25. 
• Selection modes – add to selection, remove from selection, 

single selection. 

See the section Selection modes on page 25. 
• Selection method – by picking, within window, crossing polygon 

and others. 

See the section Selection methods on page 26. 

 

 

 

 



25 

 Type of data selected Selection mode 

 

S
e
le

ct
in

g
 r

a
st

e
r 

im
a
g
e
s 

fr
o
m

 
th

e
 l
is

t 

S
e
le

ct
 b

y
 f

ilt
e
r 

P
o
ly

lin
e
 

e
d
it
in

g
 

m
o
d
e
 

V
e
ct

o
r 

se
le

ct
io

n
 

R
a
s
te

r 
se

le
ct

io
n
 

H
y
b

ri
d
 

se
le

ct
io

n
 

R
a
s
te

r 
a
re

a
 

se
le

ct
io

n
 

A
d
d
 t

o
 s

e
le

ct
io

n
 

R
e
m

o
v
e
 

fr
o
m

 
se

le
ct

io
n
 

S
in

g
le

 s
e
le

ct
io

n
 

S
e
le

ct
 

A
ll 

(d
e
p
e
n
d
a
b
le

 
o
n
 

se
le

ct
io

n
 m

o
d
e
) 

D
e
se

le
ct

 

Table 1. Type of data selected, selection modes 

Type of data selected 
You need to define the type of data to select (raster, vector or 
hybrid) by pressing the corresponding button on the Select toolbar. 

 
To select vector objects and raster images, choose 
Vector Selection 

 To select raster data, choose Raster Selection  

 To select hybrid data, choose Hybrid Selection 

Selection modes 

 New data is added to selection 

 Selected data is removed from selection 

 Every new selection deselects previously selected data 

  
Selects all vector objects in WiseImage document (except 
raster images) 

 
Selects the contents of all raster image in WiseImage 
document 

 
 

Selects all objects in WiseImage document (raster images 
are included). 

 
To deselect all selected data choose Deselect All 
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Raster Selection Methods 
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Table 2. Selection methods 
 

Object selection methods of vector and raster data  
You can select vector and raster objects (raster lines, arcs, circles) 
using object selection methods (green buttons): 

You can also select raster objects by reference objects: 

 

raster line or its 
segment by 2 
points 

 

raster arc or its 
fragment by 3 
points 

 

raster circle 
by two 
points  

 
By Picking 
(Auto)  

By Crossing a 
Window 

 
Within a Window 

 
By Crossing a 
Polygon 

 
Within a Polygon 

 
By Fence  
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How to obtain the raster area selection using object selection 
methods 

Tip: If you need to obtain an area selection 
when selecting raster objects, then press 

Raster Area Selection , located on the 
Select toolbar.  
It is convenient to select raster areas of irregular shape using the 
following selection methods:  

 

Brush Selection  

 

 

Contour Selection 

 

 

Raster Image Selection 
If you need to select the raster image, then specify (cross) its frame 
by choosing vector (hybrid) type of data selection. 
If the document contains several raster 
images and you need to select some of them, 
then use Select Raster on the Select toolbar. 

 
Choose Select Image  button, located 
on the Select toolbar. 

• Select desired raster images from the list. 
• Close the Select Raster window.  

Selecting raster area fragments 

Selecting inside rectangle or polygon 
You can select rectangular or polygonal fragments of the raster image 
area using Select by Rectangle or Select by Polygon button, 
located on the Select toolbar. You can select: 

 

rectangular 
fragment of raster 
image 

 

polygonal 
fragment of raster 
image 

Selecting raster segments 
Segment represents part of a raster line of arbitrary shape, limited 
by intersection points with other raster lines or endpoints. 
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You can select raster line segments (blue buttons): 

 
Within a 
window  

By crossing a 
window 

 
Within a 
polygon  

By crossing a 
polygon 

  
 

By fence  

Selecting isolated raster fragments 
You can select isolated raster objects (red buttons): 

 
By picking 

 
By crossing a 
window  

 
Within a 
window   

By crossing a 
polygon  

 
Within a 
polygon  

By fence  

Tuning of raster selection 
You need to tune the geometry of raster data to obtain the best 
results when selecting raster objects and raster segments.                     
How to tune raster selection. 
The selection geometry is tuned using the R2V Conversion Options 
dialog or Raster Properties toolbar. To open this dialog, choose 
Conversion Options from the Convert menu. 
Specify the following values in the Options tab: 

 

 

Max. Width – maximum width of 
raster object to select. Specify this 
parameter’s value as slightly 
greater than maximum width of 
raster objects or raster line 
segments. 
 
Max. Break – length of ignored 
break in raster lines. 
 
Accuracy – your document 
accuracy. For example, if when 
selecting a raster circle by picking, 
the program only selects its 
fragments (arc), reduce the 
accuracy value.  
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Filter for data selection 
You can select data, grouping them by type, color, and layer.  

 
To select a group of objects, choose Select Objects with Filters  
button on the Select toolbar. 

 

• Select a desired object type from 
the Type list 

Note: Type includes only those types 
of objects, which are contained in the 
document. 
• You can group objects of a selected 

type by color and layer. 

WiseObject Selection 
The brand new selection engine, called WiseObject selection tool 
added with its new toolbar. This tool allows you to select all text 
areas and hatches as well as speckles and linear objects with the new 
advanced method. 

You can select hatches, linear 
objects, text areas and speckles 

 

 
All the indicated objects in the current image will be selected  

 
You can select the indicated objects within window 

 
You can select the indicated objects within polygon 
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Editing WiseImage objects 
Brief description: In this section you will learn different methods of 
editing selected data – raster, vector and hybrid, and also the 
commands designed for editing raster images and vector objects, 
including vector polylines. 

Editing data, selected with object selection methods 
If you select data with the object selection methods, then you can 
view and edit the properties and geometry of selected objects using  
the Inspector: 
 

  

Selected raster 
object 

Modified raster 
object 
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• change the geometry of raster and vector objects and also the 

location of selected objects on screen using ‘grips’, and 
• apply the following edit commands to selected objects. 

The commands are located in the Modify and Correct menus. 

Edit commands: You need to specify: 

 
Move 

• Shift – by 2 points on the screen or in the 
Shift field of the Inspector. 

 
Copy 

• A number of copies – in Copy field of the 
Inspector. 

• Distance between copies – by 2 points on the 
screen or in the Shift field of the Inspector. 

 
Duplicate  

 
Rotate 

• A number of copies– in the Copy field of the 
Inspector. 
Specify ‘0’ to set no copies.  

• Rotation center (if it differs from the 
selection geometric center) and rotation 
angle –on the screen or enter the values in 
the corresponding fields of the Inspector. 
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Scale 

• A number of copies– in the Copy field of the 
Inspector. Specify ‘0’ to set no copies. 

• A base point by which to scale (if it differs 
from the selection geometric center). 

• Scale factor – in the Scale field of the 
Inspector or specify a base distance and 
desired distance on the screen.  Distances 
are specified between the base and 
reference points. 

 
Mirror 

• A number of copies– in the Copy field of the 
Inspector. 
Specify ‘1’ to keep the original object, ‘0’ – 
to delete it. 

• Mirror line – directly on the screen or by 
specifying the first point and angle for the 
mirror line in the corresponding fields of the 
Inspector. 

 
Flip 
Horizontal 

 

 
Flip Vertical  

 
Align 

• A number of copies– in the Copy field of the 
Inspector. 
Specify ‘1’ to keep the original object, ‘0’ – 
to delete it. 

• The first source and destination points. 
• The second source and destination points. 

Array 

• A number of Rows и Columns in the 
corresponding fields of the Inspector. 

• The angle of array rotation relative to the X-
axe in the Inspector or on the screen (if 
needed). 

• The distance between Rows and Columns – 
in the corresponding field of the Inspector 
or directly on the screen. 

 
Duplicate by 
vector 

• A number of copies– in the Copy field of the 
Inspector.  

• The insertion point for the duplicated object 
(if it differs from the selection geometric 
center). 

• The vector object along which copies will be 
placed – on the screen. 

Edit commands: Executive order: 
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Correct to 
intersection 

• Select objects to edit, and then start the 
command. 

• Move cursor to a pair of vector objects. If 
you are satisfied with the rubber line 
position, press the left mouse button. 

 
Offset 

• Offset Distance in the corresponding field of 
the Inspector toolbar.  

• Offset position (inside or outside) – on the 
screen  

 
Create 
Chamber 

• Select objects to edit, and then start the 
command. 

• Choose the way to create Chamber in the 
Inspector– by either two distances or one 
distance and angle. 

• Enter the command parameters (distances, 
angle) in the corresponding fields of the 
Inspector. 

• Moving cursor, choose the right position for 
the rubber line and press the left mouse 
button. 

 
Create Fillet 

• Select objects to edit, and then start the 
command. 

• Specify a radius for the Fillet in the 
corresponding field of the Inspector  

• Moving the cursor, choose the right position 
for the rubber line and press the left mouse 
button.  

 
Align Angle 
and Distance 

• Select objects to edit, and then start the 
command. Set in Inspector. 

To align angles between the lines: 
§ AutoResizing – FALSE, Distance – ‘0’ 

To align angles and specify a distance between 
the lines: 

§ AutoResizing – FALSE, enter a desired 
value in the Distance field 

To align angles and distance between the 
lines: 

§ AutoResizing – TRUE 
• Move the cursor to the line, relative to which 

you want to align the others. If you are 
satisfied with the rubber lines position, press 
the left mouse button. 
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Editing vector objects 

Trim, extend, break vectors 
You can use the following objects as a cutting edge – for trimming, 
extending, or breaking vector objects: 
• A vector or raster object 
• A pre-defined Edge. 
In case you use a vector or raster object as cutting edge: 
1. Select the object(s)you want to use as cutting edge. 
2. Choose the command – trim, extend or break from the Correct 

menu or on the Vector Correction toolbar. 
3. Specify the vector objects one by one to apply the command to. 
In case you use pre-defined Edge as cutting edge: 
1. Define Edge: 

• Select vector objects to form Edge.  
• Choose Group/Ungroup Edge command from the Correct 

menu. 
2. Select vector objects to edit 
3. Choose the command – trim, extend or break from the Correct 

menu or on the Vector Correction toolbar. 

Editing Raster Images 
The commands in the Image menu are designed for editing raster 
images. 
The commands from the Image menu modify the raster image 
contents – resolution, real size, size in pixels, points’ positions. 
Unlike the commands of the Image menu, the commands of the 
Modify menu do not change the raster image contents. For example: 
• The Scale command of the Modify menu only changes the scale of 

raster display in the document; the raster image contents 
(resolution, number of points and location), is the same. 

• Using the Scale field of the Resample dialog box, you can modify 
the raster image contents – resolution and/or the number of points 
the image is composed of. 

Change Image Size 
Choose Change Size from the Image menu. 
Using the Change Size dialog box you can: 
• Change the image size to the desired format. 

§ Choose the desired format from the list of Standard Paper 
Size. Set the orientation – Portrait or Landscape. 
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• Change the image size to the closest standard format.  
§ Press the Find Closest button. 

You can edit the list of standard formats using the Preferences 
dialog box. See the section Customizing Program Parameters on 
page 73. 

• Add (cut) image margins.  
§ Specify values to add (cut) margins in the 

Alignment/Margins section. 
You can also align the image position relative to its margins by 
• Using one of the nine buttons of the Alignment/Margins field or 
• Entering the margins values in the Alignment/Margins section 

with the Fixed Size checkbox selected. 

Resample 
Choose Resample dialog from the Image menu. Using the 
Resample dialog you can: 
• Proportionally change the image size with fixed resolution. 

§ Choose measurement units from the list; you can choose 
pixels as measurement units. 

§ Enter the new values in the Width and Height fields. 
§ The Fixed size in pixels checkbox is off (unchecked). 

• Change the image size according to specified Scale value with fixed 
resolution. 
§ Enter the new scale value to the corresponding field.  
§ The Fixed size in pixels checkbox is off. 

• Change the image resolution with fixed size. 
§ Enter the new resolution value to the corresponding field. 
§ The Fixed size in pixels checkbox is off. 

• Change the image resolution (size) with fixed number of pixels. 
§ Select the Fixed size in pixels checkbox. 
§ Enter the new resolution (size, scale) value. 

Cropping Image 
Cropping commands are located in the Crop submenu of the Image 
menu. 
You can 
• crop blank margins of the raster image, 
• crop the raster image by its frame, 
• crop the raster image by a rectangle specified on the screen, and 
• crop the raster image by pre-defined clip. 
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Rotate and mirror 
These commands located in the Image menu, allow you to rotate an 
image by 900, 1800, 2700, or by an arbitrary angle; and also mirror 
an image about the X-axis or the Y-axis. 

The other commands for editing raster images are provided in 
the section Enhancing Scanned Images on page 36. 

Editing Vector Polyline 
The polyline editing commands are located on the Edit Polyline 
toolbar, and also in the contextual (right-button) menu. Select a 
polyline to edit. 
You can apply the following commands: 

 
Close a polyline by joining end nodes 

 
Close a polyline with a new segment, which connects end 
nodes 

 
Add a new vertex at a specified point 

 
Break a polyline at a specified point or node 

 

Note: The following operation requires the selection of 
polyline nodes. For this, you need to press the 
Node Selection button of the Select toolbar.  
Now you can select polyline nodes by mouse click. 

 
To delete a polyline node, select it and press the Delete 
node button 

 
by connecting specified end nodes with linear 
segment 

 
by connecting specified end nodes with arc 
segment 
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by joining specified end nodes 

 

Transform a specified arc segment to a linear segment  
To specify a segment, click on its first node; nodes are 
numerated from the polyline start. 

 

Transform a specified linear segment to an arc 
 To specify a segment, click on its first node; nodes are 
numerated from the polyline start. 
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Enhancing Scanned Images 
Brief description: This section demonstrates ways of enhancing 
scanned monochrome images – deskewing, filtering, and eliminating 
distortions using calibration and four-point correction. Also, we give 
you some recommendations about restoring poor quality images. 

Deskewing 
When paper is fed through a scanner the direction of the paper often 
deviates from the orthogonal; therefore, the resulting scanned image 
is often skewed (sometimes considerably). 
The special command – Deskew is used to deskew an image.  
The command works in two modes: 
1. Auto Deskewing – program automatically estimates the skew 

value, and then performs deskewing. 
Choose Deskew from the Image menu, and then –Auto 

2. Manual Deskewing – you can use this mode, if the result of 
Auto Deskewing is not satisfactory. 
In this mode you can specify a skew angle by specifying a line, 
which must be horizontal or vertical. 
Choose Deskew from the Image menu, and then –Manual. 

  

Press the 
Measure Angle 
button in the 
displayed dialog, 
and then specify 
the deskew line 
with two points. 
You can use snap 
tools during this 
operation. 

Manual deskewing After deskewing 

Filtering Monochrome Images 
There are a number of different filters available within WiseImage, 
which allow you to considerably enhance the scanned monochrome 
raster image. You can apply filters to the whole image or to a 
fragment. You can also apply filters to several raster images 
simultaneously. 
Using the filters, you can 
• remove raster speckles, 
• remove holes (white points in black raster lines or filling), 
• invert images, 
• smooth raster objects, 
• thin and thicken raster objects, and 
• transform filled raster area to one-pixel contour 
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All commands for filtering monochrome images are located in the 
Filters menu. 

Speckle Remover 
Choose Speckle Remover from the Filters menu. 
You can specify the size of raster speckle on the screen using the 
measure buttons of the Speckle Remover dialog.  

  

If the Auto 
Estimating 
checkbox is on, 
then the program 
automatically 
estimates the 
speckle size. You 
can apply the filter 
several times. 

Before applying 
Speckle Remover  

The result of applying 
Speckle Remover 

When applying the filter to the image of very poor quality some data 
may be lost. To avoid it, you can use the operation of Separation by 
size. 

See page 39 for information on separation by size in a 
monochrome image. 

Hole Remover 
Choose Hole Remover from the Filters menu. 
You can specify the size of raster speckle to remove on the screen 
using the measure buttons of the Hole Remover dialog box. 

 

If the Auto Estimating 
checkbox is on, then the 
program automatically 
estimates the speckle 
size. Before applying 

Hole Remover 
The result of applying 
Hole Remover 

Inversion 
Choose Inversion from the Filters menu  

  

This filter reverses 
the color of the 
monochrome image: 
After applying this 
filter the background 
dots become the 
image dots and vice 
versa. Before applying 

Inversion 
The result of applying 
Inversion 

Smoothing 
Choose Smoothing from the Filters menu  
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This filter smoothes 
raster object 
outlines, fills edge 
and inner 
background droplets, 
and partially 
removes raster 
speckles. 

Before applying 
Smoothing 

The result of applying 
Smoothing 

 
Tuning of the Smoothing filter  

The Smoothing filter is 
tuned by setting optimal 
values of Medianning and 
Threshold. You can 
estimate the result before 
applying the filter in the 
preview window. 

Thinning and Thickening filters 
Choose Thinning (Thickening) from the Filters menu.  

  

Thinning filter makes 
raster objects thinner 
in the specified 
directions; by one 
pixel for each pass. 
You can specify a 
number of passes.  

Before applying 
Thinning 

The result of applying 
Thinning 

If needed, then you can apply the mode of thinning raster objects up 
to skeleton – i.e. only pixels in the middle are left.   
The Thickening filter makes raster objects thicker in the specified 
directions. You can specify a number of passes and choose any 
combination of thickening directions. 

Contour (4-coupling and 8- coupling) 
Choose Contour from the Filters menu 
Contour filters convert filled raster areas to one-pixel contours. 
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Before applying Contour  The result of applying Contour  

Separating Monochrome Images by Size 
This operation is effective in the following two cases: 
• Some small objects (dots in dashed-dotted lines, other multiple 

small fragments in lines, delimiters, etc.) are not speckles . 
• The image is of very poor quality. 
The principle of the separation by size operation differs only from 
speckle removing in that speckles are not removed but transferred to 
a new raster layer. From there the user can move incorrectly selected 
fragments back to the drawing. 
. 
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The significant elements have 
been brought back from the 
‘speckle’ layer to the basic layer; 
the ‘speckle’ layer is removed 

Eliminating linear and non-linear distortions using calibration 
Calibration – is applied to eliminate arbitrary (both linear and non-
linear) distortions of monochrome, grey-scale and color raster 
images. 
Important tip: You should calibrate the raster image before 
vectorization (tracing), because if you vectorize a distorted image you 
will obtain distorted vector data that is impossible to correct later. 
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Calibration terms 
The original image must contain points with known coordinates. 
These points are called real points. You can use nodes of a 
rectangular grid as real points (if you work with mapping materials) 
and/or other points whose coordinates are known or can be 
calculated. The points, which correspond to the real ones on the 
distorted image, are often located with some displacement (i.e. they 
have different coordinates). These points are called measured points 
as their coordinates value can be measured on the raster image. By 
applying calibration, the raster image is transformed so that the 
measured points coincide with, or are extremely close to the real 
points. 
Tip: Before applying calibration you should set the User Coordinate 
System by specifying its origin and scale. 

See the section Document Coordinate System on page 5 for 
information on setting User Coordinate System. 

How to calibrate an image 
Choose Calibration from the Image menu. 
Step 1. Defining real points 
We can define rectangular grid nodes and points with known 
(estimated) coordinates. 
Defining grid: Grid is defined by the three parameters: start point 
(coordinates of lower-left node), cell size (by X and Y axis), and grid 
size (by X and Y axis). 

• Press Define Grid  on the Calibration toolbar. In the 
Calibration Grid dialog: 

• Specify the coordinates of the lower-left grid node in Origin. 
You can enter the coordinate values of the lower-left grid corner 
in the corresponding field or specify it with the cursor on screen. 

• Enter the number of grid cells along the X and the Y axis in Size 
field. 

• Enter the cell size along X and Y axis in Cell field. 
• If the grid is rotated about the coordinate axis, then enter the 

skew angle relative to X-axis in Angle field. 
Tip: Use the Preview button to make sure that the grid is properly 
specified. 
Specifying points with known coordinates 

• Press Add point  button from the Calibration dialog. Enter the 
point’s known coordinates in Real field (use separating character 
between X and Y values). 
You can enter a name for the point in Label field; alternatively the 
program numbers the points consecutively. 

• Do the same for all points. 
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Step 2. Specifying measured points 

To begin step 2 you can press Next Point . WiseImage places 
the first point from the list in the screen center and highlights it with 
grips. 

  
You see the real (correct) 
coordinates of the first point 
with grips. 

Drag grips to the grid node on 
the scanned image – so you 
specify the ‘measured’ point. 

To shift to the next (previous) point, use Next (Previous) point. 
You can also use the acceleration keys: N (Next) or Tab – to shift to 
the next point and P (Previous) – to the previous. 
Step 3. Choosing calibration method 
Choose the optimal method from the pull-down list of 
Calibration Method field. 

 

What method to choose? 
• If you are sure of the proper method, 

choose it from the list. Estimate the 
accuracy of this method by pressing 

Estimate  button. 
• If you are not sure of the proper method, 

select Choose automatically from the 
combo-box of the calibration method.  

Step 4. Running Calibration 
• Note: If you have several raster images in your document, then 

select one(s) that need calibrating using the specified set of 
calibration pairs. 

See page 27 for information on raster image selection. 
• Run the calibration by pressing the Apply button. 

Four-Point Correction 
You can use this operation for quick correction of scanned technical 
drawings, which contain a frame. This operation assumes that both 
frame and contents of the image have the same distortion. 
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How to correct an image by 4 points 

• Note: If you have several raster images in your document, then 
select the one to calibrate by four points. 

See page 27 for information on raster image selection. 
• Choose 4 point correction from the Image menu. 
• Enter the frame size in the Width and Height fields of the 4 point 

correction dialog. 
You can also choose a standard frame size from the list of Frame 
Size or find the closest by pressing Find Closest paper. 

• Press Find Frame  – the program finds and highlights the 
image frame. 
If the frame is defined correctly, then 
§ press OK. 
Otherwise, : 

§ press Measure frame  button, and then specify four 
points of the frame on the screen and then 

§ press OK. 

Autocorrecting Image 
Autocorrect runs a set of predefined operations. 
How to apply autocorrection 

 

• Choose Preferences from the Tools 
menu.  

• Specify a set of commands to apply 
with autocorrection using the 
Preferences dialog. Close 
Preferences. 

• If you have several raster images in 
your document, then select the one(s) 
to apply autocorrection to. 

See information on raster image 
selection on page 27. 

• Choose AutoCorrect from the Image 
menu. 

Note: The parameters of the commands included in the 
autocorrection list (except Rotate) are automatically defined. For 
example, deskewing with auto definition of rotation angle, removing 
speckles with auto definition of speckle size, etc. If you want to 
specify the parameters of executed commands precisely, then use the 
batch process. 

See information on batch process on page 70. 
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Editing raster text 
You can edit raster texts –original text under the defined rectangle is 
erased and replaced with new text. 
• From the Draw menu, choose Raster and then Edit Raster text. 
• Draw a frame over the text to be modified. 

While drawing, you can specify the frame angle in the 
corresponding field of the Inspector.  

• Enter new text in the Text field of the Inspector. 
You can set text parameters in the corresponding fields of the 
Inspector. 

   
Original raster text Selected text area After editing 

Restoring Images of Poor Quality 

How to work with a raster image of very poor quality. 
There is not much choice – either redraw it in the document with the 
corresponding program, or restore it with a hybrid editor 
(Vectorization of such a document produces poor results.).  
The purpose of this section is not to discuss the plus and minus points 
of these choices, but to provide you with some methods to restore 
scanned documents of poor quality. 
• Separating an image by size – can be used for blueprints, images 

on dark backgrounds, with lots of speckles. 

Information on separating image by size is provided on page 39. 
• Editing selected raster objects (modifying their properties, 

geometry using «grips» and others.) 

Information on editing selection is provided on page 30. 
• Tracing in smooth mode. 
• Tracing in vector producing mode. Editing and rasterizing the 

obtained vector object. 

Information on tracing is provided on page 57. 
• Drawing missing raster lines in Raster drawing mode. 

Information on Raster drawing mode is provided on page 23. 

• Editing raster texts 

Information on editing raster texts is provided on page 43. 
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Example of restoring an image  

 

Original image fragment 

 

Choosing and editing the axial 
line 

 

Result of editing the axe line 

 

Tracing the curve in smooth 
mode 

 

Hatch on the original raster 
image 

 

Tracing the hatch in Create 
Vector and Erase Raster mode 

 

Rasterizing the vector hatch 

Then you can apply the following actions: 
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Edited raster image Selecting the whole raster image 
(or fragment) 

  

Deleting isolated raster fragments 
from the selection  

Removing speckles that were not 
selected. 
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Editing color images 
Brief description: This lesson is devoted to methods of enhancing 
color and grayscale raster images – correcting image brightness, 
contrast, hue, and saturation; correction by histogram, and filtration. 
You will also learn about converting images to RGB, 8-bit indexed and 
grayscale; layering color and grayscale images to monochrome 
layers. 

Correcting image brightness, contrast, hue, and 
saturation 

You can tune brightness, contrast, hue and saturation of color and 
grayscale images. 
Choose Brightness/Contrast from the Image menu. 
Using Brightness/Contrast dialog, you can tune: 
• Brightness of color and grayscale image 
• Contrast of color and grayscale image 
• Hue of color image 
• Saturation of color image 
You can tune the parameter’s value using the sliders or entering the 
values in the corresponding fields. 

Correction by histogram 
Using correction by histogram you can tune the image brightness, 
hue and contrast. You can apply automatic correction by histogram or 
tune the parameters manually. 
Choose Equalize from the Image menu. 
To correct an image by histogram automatically, press the Auto 
button of the Equalize dialog.  
To correct an image manually you need to specify three values: 
lightest and darkest levels, and image gamma – for each channel or 
for Master channel. 

The darkest level (the left slider 
position) is set using the dark 

eyedropper , using which you can 
specify the colors to turn black. All pixels 
included in the histogram area from 0 to 
the left slider, will turn black. 
The lightest level is set using the light 

eyedropper , using which you can 
specify the colors to turn white. 
All pixels included in the histogram area 
from the right slider to 256, will turn 
white. 
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• Using the middle slider, specify the value of image gamma. 
Moving the middle slider to the left increases the gamma value; the 
image becomes lighter. Moving the middle slider to the right reduces 
the gamma value; the image becomes darker. 
• When you achieve satisfactory results in the Preview window, press 

the Apply button. 

Color Filters 

Blur 
This filter produces a blur effect on an image. For example, you can 
apply the Blur filter to an image which has texture fills. 
Choose Blur from the Filters menu. 

 

• Set Radius for the filter. 
Increasing the radius value also 
increases image blurring. To 
modify the ‘Radius’ value use the 
slider or enter the value in the 
field. 

• When you achieve satisfactory 
results in the Preview window, 
press the Apply button. 

Unsharp Mask 
This filter is designed to increase the sharpness of color boundaries, 
producing an overall increase of image sharpness. For example, this 
filter can be used to correct images that became blurred after 
interpolation – e.g., after such operations as rotate, scale, alignment, 
calibration or four-point calibration, and also resize and resample. 
Choose Unsharp Mask from the Filters menu. 

 

Set Radius – ‘level’ of the filter 
effect. Increasing the radius 
value increases the number of 
pixels surrounding the color 
boundary that are to be 
processed. Applying small 
Radius values results in an 
increase of sharpness only on 
color boundaries. 

• Set Sensitivity for the filter 
using the slider or enter the 
value in the corresponding 
field. Increasing this value 
provides a stronger effect. 

• When you achieve satisfactory results in the Preview window, press 
the Apply button. 
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Median 
This filter reduces image noise, analyzing all pixels within the 
specified radius and assigning the central pixel the averaged value of 
reviewed pixels. As a result, pixel color and brightness are evened. 
For example, Median filter can be used to eliminate image ‘grain’. 

 

Choose Median from the Filters 
menu. 
• Set Radius for the filter – area 

within which color values are 
to be analyzed.  

• When you achieve satisfactory 
results in the Preview window, 
press the Apply button. 

Convert to RGB, greyscale, 8-bit indexed 

Convert to RGB (greyscale) 
• If your document contains several raster images, then select the 

one(s) to convert to RGB (greyscale). 
• From the Image menu, choose Convert to, and then Convert to 

RGB (Convert to greyscale) 

Convert to Indexed colors 
You can convert full-color images (24 bits per pixel) and monochrome 
images to 8-bit-indexed (8 bits per pixel). This operation can be used 
to reduce the size of a full-color file, and therefore speed up working 
with it. Note that in some cases the converted image might have 
lower quality due to some information loss. 

• If your document contains several raster images, then select the 
one(s) to convert to 8-bit indexed. 

• From the Image menu, choose Convert to, and then Convert to 
Indexed colors. 

 Execution order 

Calculating the 
optimal palette 
for the selected 
image(s) 

• Press Set auto palette . 

Recalculating of 
palette for 
specified color 
number 

• Specify the color number in the Colors 

 field. 

• Press the Reset Palette  button. 
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Selecting colors 
from the palette 

• Press Shift, select colors from the palette by 
clicking on them (If only selecting one color, 
then there is no need to press Shift). 

Note: Select the Light Paint checkbox 

 button to view selected colors in 
the Preview window. 

Merging selected 
colors  • Press Merge Colors  button 

Deleting selected 
colors  • Press Delete Colors  button 

Changing 
selected color(s)  

To Change selected color(s) 
• to the specified color– Press Get color to set 

 and choose a desired color from the Color 
box.  

• to one color of the image – press the button 

with eyedropper , and then specify a 
desired color on the screen. 

Adding color(s) 
to the palette 

• Enter desired number of colors in the Colors 
field. 

• Press Set auto palette  
  – or  – 

    Click on a blank palette cell. 
• Click on the added field, and assign the color 

as described above in section Changing 
selected color(s). 

Separating color and grayscale images to 
monochrome layers 

This section describes the operation of separating color or grayscale 
raster images to monochrome layers. 
Binarization allows you to extract pixels of specified colors (or close to 
them) to a monochrome layer. For example, when you binarize a 
map, first you get a monochrome layer that contains isolines; then a 
layer that contains roads, etc. 
Color Separation allows you to separate a color or grayscale image to 
several monochrome layers with a single operation; each image pixel 
is transferred to one of the resulting monochrome layers. 

Binarization 
Using binarization you need to specify the color range(s) for a created 
layer, e.g., for hydrographic layer – from light-blue to dark-blue.  
• Choose Binarization from the Image menu. 
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• Choose binarization method – Range or Threshold. Set the 
parameters for the chosen method (Color model (RGB, HSV, Grey), 
channel (grey, red, green, blue, hue)). 

• Specify a layer and its color to place the new monochrome image 
to. 

• Using one of these eyedroppers  specify the colors on 
the screen; they are added to the list of the Colors list.  
The estimated binarization results are highlighted in the preview 
window. 
You can choose any incorrectly selected color from the colors list, 

and then remove it using the Delete  button. 
• Tune the results using the sliders located in Ranges (Threshold). 
• You can delete small speckles that appear using the slider Noise 

Reduction. 
• When you achieve satisfactory results in the Preview window, press 

Apply. 

Color separation 
To carry out a color separation set color categories (thematic layers), 
by which you want to separate the image, and then set a list of colors 
for each category. 
• Choose Color separation from the Image menu. 
• Specify the first category color on the image using the eyedropper 

Add category . Choose a standard color; specify a name for 
the category in the displayed Category name and color dialog. 

• Using the eyedropper Add color, specify all colors of the image, 
which should fall within this category.  

• Repeat the previous two steps for all categories, which you want to 
set on a new layer. Incorrectly defined categories and colors can 

be selected and deleted from the list using the Delete  button. 
• Using the Noise Reduction slider you can adjust the sensitivity of 

Color separation – smooth contours. 
• Deleting small-sized speckles is executed when the Despeckling 

checkbox is checked. 
• When you achieve satisfactory results in the Preview window, press 

Apply. 

 

Advanced Color Tools 

Color Classifier 
This versatile tool allows you to manage the colors within the image.  
(Note: It is not applicable to monochrome images.) You can reduce the 
palette by deleting the selected color or colors or by merging several 
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colors into one. You can also replace selected colors and add them to 
the palette. 
To open the Color Classifier dialog - choose Color Classifier from the 
Image menu. 

 
The buttons and controls in the Color Classifier dialog window 

 Color 
samples 
table 

This table contains color samples of 
the current palette. Select a color by 
clicking on it. Clicking while holding 
down SHIFT selects multiple colors.  

 
Color counter This control is used to show the 

number of colors in the current 
palette. You can increase or reduce 
this number(2-256). 

 
Set auto 
palette 
button 

By pressing this button you Calculate 
palette automatically. WiseImage 
can automatically determine the 
number of colors.  

 
Recalculate 
palette 
button 

Set colors number in palette to 
counter 

 View 
Selection  

When this box is checked, the points 
of selected colors are shown on the 
image.  

 

Choose a 
color from 
the image 

This tool is used to obtain a color by 
clicking on a pixel in the document 
window. The color of the selected 
pixel will be highlighted in the Color 
samples table. 



52 

 

Select colors 
from the 
image 

This tool is used to obtain colors by 
drawing a polygon around an area in 
the document window. Double-click 
to finish the polygon. The colors 
contained within the polygon will be 
selected in the Color samples table. 

 

RGB button Opens the color selection dialog, 
which lets you replace the currently 
selected color with a new one.  

 

Merger 
button 

Merges the colors selected in the 
color samples table to the mean 
color. 

 

Delete 
button 

Deletes the colors selected in the 
color samples table from the palette.  

 
Save LUT Saves the current palette in a Look-

Up Table (LUT) file. 

 
Load LUT Loads the current palette from a 

Look-Up Table (LUT) file. 

 Template You can save and load color palette 
information to and from a template 
file using Template button.  

When the palette is ready to be built press OK. 
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Adaptive Binarization 
The adaptive binarization tool eases the conversion of scanned 
Grayscale or Color images with difficult background. This brand new 
tool makes a workflow while operating with a drawings and sketches 
on a rough colored background (i.e. blueprints and sepias) fast and 
easy.  
Choose Adaptive Binarization from the Image menu. 

 
• Set Radius – ‘level’ of the filter effect. Increasing the radius value 

increases the number of pixels surrounding the color boundary 
that are to be processed. Generally, the best results can be 
attained by setting the Radius value approximately two times 
thicker than the thickest linear object on the image. 

• Set Smooth checkbox (if required) and adjust the parameter. 
Using smoothing with the Binarize checkbox set to off produces a 
cleaner image with the background evened and line objects 
revealed 

• Set Binarize checkbox (if required) and adjust the parameter. 
Binarize – binarization using Threshold value. The method used – 
Threshold by grey – is described in the previous section. 

 
 



54 

Rasterizing; Merging Raster Images 
Rasterizing Vector Data 

You can rasterize vector data on raster images and either retain or 
delete the original vector objects. 
Select the vector objects to rasterize; must be located over the raster 
image. 
Choose Merge (Rasterize) from the Modify menu. 

   

Original vectors Rasterizing on 
monochrome raster 

Rasterizing on color 
raster 

Vector objects located outside the boundary of the raster image 
disappear. 
If vector objects are located over several raster images, then they 
are rasterized on all visible images that are located on unlocked 
layers. 
Tip: If you want to rasterize vector objects without removing the 
vector originals, then use the command Merge a copy (Rasterize) 
from the Modify menu. 

Merging Raster Images 
You can merge a raster image or raster selection with another raster 
image. 
Select a raster image (or its fragment) and choose Merge 
(Rasterize) from the Modify menu. 
If the selected raster data (or part of it) is placed outside the 
destination raster image area, then it disappears. 
If the selected raster data is located over several raster images, then 
it is rasterized on all visible images that are located on unlocked 
layers. 
Tip: If you want to merge a raster image without removing the 
original image, then choose Merge a copy (Rasterize) from the 
Modify menu. 
For the Merge (Rasterize) operation it is convenient to select one or 
more images from the combo-box in the Modify menu.     
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The Merge to all images option allows you to apply the Merge 
command to all images. 
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Tracing 
Tracing is an interactive (or semi-automatic) vectorization procedure. 
During the tracing procedure raster objects are specified one by one; 
these are then recognized by the program and converted to 
corresponding vector objects. In the process of tracing the original 
raster objects can be deleted, smoothed or left intact. 

Tuning of tracing 
You should tune the tracing parameters before applying this 
procedure. 
Tracing is tuned in the R2V Conversion Options dialog or by 
Raster Properties (for quick preview). 

Raster Properties toolbar quick preview 

 

• Tune the parameters in the 
same manner as will be 
described below.  

• Select Draw R2V preview 

 button.  
• Draw by rectangle the preview 

zone of the image. 
To specify all the conversion setting for tracing - choose 
Conversion Options from the Convert menu. 

Tuning of the geometry of traced objects 
Open the Options tab of the R2V Conversion Options dialog.  

 

Max. Width – maximum width 
of traced raster objects. 
Measure width of the widest 
traced lines. Set this 
parameter’s value as slightly 
greater then the measured 
width. 
Max. Break – length of ignored 
break of raster lines. 
If you trace dashed lines, then 
set the value of this parameter 
as slightly greater than the 
maximum gap between dashes. 

Accuracy – set the accuracy value for tracing polylines to high for  a 
closer approximation of raster curves with vector polylines. In other 
cases increase the accuracy value for images of good quality; and 
reduce the value for images of poor quality. 
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Layering resulting vector objects 
You can place resulting vector objects on different layers: 
• Create the desired layers in the Layer Manager. 

See the section The Layer Manager on page 7 for information on 
Layer Manager. 

 

• Open the Separate tab of 
the R2V Conversion  
Options dialog. 

• From the pull-down list of 
Layer select one to place 
the traced vector object. 

• Select the Use Table 
checkbox. 

Orthogonalization mode with tracing 
When tracing lines and polylines you can use the orthogonalization 
mode which allows you to obtain orthogonal vector lines and 
polylines that consist of orthogonal segments (The base angle can be 
calculated automatically or specified.). 
 
Tracing lines with orthogonalization 
To turn on line orthogonalization mode open the Options tab of the 
R2V Conversion Options dialog. 
Select the Orthogonalization checkbox. If necessary, then enter 
the base angle value in the Base Angle field and clear the Auto 
Estimate base angle checkbox. Note: The operation can only work 
if the raster line you want to trace deviates from the orthogonal (or 
specified) direction by no more than 20. 
 
Tracing with resulting polyline of orthogonal segments  

This information is provided in the section Tracing polylines with 
orthogonal segments on page 60 

Tracing Modes and Commands 
Before executing tracing, you should choose a tracing mode. 
Tracing modes: 

 
Original 
fragment      

 
Produce vector 
and keep raster      

 
Produce vector 
and erase raster  
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Erase raster 
without 
producing 
vector 

 

 

Smooth raster 
without 
producing 
vector 

  

Tracing command: 
You can trace: 

 
Lines, arcs, circles with 
auto recognition  

Hatches which consists of 
lines 

 
Lines by two points 

 
Raster symbols 

 
Arcs by three points 

 
Polylines 

 
Circles by two points 

 
Outlines 

How to trace 
• Set the tracing parameters 

Information on setting tracing parameters is provided on page 
56. 

• Choose from the Raster to vector toolbar or from the Trace 
menu: 
§ Tracing mode 
§ Tracing command 

Information on tracing modes and commands is provided on 
page 57. 

Tracing lines, arcs, circles, and outlines 

 

You can trace raster lines, arcs, circles, and 
outlines with automatic recognition of their type – 
click once on the desired object. 

 

If you work with a complicated image, or an 
image of poor quality or you need to vectorize 
only part of a raster entity, then you can apply 
forced tracing. 

Auto extension mode: When tracing lines or arcs you can use the 
auto extension mode you only need to specify a fragment of the 
object, but the program recognizes the whole object. To switch to this 
mode select the Auto extend vectors checkbox in the Trace tab of 
the R2V Conversion Options dialog. 
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Tracing Hatches 
To trace a hatch, you need to intersect all its lines with a crossing 
polyline. 
Tip: Raster lines that cross the hatch can interfere in the recognition 
operation, so before tracing the hatch it can be useful to trace these 
lines and erase the original raster. 

    

Original hatch 

Tracing lines that 
intersect hatch 
(with erasing the 
original raster) 

Tracing hatch – 
intersecting 
hatch lines 

Result of hatch 
tracing (in 
Produce Vector 
and Erase Raster 
mode) 

 

Tracing polylines 

 

Tracing polylines produces 
vector polylines which 
approximate raster curves. 
To increase accuracy of 
approximating vector polyline 
to the original raster curve 
increase the Accuracy slider 
in the Options tab of the 
R2V Conversion Options 
dialog. 

See page 56 for 
information on tuning of 
tracing. 

How to trace polylines 
• Select tracing mode (e.g., Produce Vector and Keep Raster). 

You can see the information of section Tracing Modes and 
Commands on page 57. 

• Run the Linefollowing command. 
• Specify a point on the raster curve – the program tracks this curve 

up to the nearest intersection and waits for you to indicate the 
direction in which tracing should continue. You can also use the 
Autodetect direction mode: 
Open the Trace tab of the R2VConversion Options dialog.  
Select the Autodetect direction checkbox. 
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Set the waiting period (in sec) in the Pause field. 
• If you turn on the Autodetect direction mode, and you are 

satisfied with the auto-detected direction, indicated by a cross, 
then press the Space key (Alternatively, the program continues 
tracing after the waiting period expires.). If you are not satisfied 
with the direction as suggested by the program, then specify the 
right direction on the screen. 
If Autodetect direction mode is off, then you must specify the 
next fragment of the raster curve on screen (either fragment 
between two nodes or one between a node and the end point of 
the raster curve). 

• If you need to change the tracing direction, then chose Change 
direction from the context menu. 

• To cancel the last segment of the vector polyline, press 
Ctrl+Backspace. 

• To cancel the last step, press Backspace. 
• If needed, then you can draw segments in Free Hand Drawing 

mode. Press Shift and specify the new nodes of the vector polyline 
on the screen. 

• When you have completed tracing the polyline, press Enter. 
Tip: You can use the Centralize View command from the context 
menu for convenience. 

Tracing polylines with orthogonal segments 
When tracing, you can obtain vector polylines with orthogonal 
segments. For example, this mode can be used to trace buildings on 
scanned maps. The direction of the first segment can be estimated 
automatically or specified. 

 

To obtain polylines with orthogonal 
segments: 
• Open the Trace tab of the 

R2VConversion options dialog. 
Select the Line Follow 
Orthogonalization checkbox. 

• Select the Autoestimate Base 
Angle checkbox or specify the 
angle for orthogonalization in the 
Base Angle field or by the 
measure button. 

Tip: You can reduce the Accuracy value to avoid creating 
unnecessary segments. 
If necessary, then you can create a vertex at each point of 
intersection on the polyline. – Select the Place vertex on nodes 
checkbox in the Trace tab of the R2VConversion options dialog 
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Tracing Outline 
You can trace raster outlines. Tracing results depend on the 
parameters and mode of tracing. Tracing parameters are set in the 
Trace tab of the R2V Conversion Options dialog.  

Setting parameters of tracing outline 

Auto Extend 
vectors – Off 

Creates vector on two colors 
boundary. 

 

Auto Extend 
vectors – On 

Creates vector at the center of 
raster line. 
Note: Raster line width is 
specified with the Options tab of 
the R2V Conversion Options 
dialog. 

 

Export single 
contour – Off 

Creates outer and nested 
outlines. 

 

Export single 
contour – On 

Creates the outer outline only. 

 
Auto Extend 
vectors – On 
Export single 
contour – On 

 Trace 
mode – keep 
raster  

Raster data inside the outline is 
kept. 

 

Auto Extend 
vectors – On 
Export single 
contour – On 

 Trace 
mode – erase 
raster. 

Raster data inside the outline is 
erased. 

 

How to trace outlines 
• Run the Trace Outline command. 
• Specify a point inside the outline. 
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Automatic Vectorization, Text 
Recognition 

Automatic vectorization is a procedure for converting raster data to 
appropriate vector objects. 
WiseImage recognizes the following objects when vectorize 
monochrome images: lines, arcs, circles, hatches, points, texts and 
symbols. Raster curves and filled contours are approximated with 
vector polylines.  The program can recognize line styles and arrows 
on line and arc ends. You can train the program to recognize new 
symbols and texts. You can round vector object widths to specified 
values. You can also place vector objects corresponding to raster 
lines of various widths on different layers and/or assign different 
colors to them. 

Tuning of Vectorization 
You can use one of the pre-defined templates or tune the parameters 
yourself. Vectorization parameters can be saved as a template for 
further use. Automatic vectorization is tuned in the R2VConversion 
Options dialog or by Raster Properties (for quick preview) – see 
Tracing. To open the dialog, choose Conversion Options from the 
rConvert menu. 

Select objects to recognize: 
Open the Recognition tab of the R2VConversion Options dialog. 

 

Select the entities you want to obtain after 
vectorization – select the corresponding 
checkboxes. 
The additional parameters for recognized 
objects, such as line type, arrows, hatch 
angle, and others are located on the second 
level. Click on ‘+’ open the display in order to 
get access to these parameters. 
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Setting the geometry of vectorized drawing: 
The geometry is set in the Options tab of the R2Vconversion 
Options dialog. 

 

Min Length –minimum length 
of a raster object to be 
recognized. (For example, enter 
1 mm in the Min Length field 
so that raster fragments smaller 
than 1 mm will not be 
recognized.) 
Max Width – maximum width 
of raster lines Set the value of 
this parameter as slightly 
greater than the measured line 
width on your drawing. 

Max Break – maximum accepted length of a break in a raster line to 
be ignored. Set the value of this parameter as slightly greater than 
the distance between dashes in dash lines or the broken distance in 
poor quality lines. 
Text Height – Set the value for this parameter equal to the 
maximum height of raster text symbols of upper case. 
Accuracy – this parameter corresponds to the accuracy of your 
raster image. Use a high accuracy value for images of good quality, 
and a low accuracy value for images of poor quality. 
Orthogonalization – select this checkbox to obtain orthogonal 
vector lines as a result of vectorizing raster lines, which deviate from 
the orthogonal direction by not more than 20. 
You can also align vector objects to a specified base angle; enter the 
angle value in the corresponding field. 

Separating vector objects by layer and /or by color 
The criterion for separating vector objects (by layer and/or color) is 
the width of the original raster lines. 

In the Separate tab of the 
R2V Conversion Options 
dialog, you can: 

• Specify width of resulting 
vector objects  

• Separate resulting vector 
objects by color 

• Separate resulting vector 
objects by layer 

In the Width field you can specify widths for vector objects obtained 
after vectorization of raster objects with line widths included in the 
interval, defined with the Start and End fields. You can also define a 
layer and/or color for these vector objects in the corresponding fields. 
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How to Vectorize 
• Set the vectorization parameters. 

Information on the tuning of vectorization is provided on page 
62. 

• If you have several images in your document, then select the 
one(s) to vectorize.  You can also vectorize a selected image 
fragment or an image clip. 

• Choose Raster2Vector from the Conversion menu. 

Text Recognition 
This section provides information on various algorithms for 
recognizing raster text; the procedure and parameters of setting up 
raster text recognition. 

Text Recognition Algorithms 

 

You can use the following algorithms for working 
with raster texts. You can choose them using the 
Recognition tab of the R2V Conversion Options 
dialog. 

 

None – this algorithm searches for raster text areas 
without vectorizing. 

 

Text Areas – this algorithm recognizes and creates 
text areas. You can enter text information in these 
text areas using the procedure of editing recognized 
texts. 

Information on editing recognized texts is 
provided below. 

 
Polylines (Outlines) – approximating the raster 
text with vector polylines (outline). 

 
OCR – recognizing the raster text and creating the 
corresponding text objects. 

How to Recognize Text 

• Select the Text Area checkbox in the Recognition tab of the R2V 
Conversion Options dialog. 

• Choose your required algorithm for working with the raster text. 
• In the Options tab of the R2V Conversion Options dialog set the 

Text Height value equal to the maximum height of raster text 
symbols of upper case. 

• Tune the text recognition options in the Texts tab of the R2V 
Conversion Option dialog. 
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See section Text Recognition Options on page 65 for information 
on the tuning of text recognition options. 

• Editing recognized texts  
• The procedure of editing recognized texts (text areas) is used after 

recognition with the OCR module or with Text Areas recognition. 
After applying automatic 
vectorization choose the command 
Edit OCR Texts from the Convert 
menu. The program displays the first 
recognized text fragment (area), the 
content of which appears in the Text 
Correction dialog.  

 

You can edit the text area contents. To accept the text and move 
on to the next one press the Accept Recognized Text button of 
the Text Correction dialog. To delete the current text, press 
Delete OCR Text button in the Text Correction dialog. 

Text Recognition Options 

 

Orientation – choose the 
orientation for raster texts 
contained in the image. 
Overlapped by Graphics – if 
this option is on, the program 
searches for raster texts, 
crossed with other raster 
objects. 
Tip: It is not recommended to 
use this mode when working 
with complicated documents to 
avoid possible mistakes such 
as incorrect recognition of 
small graphic objects as texts. 

Only Standalone Letters – allows searching for standalone text 
characters.  
Tip: If this option is off, then the program does not search for 
standalone text characters, but you can avoid incorrect recognition of 
small objects. 
Patterns – If you use the OCR module, then you should set patterns 
for text inscriptions contained in the raster document to obtain better 
recognition results. Select the Word pattern checkbox.  
If Patterns are not specified, then the program uses a set of 
standard patterns. 
Height Table – If after vectorizing, then you want to obtain texts of 
specific height, enter the desired text height(s) in the table and select 
the Height Table checkbox. 
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If you specify several height values, then texts height will be rounded 
to the nearest value from the list. 
Template file –file for storing topology models of text characters, 
which are used when performing OCR. 
You can also train the program to recognize other text characters or 
different forms of characters contained in the standard template file. 

Information on training OCR is provided on page 66. 

Setting a Text Pattern 

Text patterns can comprise of fixed and variable parts. 
Here is formal description of word pattern definition: 
‘[% [length]character type] II [ letter] ]…’ 
length – number of letters (you do not need to specify this, if length 
will be different), 
character type – type of a letter or a character (the name of the set 
that include it and related characters) 
The types of recognizable characters are presented in the 
following table: 

D Digits 

N Capital letters of national alphabet 

n Small letters of national alphabet 

E Capital letters of Latin alphabet  

e Small letters of Latin alphabet  

S Special characters (signs of plus, minus, equality, degree, 
and others) 

For example, 5V, 220V, 13.8V: 5, 220, 13.8 – variable part, V – 
fixed. Therefore, the pattern can be defined as %DV. The length is 
different, so it is not specified). 
Examples: 

Symbol sequence Pattern 

5    25     5559     22.9 %D 

R25     R15     R13 R%2D 

Moscow     Hanover %1E%e 

project     design %n 

5V     220V     13.8V %DV 

120     300     450 %2D%1S 

Training OCR 
You can train the OCR module to recognize new characters. You can 
add a new character to one of the standard template libraries or 
create your own. 
Tip: In some cases it is more convenient to use the standard library 
(e.g., DEFAULT.OCR) as basis, having saved it with a new name. 
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To train the program to recognize a 
new character or different forms of 
existing characters: 
• Choose Train OCR from the 

Conversion menu. 
• Open (create) OCR-file. 
• Enter a character to recognize in the 

Character field.  
• Select the corresponding character 

on the raster image using one of the 
selection buttons. 

• Press ‘+’ to add the new pattern to the OCR-file. 
• Save the OCR-file. 

Color Vectorization 
Color vectorization is intended for recognition of linear objects on 
color schematic raster images (plans, schemes, maps) with their 
further vectorization by polylines. WiseImage defines the color table 
for an initial image automatically assigning the nearest color from this 
table to resulting vector objects. 

Tuning of color conversion options 
Choose Color Conversion options from the Convert menu. 
Set the following parameters in the R2V Color Conversion dialog: 
• In the Binarizing section– Radius and Threshold. Starting from 

the minimum increase the values of these parameters gradually 
until you get the required quality of the monochrome raster 
image in the preview window 

For convenience you can use the Show/Hide buttons in the Preview 
window: 

  – Hide Source Raster;  

  – Hide Raster (binarization result); 

   – Hide Vectors. 
Use the Smoothing slider to smooth raster lines, if necessary. 
• In the Recognition section – Min .length and Max. width and 

Accuracy. 
The Min.length and Max.width are set in the same way as in the 
Automatic vectorization procedure.  
Use the Accuracy slider to get a raster object in the preview window 
approximated by a vector object in the best way.   
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• Select the Separate by Color checkbox to distribute the resulting 

vector objects of different color by different layers. 

 

• Set a layer, output color and width for the resulting vector 
objects in the appropriate columns of the table. 

• To vectorize lines of a specific color you should clear the Export 

to layer checkbox  for the colors you want to exclude from 
the recognition process. 

• The polylines resulting from vectorization will be broken at the 
crossing points with other objects. The Collect Polyline command is 
intended for correction. 

Correcting Vectorization Results 
Vectorization results usually need further editing and correcting. The 
program has both an automatic and interactive correction procedure 
intended for this purpose. 
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Automatic correction of vectorization results 
This operation restores the contact of arcs and circles, ‘merges’ 
vector fragments, removes vector ‘speckles’, and, aligns lines to 
standard directions (00, 300, 450, 600, 900, etc.) if their deviations do 
not exceed the angle specified by user. 
How to correct vectorization results automatically 
• Choose Vector Correction Options from the Conversion menu. 
• Using the displayed Vector Correction Options dialog, specify 

the autocorrection operations and parameters. Close the dialog by 
pressing OK. 

• Select vector objects to apply autocorrection. 
• Choose Vector Autocorrect from the Conversion menu. 

Interactive correction of vectorization results 
After applying automatic correction, it is recommended that you also 
use the manual correction (interactive). The commands for 
interactive correction are located on the Vector Correction toolbar. 
Using interactive correction you can: 

Commands for interactive vector correction 

 
Join selected vector fragments to a polyline 

 
Join selected vector fragments to a circle 

 Join selected vector objects to an arc 

 
Join selected vector objects to a line 

 
Join selected vector objects to create the closest matching 
(in terms of geometry) single vector object 

 
Trim vector objects 

 
Expand vector objects 

 
Break at specified point 

 
Correct to intersection 

 
Align angle and distance 

See more detailed information on editing vector objects on page 
31. 
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Batch and Script 
Script Studio 

A script is a sequence of operations, which can be executed 
unattended. 
Let us consider an example of creating a Script on the basis of raster 
image calibration. 
How to prepare data to start  script: 
• Prepare document (*.cws): open the raster image, customize 

the User Coordinate System (UCS), save the document (Map.cws) 
• Prepare calibration template: set calibration pairs – grid and 

measured points, save the calibration pairs in file (map.tpl) 
Note: You can also set calibration pairs and save them in the 
document file. 

Prepare, save, and start Script (*.csf): 
Define the calibration execution order:  
1.   Open document (*.cws); . 
2.   Start calibration using calibration template (*.tpl);  
3.   Save document with calibrated image with a different name. 
• Choose the command Script Studio from the Tools menu. Using 

the Edit Scripts dialog box:  
1. Choose File from the 

Category list; choose 
Open Document 
from the list of 
commands of the File 
category; move the 
selected command to 
the Script field. 

 

Click on ‘+’ to open a sub-category that contains the chosen 
command options. 
Specify name and folder for the document file - Map.cws  
2. From the Category 

list, choose Image; 
from the list of 
commands choose 
Calibration; and 
move the selected 
command to the 
Script field. 

 

Open the sub-category of calibration options and specify the pre-
defined calibration template file - map.tpl 
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3. From the Category 
list choose File; from 
the list of commands 
choose Save as 
Document. 

Open the sub-folder of 
the command options 
and specify in the File 
Name field - the location 
and name of the 
resulting file, and in the 
File Type  

 

field – the type of the resulting file, for all needed fields. 
• To save the script (*.csf) file press the Save As button of the Edit 

Script dialog. 
• To start the script:  

§ Press the Run button of the Edit Script dialog. 
§ If the script file has been previously saved, then choose Run 

Script from the Tools menu and choose the required script file 
from the open Script File dialog. 

After starting a script the 
lower-right corner of the 
Edit Script dialog 
displays a report on the 
command execution. 

 

Tip: Save the report to file, specifies Set Log File as the first Script 
command, selecting name and location of the report file as 
parameters. 
Tip: For faster navigation you can set All Commands in the list of 
categories of the Edit Script dialog, and then you can choose a 
command by pressing its first letter. 

Batch Studio 
Batch – is a specified sequence of Scripts to process files. 
It is convenient to use the Batch option when you need to apply 
regular operations to several raster images. Before creating a Batch, 
you need to prepare a set of scripts, which describe commands for 
processing. You do not need to describe the commands for opening, 
inserting and saving files in Scripts, prepared for Batch, as these 
operations are performed with the Batch studio tools. 
Look at the following example of creating a Batch: 
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Prepare data to start Batch 

Prepare a script that performs the 
following commands: Deskew, Crop, 
Rotate by 900 and save it as 
Deskew_Crop_Rotate.csf 

 

Prepare a script that performs the 
4-point correction for images of 
format ISO A4 and save it as 
4p_correction_ISO_A4.csf 

 
You can create and save scripts in the Script studio. 

Information on creating Scripts is provided on page 70. 

Prepare and start Batch 
Choose the Batch Studio command from the Tools menu in the 
open Run Batch dialog: 
• From the list of folders, located in 

the left part of the Run Batch 
dialog, choose the files, or folders 
with files to process and using drag 
& drop to move them to the Input 
files or directories field. 

Note: You can use * to specify names 
for files, e.g., if you specify 
…\Images\*.tif, only files with 
extension tif (contained in the 
Images folder) will be processed. 
• From the list of folders, located in 

the left part of the Run Batch 
dialog, select the prepared Scripts 
files, and drag and drop them to 
the Script files list field.  

• If you want to save the processed files in a different folder (with 
different name or extension), then select the Use output 
directory checkbox. Specify a name for the folder. Otherwise, the 
processed files will overwrite the originals. 

• Press the Run button of the Run Batch dialog. 
 

When starting a Batch, the lower-right 
corner of the Run Batch dialog 
displays a report on the command 
execution. 
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Customizing WiseImage 
Brief description: In this section you will learn how to customize the 
interface and various parameters of WiseImage. 

Customizing Program Parameters 
Choose Preferences from the Tools menu. 

 

Using the Preferences 
dialog box you can customize 
the following parameters: 

• Cursor’s appearance, color 
and size 

• Size and color of ‘grips’, 
which appear when 
selecting objects 

• Colors of interface 
elements (e.g., color of 
selected raster objects, 
color of the program 
window background, etc.). 

• Preview window style for Binarization. 
• Scroll Settings (scroll step, arrows step, Mouse Wheel scale 

factor) 
• Snap settings (aperture size, snap markers’ size and color, 

tooltips) 
• Filter usage mode; setting limit for displaying object properties. 
• Modifying the existing standard paper formats and adding new 

ones 
• Defining the path to OCR template files, symbols to external 

filters folders 
• List of operations for autocorrect 
• Default properties for new raster images 
• Settings for the New raster from selection command (keep or 

erase the original raster object) 
• Properties (width and color) of clipping edge used for vector 

correction 
• Style and size of markers for vector point display 
• Templates usage 
• Settings for batch script (linear and angle units, default file name 

and report name) 
• Mode of monochrome raster display 
• Turning on/off the use of World-file (for GIS users) 
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This general information includes the description of WiseImage 
parameters, which can be customized by the user. For more detailed 
information see the corresponding sections of User’s Guide and Help. 

Customizing the Interface 
You can easily customize the WiseImage interface. To start modifying 
the interface choose Customize from the Tools menu. 

Creating a new toolbar 

• Press New on the 
Toolbars tab. 

• Specify a name for the 
new toolbar in the 
Toolbar Name dialog 
that appears in the list. 

 

• Go to the Commands 
tab. Select the required 
group of commands from 
the Categories list, and 
then choose a command 
from the Commands list 
and drag it to the newly 
created toolbar.  
Repeat this operation for 
all commands, which you 
want to place on the new 
toolbar. 

Modifying a toolbar 
Working in this mode, you can rename toolbars, add buttons from the 
list located in the Commands tab, delete and move buttons to other 
toolbars. 
How to modify a toolbar 
Choose Customize from the Tools menu. To rename (delete) a 
toolbar select it from the list of the Toolbars tab and press Rename 
(Delete). You can move (delete) buttons using the drag-and-drop 
technique. 
Note: If you want to reset a modified standard toolbar to its original 
state, then select it and press the Reset button in the Toolbars tab.  
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Turning on/off toolbar display 
You can turn on/off the display of toolbars on the screen. For this you 
can choose Show Toolbar from the View menu and then select 
Check Mark for desired toolbars. 

Creating a new menu item 
Choose Customize from the Tools menu. 

 

• From the Categories list of 
the Commands tab choose 
New Menu. 

• Place the cursor on the 
New Menu string of the 
Commands list, click and 
drag the cursor to the menu 
item string where you want 
to place the new item. 

• You can select commands 
for a new menu item in the 
same way as for a new 
toolbar. 

Information on adding commands from the list of Commands is 
provided on page 74. 

Modifying a menu 
You can rename menu items, add, delete, move and group menu 
commands. 
How to modify a menu 
Choose Customize from the Tools menu. 

 

• To rename a menu item place the cursor 
over it, right-click and choose Rename from 
the right-button menu. 

 

• If you want to group some menu commands, 
then choose Begin Group from the right-
button contextual menu. 

• You can move (delete) commands using the drag-and-drop 
technique. 

Information on adding commands from the list of Commands is 
provided on page 74. 
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Tip: If you want to reset all menu items to their original state, then  
press the Reset All button, located in the Toolbars tab. Note that 
pressing this button resets all interface modifications made by the 
user. 

Assign acceleration keys 
Start customizing the interface by choosing Customize from the 
Tools menu. Open the Keyboard tab. 

 

• Select the desired group of 
commands from Category, 
and then the command from 
the Commands list. 

• Enter a desired key 
combination in Press new 
acceleration key field. 

• If this key combination has 
already been assigned, then 
the name of the command for 
which this combination is 
already used appears in the 
Assigned to field. 

• Press Assign, if this combination is not already used (message: 
Unassigned in the Assigned to field). 

• To delete the existing acceleration keys, select them from Current 
keys and press Remove. 

Modifying context (right-button) menu 
You can modify the list of commands contained in context (right-
button) menu (invoked by pressing the right mouse button).  

 

• Choose Customize from the 
Tools menu, and then the 
Menus tab. 

• Select a command from the 
list, for which you intend to 
modify the context (right-
button) menu. 

• Press the Customize button. 
• Modify the appeared context 

menu. 

Note: If you want to reset the modified context menu to the original, 
then select it from the list and press the Reset button. 

Custom Button Size 
Button sizes can be tuned freely to achieve a better performance 
while operating in a wide range of screen resolutions. 
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• Choose Customize from the 
Tools menu, and then the 
Options tab. 

• Modify the displayed settings. 

User Defined Buttons 
The user can create custom toolbars and buttons.  Scripts or 
command sequences can be assigned to these new buttons. 

• Choose Customize from the 
Tools menu, and then the 
Commands tab. 

• On the left bottom corner click 
on the harmer symbol and 
drag it to the desired toolbar. 

• By a right mouse click on the 
new button enter Tool Setup. 

• To modify button image select 
Edit in Tool Setup. 

 

Multiple Preview Windows 
It is possible to open several preview windows at a time during any 
image enhancement procedure. To launch a new preview window 

press  button under the active preview window. 

Transparency 
Dialog boxes and palettes can be set to semi-transparent.  To do this 
press Ctrl + Right mouse button on a desired dialog box and set 
Window Transparency. 

Raster Border Control 
In WiseImage you can switch off raster border frame, for 

convenience. To do it, go to Preferences , and unselect Draw 

Raster Frame in Display View  


