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License Agreement 
Object: Software package RasterID, comprising programs and documentation (thereafter package). 
Consistent Software (thereafter CS) from one party and the Principal from the other party agreed as the 
follows: 
CS transfers the Principal a non-exclusive License to use the Package (thereafter License), supplied under 
this Agreement according to the conditions specified bellow. Should the Principal is not contented with the 
terms of the Agreement and/or the Package supplied, he can within 30 days return CS all the transferred 
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1.  License 
1.1 Under this License the Principal may use the programs on one computer only. To use the programs on 
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1.2 The Principal is entitled to make one archive copy of these programs, which automatically becomes CS 
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2.1 CS warrants that the Software will be free from defects at delivery and for a period of ninety (90) days of 
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2.2 CS has no warrant responsibility for application and application results of this Package and other 
materials, linked with it, in terms of accuracy, correctness, reliability, etc. 

2.3 CS is not responsible for any damage, directly or indirectly linked with the use of, misuse of, or impos-
sibility to apply this Software. 

2.4 No other information, except for the present License, obtained by the Principal shall cause any CS 
warrant responsibility. 

3. Modifications in the programs and new versions 
3.5 The Principal can fill out and forward to CS the User’s Registration Card in order to have a possibility of 

getting the entire supplement, the software new copies on preferential terms and notice of errors cor-
rection.
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Chapter 1 
INTRODUCTION 

Welcome to RasterID v. 3.5! 
RasterID is designed for enhancing scanned raster images as well as 
manual and batch processing and indexing of scanned images. 

Indexing procedure stands for searching a title block in a document, 
recognizing the text fields in this title block with further exporting the 
recognized data to external databases. 

Scope of Application 
Architecture, construction, engineering, EDM, TDM and facilities man-
agement. 

Supported Formats 
RasterID allows for work with monochrome and color raster images in 
the following formats: TIFF (including multipage), BMP, RLC, CAL, C4, 
TG4, PCX, JPG, JPEG, PNG, ECW, PDF. 

RasterID provides the ability to tune saving settings for several formats 
as well as to create a custom format based on the existing ones proper-
ties of some set a custom format. 

Features 
• Scanning using TWAIN-scanners 
• Direct support for wide scanners 
• A wide range of tools: 
Ø Mirroring 
Ø Rotating at 90,180 and 270 degrees 
Ø Resizing 
Ø Cropping 
Ø Automatic deskewing 
Ø Four-point correction (Rubber sheeting) 
Ø Fitting image to closest paper 
Ø Speckle and Hole Remover 
Ø Separation by size 
Ø Smoothing 
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Ø Inversion 
• Wide range of color filters and processing tools 
• Batch processing 
• User defined Title Blocks search and field contents recognition 
• Export recognized Title Blocks to MS Excel or other database 
• Internal OCR with character training capability 
• External OCR option 
• Friendly interface 

Equipment Required 
• OS: Windows 98/ 2000/Me XP. 
• Free disk space: 30 Mb 
• Memory: 64 Mb 
• Processor: Pentium 
• Hardware  lock (optional) 

Typeface Conventions 
This manual uses the following typeface conventions: 

Convention Use 
UPPERCASE Keys on the keyboard: 

ENTER, ESC, ALT, etc. 
File name extensions such as: 

.TIF, .PCX, .RLC 
Names of files, disks and folders: 

B:, \FILTERS, ESL.EXE 

Initial Caps Italic Names of menu items and dialog 
box options: 
Inversion, Train OCR 

Lowercase italic RasterID terms: 
indexing, image correction 

Software Protection  
RasterID can use a software or hardware protection system. It offers the 
flexibility to use the program in either a single user or network environ-
ment. Before you can use RasterID you need to set up the license for 
the program. You should install RasterID and setup the license (run the 



 

3 

Registration Wizard) for the computer on which you intend to use 
RasterID. 

RasterID Installation 
Before the installation procedure make sure that the hard disk in your 
system has at least 30 MB of free space. 

To install RasterID: 

§ Insert the hardware lock (if you have one) in the printer’s or USB-
port of your computer. 

§ Insert a CD-ROM containing RasterID into the CD-ROM drive. 

§ Run the SETUP.EXE file from the CD-ROM root folder. 

§ If you select a commercial version, enter the serial number of your 
product (see your CD or Packaging) in the Serial Number entry. 

§ Enter the User’s name and Company fields. 

§ Check that this information is correct before continuing, as this 
information cannot be changed once installation is complete. Click 
on the Next button. 

§ The Choose destination location dialog appears, which specifies the 
folder name and the disk where RasterID will be installed. You can 
accept the default path or specify another location for the installa-
tion with the Browse button. Click on the Next button to continue. 

§ Select the type of installation you require in the Installation Type 
dialog; click on the Next button. 

§ The Select Program Folder dialog appears prompting you to specify 
the folder name of the system menu where will be a shortcut to 
launch RasterID. The Program Folder already has a name, which 
you can accept by clicking on the Next button. If you want to 
change this, enter a new name and click on the Next button.  

§ The installation procedure creates a folder on the hard for RasterID 
disk where all the necessary files will be copied, and a shortcut for 
RasterID in the Windows system menu.  
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To setup the license 

§ To setup the license for the first time you have to use the Registra-
tion Wizard. 

• The installation procedure prompts you to start the Registration 
Wizard after RasterID installation has been complete. 

• You can start the Registration Wizard from the folder where 
RasterID is installed: select it and start the REGWIZARD.EXE 
file.  

• You can start the Registration Wizard from the RasterID folder 
in the Windows system menu. 

§ The program defines the serial numbers of your product, and also 
the hardware lock (if any) and places them in the appropriate fields. 

§ If you have the hardware lock you should select the Use Hardware 
Lock option. 

§ Please be attentive when entering your registration data in the two 
following dialog boxes. Should those fields are filled incorrectly 
Consistent Software has the right to refuse licensing. 

§ Send your registration data via e-mail at: getlicense@csoft.com.  
 
License Registration 

§ Start the Registration Wizard. 

§ Select Specify path to License file or enter the License Server ad-
dress.  

§ In the License file or Server dialog press the Browse button and 
specify the location of the License file on your hard disk. 

Press the Send E-Mail… or Print…  button. 

Uninstalling RasterID  
To uninstall RasterID you should use the standard procedure for unin-
stalling all Microsoft Windows applications. RasterID will be completely 
removed from the computer. Any files or templates created by the user 
will not be removed. 

1. Click Start, Settings and open the Control panel. 

2. Choose Add/Remove Programs. 

3. Choose RasterID from the list. 

4. Click on the Remove button. 

5. Follow instructions on the screen. 
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Installed RasterID 3.5 Folder Contents 

 
RasterID, Formats, Tools – application binary files 

Help – doc and help files 

Sample Application, Table Receivers – application source files 

OCR, Templates – OCR and title block template files 

Samples – image files 



 

 

Chapter 2 
RasterID BASICS 
This chapter helps you to familiarize yourself with the main screen 
components of RasterID and teaches you a few basic skills you will use 
each time you work with the program. 

Running RasterID 
Before you run RasterID for the first time, install it on your hard disk.  

To start RasterID 
1. On the taskbar, choose Start, and then click on Programs. 
2. Click on RasterID, then from the displayed folder click RasterID. 

RasterID Window 

 

 
This is a screenshot 
of RasterID. Each of 
the toolbars and 
window elements are 
described in the 
following para-
graphs. 

Menu Bar 

The Menu bar contains a set of pull-down menu headings.  

Toolbars 
There are the six RasterID toolbars: File, Edit, View, Image, Color and 
Tools. Each of the RasterID toolbar buttons is briefly described below. 



 

7 

File toolbar 

 
• Opens WiseScan in Scan to View mode 
• Opens WiseScan in Scan to File mode 
• Opens WiseScan in Scan to Print mode 
• Opens WiseScan in Scan to Net mode 
• Opens an existing image 
• Saves the current image  
• Saves the current image to another file  
• Closes the current image file 
• Selects a scanner source 
• Acquires an image from scanner 
• Prints a color table 
• Creates a color profile 
• Setting print options 
• Prints the current image 
• Exits RasterID 
• Help system 

Edit toolbar 

 
 

• Reverses the last action 
• Returns the changes reversed with Undo 
• Sets Work Area to process a part of the image 
• Resets Work Area to process the entire image 
• Cuts Work Area contents to clipboard  
• Copies Work Area contents to clipboard 
• Pastes the clipboard contents to the image 
• Pastes the clipboard contents to the selected position 
• Erases the Work Area contents from the image  

View toolbar 

 
• Displays a view of the entire raster image 
• Zooms to a rectangular image area  
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• Increases the display magnification x 2 
• Reduces the display magnification by half 
• Sets zoom level so 1 screen pixel corresponds to 1 image dot 
• Scrolls the image by dragging with the mouse 
• Previous page for loaded multipage images 
• Next page for loaded multipage images 
• Zooms to recognized title block 
• Shows or hides recognized title block 
• Shows or hides loaded image 

Image toolbar 

 
• Inverts image  
• Rotates image by 90 degrees 
• Rotates image by 180 degrees 
• Rotates image by 270 degrees 
• Mirrors by horizontal axis  
• Mirrors by vertical axis  
• Deskews image automatically 
• Deskews image manually  
• Crops image by black pixels  
• Crops image to a bounding frame 
• Crops image to the work area boundary 
• Crops image by a rectangle 
• Crops image by a standard paper format 
• Removes raster spots of the specified size  
• Fills raster holes of the specified size  
• Smoothes raster lines 
• Fits image to the closest paper size 
• Resizes image to the closest paper size 
• Scales image proportionally  
• Corrects image by four points 
• Separation by size 
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Color toolbar 

 
• Brightness/Contrast tuning 
• Equalizer 
• Binarization 
• Adaptive binarization 
• Convert to RGB 
• Convert to 8-bit indexed 
• Convert to grayscale 
• Color reduction tool 
• Color separation tool 
• Blur filter 
• Unsharp Mask filter 
• Median filter 
• Gamma Correction 
• Image Classifier 

Tools toolbar 

 
• Image manager – controls multi-paging 
• Trains OCR on current image 
• Trains Title block on current image 
• Runs Title block recognition to preview results 
• Opens the Recognize Text to File dialog box 
• Opens the Script Studio dialog box 
• Runs Batch processing 
• Sets output logger for indexing 
• Opens Preferences dialog box 
• Opens Virtual Scanner facility. 

Status bar  
Displays information about the cursor position and the resolution and 
size of the current image. The Status bar can be switched on/off in the 
View menu. 
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Preview Window 
In some RasterID dialog boxes there is a preview window, where you 
can observe the result of an operation on a selected image part while 
tuning its parameters. 

 
The image part displayed in the left pane of the dialog is called a pre-
view area. Also, there are the following controls: 

 – Turns on/off the viewing of results in the preview window. You 
can change the position of a preview area using the mouse. 

 – Zoom in. Doubles a preview scale in the preview window. 

 – Zoom 1:1. Displays an image in the preview window 1:1 so that 1 
dot in the preview window corresponds to 1 dot of an image. 

 – Zoom out. Reduces a preview scale by half in the preview win-
dow. 

 – Opens/closes a detached preview window. Pressing this but-
ton repeatedly allows you to create several preview windows for differ-
ent parts of your image. The right pane of the dialog becomes a sepa-
rate window. To reset the dialog box to the original view you should 
close all the detached windows one by one. 

RasterID Preferences 
You can customize RasterID to suit the way you work. For example, you 
can choose whether or not to display the rulers and the frame bordering 
the image. You can set your preferences so that RasterID uses only 
those paper formats that you specify. You can also define the color of 
screen elements, such as the image color.  

To set your preferences: 
1. From the Tools menu, choose Preferences.  
2. Select the tab and the options that you want to modify. 
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3. Modify the selected option. 
4. Choose OK.  

The following sections describe the tabs of the Preferences dialog box.  

 
The Raster Image properties section allows you to control the image 
display and the current units used. 

The Colors section contains options to change the colors used for dis-
playing the image. 

The Papers section contains a list of standard paper sizes. 

The Standard directories section contains the location of files used by 
RasterID. 

The External OCR section contains one or several OCR engines that 
can be used to recognize texts. 

In the Default raster properties section you can set the standard image 
resolution value. This is used to set a resolution for images that do not 
contain a resolution value (such as BMP). 

In the Display View section the Half Tone Paint check box controls the 
visual effect which makes zoomed out images appear a little blurred as 
if they are seen at a distance. 
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Using Dialog Boxes 
Some RasterID commands invoke dialog boxes. Dialog boxes contain a 
number of standard controls. The following sections briefly describe 
these controls. 

Apply button 
Performs the current operation using the parameters you’ve specified, 
without closing the dialog box. 

OK button 
Performs the current operation with the parameters you’ve specified, 
and closes the dialog box. 

Close button 
Closes the dialog box and stores the parameters you’ve specified. The 
next time the dialog box is opened, the last specified parameters will be 
remembered. 

Cancel button 
Closes the dialog without saving any changes. 



 

 

Chapter 3 
MANUAL IMAGE PROCESSING 

Opening and Scanning Image Files 

You use the Open command to load existing images of all file types in 
RasterID. 

To open a file 
1. Choose Open from the File menu or choose button from the File 

toolbar. The Open dialog box appears. 

 
All the files recognized by RasterID are listed. If the desired file 
does not appear, choose Image Files from the Files of type list. 
RasterID then displays all the files in the folder in the file listing. To 
locate files in other folders, use the Look in list. 
Use the buttons at the top of the Open dialog to display information 
about image files before opening them. 

2. Select the name of the file you want to open. 
3. Choose Open and the selected file will be loaded. 

To scan a raster image  

WiseScan module 

RasterID has internal support for wide-format scanners and supports 
the TWAIN standard for image acquisition. 
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See “WiseScan” manual shipped with RasterID 3.5 for information on 
scanning modes and WiseScan controls. 

Virtual Scanner 

Using Virtual Scanner you can process images obtained from sources 
other than scanners, for example from video cameras or engineering 
systems that use scanner-like devices for batch input, but do not pro-
vide a scanner interface. 

Processing involves applying commands from script files and post proc-
essing to distinguish processed files from new ones. The path to the 
folder containing the image files can be rescanned at set intervals to 
retrieve any new files. 

Using this option means that scanning can be performed in the back-
ground in a continuous loop. 

To activate Virtual Scanner  
1. Choose Virtual Scanner from the Tools menu. 
2. In the Path to Scan entry select the folder where the source image 

files reside, and in the Script file entry, select the script file contain-
ing the required batch of processing commands. 

3. Select the Post Process option – this is the action to be applied to 
each source image after the batch has been processed. 

4. Select Scan interval. 
5. Press Start. 

 
Virtual Scanner revisits the Path to Scan at each Scan interval and ap-
plies the Script file to every new source image found that has not previ-
ously been marked as processed. Processed files can be moved, de-
leted or marked as processed. 
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The lower part of the Virtual Scanner dialog box reflects the progress of 
the processing operation.  
6. Press Stop to terminate the scanning loop. 
7. Press Clear Log to begin a new log. 
8. Press Start to activate Virtual Scanner again or Close to stop all 

activities. 
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Controlling the Display 

Scrolling 

The program window contains horizontal and vertical scrollbars. You 
can scroll up and down, left and right across the whole screen by press-
ing the scrollbar arrows. 

Panning 
You can use the Pan command from the View menu to move the image in 
the application window without changing the view magnification. To pan 
the image, choose Pan or click . Move the mouse cursor over the 
image and press the left mouse button. Drag the mouse while holding 
down the left mouse button. The image will move in the same direction as 
the cursor. Release the mouse button to stop panning. To exit panning 
choose Pan or click  again.  

If you have a mouse with a wheel, pressing and holding a mouse wheel is 
equal to activate a Pan command. 

Zooming 

The most common way to change views is to use one of the many 
zoom commands, which will either increase or decrease the size of the 
image displayed in the graphics area. Zooming does not change the 
absolute size of the image. It changes the view size within the graphic 
area. RasterID offers several ways to change the view, including draw-
ing a zoom window, zooming in and out, and displaying the entire im-
age.  

To zoom in or out incrementally choose Zoom In or Zoom Out from the 
View menu, or click  or , or use a mouse wheel. 

To zoom to a window choose Zoom Window or click . Specify one 
corner of the area to view and then click the opposite corner of the area 
to view.  

To zoom to the image extents choose Zoom All or click . 

The Zoom 1:1 command displays an image so 1 screen pixel reflects 1 
image dot. To zoom 1:1 choose Zoom 1:1 from the View menu or click 

 from the View toolbar. 
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Image Manager 

Image Manager is a tool to control pages in multipage TIFF files and 
images that become separated into layers as a result of a RasterID op-
eration such as color separation or separation by size. 

Through the Image Manager dialog you can add, rearrange or delete 
layers, control visibility of layers and save selected layers to a separate 
image file. Only one of the layers is visible at any one time. 

To open the Image Manager 

Choose Image Manager from the Tools menu or click the  button 
on the Tools toolbar. 

 
The left pane displays information about the layers (pages), their type, 
size and resolution. The preview pane on the right is equipped with 
zoom buttons described in the previous section, and the Fit to Window 
(“f”) button. 

The Image Manager also has the following buttons: 

 Add from Clip-
board 

Creates a new layer and places the contents 
of the Clipboard on it. 

 Add from file Creates a layer from an existing file (through 
the Open File dialog box). 

 Save page As Saves the selected layer to a separate file. 

 
Delete Deletes the selected layer. 

 Up Moves the selected layer or page up a level. 
This allows you to rearrange the pages in a 
multipage TIFF prior to saving. 

 Down Moves the selected layer or page down a 
level. This allows you to rearrange the pages 
in a multipage TIFF prior to saving. 
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The  icon denotes which layer is currently visible. To make another 
layer visible, click on its visibility field in the Image Manager dialog. 

To browse through the pages of a layered or multipage file you can also 
use the  and  buttons from the View toolbar. 

Multipage TIFF support 

RasterID can open and save several images in a single file using the 
Multipage TIFF format. When opening a multipage TIFF file RasterID 
automatically converts pages into layers that can be changed or rear-
ranged with the Image Manager dialog. The current page number is 
always shown in the title bar of the RasterID window.  

When you save an image that was separated to pages to a standard 
(non-multipage) file, all layers except the first one are lost. To save all 
information from such an image you must either save each layer to a 

separate file using the  button in the Image Manager dialog or save 
an image in a multipage format (TIFF or PDF), that automatically pre-
serves layers as pages. 

Basic Manipulations 
The following section describes those commands that can be applied to 
improve the quality of an image. 

Rotating Images 

The Rotate command rotates the image contents around its centre point 
by the angle you choose.  

To rotate an image using a preset rotation angle choose Rotate from 
the Image menu then choose a preset angle from the submenu: 90 ccw 
(to rotate by 90 counter clockwise), 180, or 90 cw (to rotate by 90 clock-
wise). 

Mirroring Images 

The Mirror command under the Image menu flips the image contents 
horizontally or vertically. 

To mirror an image contents choose Mirror from the Image menu then 
choose by axis X (Horizontally) or by axis Y (Vertically). 
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Deskewing Images 

This function lets you correct small skew errors that frequently occur 
during scanning. Deskewing rotates the whole image around its centre 
point to align it vertically or horizontally.  
To deskew an image choose Deskew from the Image menu. 
You have two options under the Deskew menu: Auto and Manual.  

To deskew raster images manually 
1. Run the operation by choosing Deskew > Manual from the Image 
menu. 
 The following dialog box is displayed: 

  
2. Type the skew angle value in Angle or click the angle-measuring 

button  and specify the start and end points of the line that de-
fines the rotation angle – the deskew line. The measured value is 
automatically entered the in Angle box. 

3. Click OK. 

To deskew raster images automatically 
  Run the operation by choosing Deskew > Auto from the Image 

menu. 
If RasterID is able to estimate the rotation angle, the raster image will 
be deskewed. Otherwise, use the manual deskewing procedure. 

Cropping Images 

You can crop an image using either a manual procedure (specify a work 
area), or an automatic procedure that detects the image margins by a 
first black pixel or by a bounding frame.  

To achieve the best cropping results you should deskew the image be-
fore you apply the crop command. 

From the Image menu choose Crop and then a specific command you 
want to apply (see below). Alternatively you can press the appropriate 
button on the Image toolbar: 
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Command Function 

 Auto by black Crops the blank margins of the image by a first 
black pixel. 

 Auto by frame Crops an image by a bounding frame. 

 by Work Area Crops an image by the work area specified in 
the Edit menu. 

 by Rectangle Crops an image by the rectangle specified 
manually by the user on the image. 

 by Paper Crops an image to a standard paper format, 
specified or defined automatically. 

 
To crop paper to a standard size 

The Crop by Paper command allows you to fit an image on to the clos-
est paper format. If the chosen paper format is smaller than the image, 
the part of the image outside the edge of the paper will be lost. 
All of the Crop buttons are located on the Image toolbar. 

1. Choose Image > Crop > By Paper Size or press  on the Image 
toolbar. The following dialog box appears. 

 
 

2. Select a paper format from the list (press the  button to auto-
matically find the closest paper format to your image) and set the 
image orientation. 

3. Press OK. A dashed frame representing the specified paper size 
appears over your image. Drag the frame to the desired position 
and click (or press ENTER) to confirm. Pressing ESC cancels the 
operation; you can also Undo it.  
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Despeckling Images 

These filters are applied to the entire image. If you wish to apply filtra-
tion to only a part of the image use the Set Work Area command from 
the Edit menu. 

Speckle Remover 

The Speckle Remover filter removes raster objects (isolated clusters of 
pixels) whose size is smaller than the specified value. This filter can 
automatically estimate the size of the spots in the image. 

 
 

Original image fragment After speckle removing 

To use the Speckle Remover filter 
4. Choose Speckle Remover from the Image menu. The Speckle Re-

mover dialog box appears. 

 
5. Specify the maximum size of raster objects to be removed, either in 

the current units (left box) or in dots (right box). Alternatively you 
can set the Auto Estimating option so that the filter automatically 
estimates the raster speckle size before filtration. 

 
To specify the raster object size on the screen, click this but-
ton and pick a point inside the object, or 

 
Click this button and indicate two points on the screen. The 
program will specify a speckle size equal to the distance 
between the indicated points. 

6. Click Apply. 
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Hole Remover 

The Hole Remover filter fills holes in raster objects. The filter removes 
holes that have a size smaller than the specified value. This filter can 
automatically estimate the size of the holes.  

  
Original image    After hole removing 

To use the Hole Remover filter 
1. Choose Hole Remover from the Image menu. The Hole Remover 
dialog box appears. 

 
Hole Remover dialog box 

2. Specify the maximum size of raster holes to be removed in the cur-
rent units (left box) or in dots (right box) or alternatively set the Auto 
Estimating option so that the filter automatically estimates the 
raster hole size before filtration. 

 
To modify the raster hole size on screen, click this button 
and pick a point inside the hole, or 

 
click this button and indicate two points on the screen. The 
program will specify a hole size equal to the distance be-
tween the indicated points. 

3. Click Apply. 

Inversion 

The Inversion filter inverts raster dots so that black dots become white 
and white dots, black. The following illustration shows the results of 
inversion filtration. 
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Inversion filtration 

To use the Inversion filter choose Inversion from the Image menu. 

Smoothing 
The Smoothing filter smoothes the contours of raster objects. 

   
Original image fragment After Smoothing 

This filter works in two steps. During the first step, the Smoothing filter 
converts the monochrome image to grayscale and applies a medianing 
operation to it. This operation searches the radius of a selection of pix-
els and replaces the centre pixel with the median brightness value of 
those pixels. This produces the effect that may be described as blurring 
of the contours of raster objects. Increasing the Medianing value makes 
the blurring wider. 

During the second step, the filter converts those pixels that have a 
brightness values less than the Threshold parameter value to black. The 
wide black lines on the next picture show the resulting boundaries. Pix-
els inside those boundaries become black, the outer pixels become 
white. Increasing the Threshold value thickens objects, while decreasing 
the value makes them thinner. 
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The first stage – medianing  The second stage - binarization 

After these two operations are performed the image is converted back to 
monochrome. 
To use the Smoothing filter 
1. Choose Smoothing from the Image menu. The Smoothing dialog 

box appears. 

 
Smoothing dialog box 

2. Specify the Medianing value. This value determines the degree of 
medianing of the contour pixels. 

Specify the Threshold value. This value determines the degree to which 
raster objects thickening. A higher value increases the degree of 
smoothing but raster lines will also become thicker. 
3. Choose OK. 

Thickening 
The Thickening filter makes raster objects thicker by the specified num-
ber of pixels. You can choose a combination of thickening directions. 
The following figure below shows the Thickening filtration effect if all 
directions are chosen. The left picture shows the original raster image, 
and the picture on the right shows the result of Thickening filtration after 
three passes. 
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Thickening filtration in all directions 

The figure below shows the Thickening filtration effect if only Vertical 
thickening direction is chosen. The picture on the left shows the original 
raster image, and the picture on the right shows the result of Thickening 
filtration after three passes. 

  
Thickening filtration in vertical direction  

To thicken an object 

 
1. Choose Thickening from the Image menu or press this but-

ton on the Image toolbar. 

 
2. Select the desired thickening direction: Horizontal – by horizontal, 

Vertical – by vertical, All – horizontal, vertical and diagonal. 
3. Choose Apply. 



26 

Thinning 
The Thinning filter makes raster fragments thinner by the specified num-
ber of pixels in the specified directions – horizontal, vertical, and diago-
nal. This filter has a supplementary parameter that allows you to thin 
raster objects to their skeleton (only the pixels in the middle are left). 

  
After thinning up to skeleton 

To thin an image 

 
1. Choose Thinning from the Image menu or press this 

button on the Image toolbar. 

 
2. Specify the desired number of thinning filtration passes. 

- or - 

Select Thin image up to skeleton to convert all the objects to one-
pixel lines. 

3. Choose Apply. 

Four-Point Correction 

This basic kind of image four-point correction (rubber-sheeting) is a 
quick and simple way of aligning mainly technical drawings. This proce-
dure is based upon the assumption that both the outside image frame 
and the image contents are distorted in the same way. 
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To perform this procedure, you need to specify the current locations of 
the frame corner points on the image and the frame size – its width and 
height. If the image contains a drawing frame, RasterID can estimate 
this frame location and corner positions automatically. You can check 
the specified frames visually. The red polyline is the source area on the 
image and the blue rectangle is the destination area. RasterID will then 
try to find the nearest paper size from the Standard Papers list and if 
required, correct the image by the found paper size. You can also 
choose the paper size manually.  

As a result of correction, the image part enclosed by the specified frame 
is transformed so that the frame corner points match the corners of the 
rectangular frame specified, with its sides parallel to the X and Y axes. 

To correct an image by 4 points 
1. From the Tools menu, choose 4-point Correction. The following 

dialog box appears. 

 
2. In the dialog, press the Find frame button. If RasterID is able to find 

the drawing frame you will see a color polygon overlaid on the 
drawing frame. If the polygon is incorrectly positioned you should 
specify these points manually.  

3. To specify the frame corners manually you should press the Meas-
ure button and click the frame corners on the image. You can spec-
ify these points in an arbitrary order because the program always 
sorts them so they form a frame without any intersections. If you 
make a mistake, repeat this step. 
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4. Enter the correct frame dimensions in the Width and Height fields. 
This can be done manually, or you can apply the Find Closest Pa-
per command. If you want to use the internal drawing frame size, 
you have to turn on this checkbox. The internal page frame for a 
particular page format is set in the Preferences dialog. 

5. Click OK to run four-point correction. 

Fit Image to Closest Paper  

To fit an image to the closest paper size RasterID offers two different 
commands in Image menu:  

Fit to Closest Paper – RasterID will automatically select the nearest 
paper size from the Papers list, thus enlarging the image. To modify the 
contents of the Papers list choose Preferences from the Tools menu.  

Resize to Closest Paper – RasterID will adjust the nearest paper size in 
the best possible way. In some cases it may entail cropping a bit of the 
image margins. 

Image Scaling  

The Resample command proportionally scales an image or changes the 
resolution of an image. You can either change DPI with the image size 
in pixels fixed or change the image size in pixels. 

Start the Resample command from the Image menu or the toolbar. The 
Resample dialog box appears. 

 
 
2. Choose measurement units from the combo-box: pixels, centimeters, 
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inches, millimeters, or points. 
3. If you only wish to change the original image size, select the Fixed 
Size in Pixels checkbox. In this case the image dimensions in pixels will 
not be changed, and you can only change image dimensions in millime-
ters, inches, etc. by changing the resolution value. 
Clear rhe Fixed Size in Pixels checkbox to change the image dimensions 
by adding or subtracting pixels. 
4. Change the image dimensions. Enter values in Width and Height  
or change the scale in Scale.  
5. Enter a resolution value in dots per inch (dpi). 
Note: If the measurement units are set in pixels and Fixed Size in Pixels 
checkbox is on, entering a new resolution does not affect the height or 
width values. 

6. Click OK. 

Separating Objects by Size 
When this procedure is running, the program searches in each selected 
image for those objects (isolated groups of image dots) with a size 
within a specified range and moves the areas found to a new raster im-
age. The image created as a result of this operation has the same pa-
rameters (size, insertion point, resolution, scale) as the original image 
but it is placed on a new layer specified by you. This image only con-
tains the objects of the value specified by you. 
This operation allows you to extract raster objects of various sizes onto 
separate raster layers (pages). It can be used instead of a speckle re-
mover filter. There is no loss of data, since objects only move to a dif-
ferent layer, and you can always control the operation performance. If 
you do not need the objects transferred from the original image, you can 
erase the entire raster layer obtained. If any important objects are trans-
ferred to this layer, you can select them and transfer them back to the 
original image, and then remove the unnecessary raster layer. 

To separate raster objects by size 

 
1. Define the selection set you want to process and choose 

Separation by Size from the Image menu or press the but-
ton on the Image toolbar. 



30 

 
2. Specify the minimum and maximum object size in the Min and 

Max boxes. 

 
To measure the size of a raster object on the image, click this button and 
then click on the object. The measured value is displayed in the correspond-
ing box. 

3. Enter the layer name in Layer, where the created image is to be 
placed. 

4. Specify the color of the created layer. Click the color sample next 
to Layer and select a color from the resulting dialog box. 

5. Click Apply. 

Processing Image Parts 
To work only with a part of the currently loaded image you have to set a 
rectangular work area by using the Set Work Area command from the 
Edit menu. You can apply the following operations to an image part: 
• Copy image part to clipboard 
• Cut image part to clipboard 
• Pastes image part from clipboard 
• Erase image part contents 
• Rotate by 90/180/270 
• Mirror by X/ by Y 
• Crop by Work Area 
• Deskew 
• 4-point correction 
• Inversion 
• Speckle / Hole Remover 
• Smoothing 
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• Print 
To work with an entire image choose Reset Work Area from the Edit 
menu. 
To paste the clipboard contents to the image origin choose the Paste 
command from the Edit menu. To paste the clipboard contents to a 
specified position choose the Paste To Position command and specify 
the position on the image. 

Undoing and Redoing Changes 
RasterID always remembers the previous state of your image. If 
you make a mistake or do not like the effect you have created, the 
Undo command can reverse the last action.  

To cancel the most recent action 
• From the Edit menu, choose Undo. 
Cancelling the last action with the Undo command can be redone with 
the Redo command (must be done immediately after undoing). 

To return the image changes cancelled with Undo 
• From the Edit menu, choose Redo. 

Interrupting an Action 
When performing a lengthy operation, RasterID displays the following 
Processing dialog box. 

 
Processing dialog box 

You can use the Cancel button on the Processing dialog box to termi-
nate a time-consuming operation - for example, to interrupt loading, 
saving, or de-speckling. 
Saving Images 
RasterID may save images to files using a wide range of raster file for-

mats. The Save command saves the image in the current file for-
mat. 

To save an image choose Save form the File menu or choose . 
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The Save As command displays a dialog box that allows you to specify 
a new filename, file type and location. 

To save an image to a new file 
1. From the File menu, choose Save As. 
2. Select the required raster file format in the Save as Type list box. 

When the Options button is enabled, you can choose optional fea-
tures for the selected file format. 
For example, if you select TIFF file format and then choose Op-
tions, the following dialog box appears. 

 
3. Select the type of compression. Select the Organization of file data: 

Native, Striped or Tiled, and also, if needed, set Save Thumbnail 
Image to store the quick preview bitmap to the TIFF file header, 
then click OK. 

4. Select the drive, folder and name for the saved file. 
5. Click OK. 
 

Setting Custom Formats for Saving 
You can set the format options and make up a list of formats applied in 
the Save as command. 
• Choose Preferences from the Tools menu. 
• Go to the Raster file formats section and select the formats you 

intend to use.  
You can create a custom format based on an existing one (for which 
the Add button is active). 
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Creation of a custom format based on an existing one 
1. Select a base format in the Preferences dialog, the Raster file for-

mats section. 

 

2. Press the Add but-
ton. Set the name 
and description for 
a new format. Press 
the Options button.  
 

 

3. Set necessary op-
tions in the dis-
played dialog. The 
dialog is different 
depending on the 
base format you se-
lect. 

4. Press OK.  
 
 

The format you have created will appear in the Files of type list of the 
Save and Open commands. 
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Printing Images 
For any given image view, you can print the entire image or a selected 
rectangular area. You can scale your print output and specify the num-
ber of copies to print. The print area can be positioned on the paper by 
defining print margins and alignment. While printing is being prepared, 
the current print area and its location on the paper are displayed on the 
screen. For the multipage type of output, you are shown how the image 
parts are distributed across the individual pages. 
When printing images of different sizes in batch, RasterID offers the 
Nesting option. It provides the optimal images arrangement, thus saving 
paper. 

To print images you need to: 

• Install a printer; 

• Set the print options; 

• Run printing. 

 

Installing a Printer  

A printer must be installed before it can be used to print from RasterID. 
Printers can be installed using Printers from the Microsoft Windows 
Control Panel. To start the Printers dialog you should press the Start 
button on the taskbar and choose Settings/Printers or open Printers 
from the Control Panel. For more information on installing printers, see 
the Windows documentation. With several printers installed, you can 
print RasterID images to any Windows printer device. 
 

Settings Print Options 

From the File menu choose Print Options or press the  on the tool-
bar. 
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In the Print Options dialog:  
1. Select the printer device from the Printer section. 
2. Press the Setup button to change the current printer properties. Set 

new values for margins and alignment in the appropriate fields.  
3. Set scale in the Scale field. 
 Choose Fit to paper to scale the print area as large as possible for 

the specified paper size. 
 To specify an exact scale for the print, select Scaled and type the 

scale (in percent) into the edit box. 
 Select Unscaled (1:1) to print so that 1 millimetre (or inch) on the 

paper will represent 1 millimetre (or inch) on the image. 
4. Specify the page margins in the Page Margins/Alignment fields. 

To specify margins, enter their values in the Page Margins edit 
boxes. The upper left edit box contains the value of the left margin, 
the upper right box – the top margin, the lower left box – the right 
margin, and the lower right box – the bottom margin. Margin values 
are positive. 
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5. If the print output is smaller than the current paper size (one page 
printing), you can specify the print area alignment in relation to the 
paper margins. 
To specify the type of alignment, press the appropriate button in the 
Alignment field. 
If the print output is larger than the current paper size (multipage 
printing), the Alignment field is disabled. 

6. Enter a number of copies in the Copies field and measurement 
units in the Units field. You can choose the pages to print in the 
Pages field. 

While setting up the print parameters you can use the on-screen print 
preview feature to observe how the print is positioned on the paper. The 
figure below shows an example of the on-screen preview for one-page 
printing. The outer frame shows the paper boundaries. 
 

 

For multipage printing, the 
program splits the print out-
put onto several parts. In 
this case the figure below 
shows how the on-screen 
preview may look. 

 

In this case the six frames 
represent the six pages. 
They show the pages with-
out the specified page mar-
gins.  
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To save print options to the template file 
To use the print options in batch and Scan to Print mode it is necessary 
that they be saved to the template file. 

For this press the Template button, chose Save and set the file name. 
By default all template files are saved in the PrintOptions subfolder. 

The Nesting Options 
If you need to print images of different size in batch you can take the 
advantage of the Nesting option for paper saving. 

Select the Nesting option and press the Mode button. 

The Nesting Options dialog will be displayed.  

 
Select the media type: either Roll or Sheet. 

In case you select ‘Roll’, RasterID will consider the media length unlim-
ited and arrange nesting within the given width. Each time after a strip is 
filled, it will be printed.  

In case you select ‘Sheet’, RasterID will try to fill up the whole sheet 
before printing. 
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Images layout (Sheet). Images layout (Roll). Figures 1, 2, 3, 4 refer 

to the paper crop line’. 

• If your image size exceeds the current paper size you may select 
one of the following options: Fit to Paper, Crop by Paper or Cut to 
Pages. 

 
• The Enable Rotating option allows your image to be fit within paper 

width and to optimise nesting of smaller images. 

• In case you select the Print Image Border option, RasterID will print 
a dash-dot line of your image border. Further it may help you cut 
the sheet into individual images. 

• Press OK. 

• After the printing and nesting options are set you should save them 
to the template file for future use in batch printing. 

If the Nesting option is set to on, RasterID will display the Nesting… 
dialog box after plotting a first image. You can visually control the nest-
ing and filling procedures with the capability of interrupting and printing 
the current sheet content before the sheet is filled up. 
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Printing Color Images 

When installing the printer driver most manufacturers supply a set of 
ICC-profiles that is also available at the manufacturer’s web-site. They 
contain typical color transformation tables recommended by the manu-
facturer for the specific printer and media. Scanners and other image 
input-output devices also have their profiles included in the supply pack-
age. They can be also obtained through specialized software as a result 
of your scanner/printer color calibration. 

In the Color Management section set the mode of using color profiles for 
the ‘scanner–printer’ color correction: 

If your printer has a built-in color calibration mechanism, choose Use 
Printer Color Settings. 

To use the standard ICC profiles:  

• Select the Use Standard ICC Color Profiles from the Mode 
combo-box; 

• In the Source field specify the scanner profile; 

• In the Output field specify the printer profile. 
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The Use Standard ICC Color Profiles mode allows for connection of a 
ICC-profile, created with RasterID through ‘scanner-printer’ color correc-
tion (see «Built-in color correction»). 

Built-in Color Correction 

You can perform the «scanner – printer» color correction (create a table 
of matching colors) with RasterID, save it as a standard ICC-profile ver-
sion 4.0 class Device Link and use it when printing color images. 

To perform the «scanner – printer» color correction considering the 
printer properties and media type: 

• From the File menu choose Print Color Table; alternatively press 

the  button on the toolbar. The Print Color Table dialog will be 
displayed: 
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• Select the printer device you require from the Printer field, then 
press the Setup button and set the printer properties. 

• Set the saturation value (in percent). This parameter depends on 
the media type used and allows you to control ink consumption 
when printing an image. For regular thin paper the saturation value 
may range from 60-80%, while glossy thick paper allows for satura-
tion values up to 90-100%. 

• Press OK to print a Color table; the image size doesn’t exceed ISO 
A4 format. 

• After your print is dry (it takes a few minutes) scan it in color mode 
– True Color or RGB, using your scanner. The recommended 
scanning resolution equals half that of your printer. For example, if 
the color table is printed with 600 dpi, it should be scanned with 
300 dpi. 

§ Choose Create Color Profile from the File menu or press the  
button on the toolbar.  
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RasterID will find its color table on the image and create the table of matching 
colors.  

The cube framework corresponds to the standard colors of the 
printed table. The rendered figure displays the colors obtained 
through scanning. 

Based on this information, RasterID will create the table of match-
ing colors for the ‘scanner – printer’ color transfer correction. 

To save the created table of matching colors in the color profile file: 

o Set the name for the created profile in the Save as type field. 

o Press ОК and set the file name. 

The created color table will be saved to file as a standard ICC-
profile version 4.0 class Device Link (connective devices). This 
class is used for direct ‘scanner-printer’ color correction. Generally, 
these files are located in c:\WinXX\system32\spool\drivers\color 
with *.icm (*.icc) extension c:\WinXX\system32\spool\drivers\color 
with extension .ICM (.ICC). These profiles are called general inside 
RasterID. 

The name of the created color profile will appear in the combo-box 
when selecting the Use Device Link ICC profiles mode. 

 
 

Printing Images 

After you have set the required print parameters, press ОК. The created 
settings are saved as default values unless they are changed. 

• From the File menu choose Print or press the  button on 
the toolbar. 

• If you are satisfied with the current printing options displayed in 
the Print dialog, press ОК.  
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To change the current values press the Options button. Then the Print 
Option dialog will be displayed, so you can make necessary alterations. 





 

 

Chapter 4 
COLOR FILTERS AND TOOLS 

Brightness/Contrast 
Brightness sets relative color lightness or darkness. It is usually meas-
ured as a percentage ranging from 0% (black) to 100% (white). 
Modifying contrast enables you to increase or reduce the image bright-
ness range. An image with the same brightness value has zero contrast 
value. If the contrast value increases, it causes an increase of the 
brightness range, i.e. darkening dark colors and lightening light ones. 
Image contrast is measured in percent ranging from 0% (pure gray) to 
100%. Color hue usually means a color, and saturation means color 
purity. You have the ability to completely modify an image color. 
 
Hue is a light wavelength reflected from or transmitted through an ob-
ject. Usually hue is identified by the name of a color, such as red, or-
ange, or green. Each hue has a specific position in the standard color 
wheel and is characterized by a specific angle between -180° and 
+180°. 
Saturation is the degree of color purity. Saturation defines the ratio of 
gray and the specific hue and is measured as a percentage from 0 per-
cent (gray) to 100 percent (fully saturated). 

To modify an image brightness, contrast, hue and saturation 
 
1. Click the  button on the Color toolbar or choose Bright-

ness/Contrast from the Color menu. 
 The following dialog box is displayed: 
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2. Use the appropriate boxes or sliders to modify the value of the 
following parameters: Brightness, Contrast, Hue, and Saturation.  

 The preview window displays the effect of modifying the parame-
ters. You can zoom in and out and show actual image pixels 
(pressing “1:1” button). You can also switch the preview pane off. 

3. Click Apply to run the operation.  

Equalize 
This operation is used for precise adjustment of image brightness, hue, 
and contrast. The algorithm of correction by histogram requires two 
threshold brightness levels to be specified – the brightest and darkest 
pixels, and image gamma that defines the position of the middle bright-
ness value relative to the current threshold values. 
The gamma defines a ratio of the brightness range length between the 
average and the brightest value to the length of brightness range be-
tween the dark threshold and the average value. As a result, the pixels 
with a brightness value below the dark threshold gain a brightness value 
of zero; the pixels with a brightness value above the brightest one gain 
the maximum brightness value (255), and the brightness values of the 
pixels in between are relocated evenly in conformance with their range 
lengths determined by the image gamma. 
The increase of gamma value causes the range for brightness value in 
the dark range to reduce, and therefore it increases the contrast, at the 
same time reducing the contrast in the light hue area, and vice versa. 
The command enables you to redistribute both image pixels average 
brightness and brightness by separate color pixel components (Red, 
Green, and Blue). It enables you to correct image pixel color, for exam-
ple, to turn a pink background to pure white. 
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To correct an image by histogram 
1. Click  on the Image toolbar or choose Equalize from the Color 
menu. 
 The following dialog box appears: 

 

 This dialog box represents the image histogram, displaying the av-
eraged number of pixels corresponding to each brightness value. 
The left part of the histogram corresponds to low brightness value, 
and the right one corresponds to high brightness value (the lightest 
tones). The sliders in the bottom part of the histogram indicate 
threshold values: the left one is for the darkest value, the middle one 
is for the middle value, and the right one is for the brightest pixel.  

 The Levels box provides the numerical expression of the current 
threshold values. You can select one of the four histograms: Master 
displays summary pixel brightness distribution, Red, Green, and 
Blue displays distribution of the corresponding pixels color compo-
nents. Using the Master histogram slides, you can proportionally 
modify the threshold value for all components at once. The Red, 
Green, and Blue histogram sliders modify brightness threshold val-
ues separately for the corresponding color component. 

 The eyedroppers are used to select threshold values and gamma for 
an image. If you select a color sample with the  (or ) eye-
dropper, it defines the threshold value for the darkest (or the lightest) 
for all components equal to the corresponding components values of 
the selected color. If you select a color sample with the  eye-
dropper, it defines the position of the middle tone, and hence defines 
the image gamma. 
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2. Select a histogram corresponding to the color component to be cor-
rected. 

3. Specify the brightness value for the darkest and the brightest pixels, 
and for the image gamma. Use Levels or eyedroppers to do this. 
Use the histogram sliders for precise adjustment. 

 The preview window displays part of the image. Using the preview 
management tools, you can adjust optimal correction parameters.  

 Using the Auto button you can automatically specify the light and 
dark threshold values so that the brightness values of each color 
component not found in the image are cut off. In this way automatic 
correction tries to increase the image contrast as much as possible, 
slightly modifying brightness values. 

 Suppose you want to make the background tone of a map image 
pure white. To do so, you should select a background sample with 
the white eyedropper. The white triangle in the Master histogram 
moves to the position corresponding to the selected color brightness. 
All the pixels with a brightness value above the defined one become 
white. Then suppose you want to turn outlines, which are not pure 
black after scanning, to black. If you select a color outline sample 
with the black eyedropper, all pixels with brightness value below the 
defined one become black.  

 The brightness value of the remaining pixels will be proportionally 
redistributed within the new tone range. As a result, the image con-
trast increases. By moving the gray slider (modifying gamma value) 
you can redistribute the contrast between the light and dark image 
parts. 

4. Click Apply to run the operation. 

You can apply this operation several times, consistently modifying an 
image pixel brightness distribution. 

Binarization and Color Separation  
Binarization and Color Separation are the procedures that extract areas 
of the same color (or falling within the specified color range) to a sepa-
rate monochrome layer. 

Binarization creates monochrome raster images, containing a black-
and-white representation of color objects. For example, from one image 
of a scanned map you can extract and place to separate monochrome 
layers objects of different colors: isolines, roads, rivers, and other ob-
jects. This method provides you with the means to place objects that 
have one or several different colors on the original image, to a separate 
monochrome layer. 
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With Color Separation you can convert a color image to a set of mono-
chrome raster layers. This method guarantees that the black-and-white 
(or monochrome) representation of each pixel of the original image will 
be placed on a certain layer. 

Binarization Basics 
Binarization creates a new monochrome image of a specified color, 
which is placed on a specified layer. Using specific criterion the program 
defines which pixels of the original (color or grayscale) image should 
become black (foreground pixels), and which ones should become white 
(background pixels), and then generates a monochrome image and 
places it on a new raster layer. The criterion for division of pixels into 
two sets is defined by the selected binarization method and its parame-
ters (threshold values or a color range), specified in the Binarization 
dialog box.  

To binarize an image 

1. Click the  button on the Color toolbar or choose Binarization 
from the Color menu. 

2 In the dialog window select a method and adjust its parameters. 
1. Click Apply. 

Binarization applies various conversion algorithms, which are called 
binarization methods. The chosen conversion method should be appro-
priate to the image type.  

Threshold by Gray  
Threshold by Gray converts color pixels with brightness values above 
the specified level to background dots, and pixels below this level to 
image dots. 
This method may be used for converting both color and grayscale im-
ages. When converting a grayscale image, RasterID uses its gray lev-
els. When converting a color image, the gray levels are defined by the 
brightness value of color dots. 

Threshold by RGB 
When using Threshold by RGB, you should define three threshold levels 
for the Red, Green, and Blue components. RasterID converts color dots 
with Red, Green and Blue values below the appropriate threshold levels 
to black dots (image dots). 
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Range by Gray 
Range by Gray allows you to convert color pixels with any brightness 
value to image dots. Using this method, you first specify a number of 
basic levels of gray. These levels are used as midpoints for ranges. For 
each of the specified levels, you can define a range half-length. A range 
half-length is the number of gray levels below and above the specified 
gray level. 
Range by Gray converts pixels that have gray values within all specified 
ranges to foreground dots. The other pixels are converted to background 
dots. 
This method may also be used for converting color and grayscale im-
ages. Gray levels for color dots are calculated as described in Threshold 
by Gray. 

Range by RGB 
With this method you can convert color pixels of the specified RGB 
ranges to image dots.  
To specify an RGB range you should first select a central range color. 
The Red, Green, and Blue components of this color define the position 
of the RGB range central point. For each of the color components (R, G, 
and B) you should specify the appropriate range half-lengths. The range 
half-length for R, G, or B component is a number of R, G, or B levels 
below and above the selected R, G, or B level. For example, if the R 
level of the selected color is equal to 50 and its range half-length for R 
component is equal to 10, then the RGB range includes colors with the 
R components from 40 to 60. 

Range by HSV 
This method allows you to convert pixels of analogous colors to image 
dots. Analogous colors are closely related colors in the human percep-
tion of color, e.g. red - orange, dark green - light green, etc. 
To convert an image using Range by HSV, you should specify one or 
more HSV ranges. The HSV range is defined by a selected color and H, 
S, V range half-lengths. The HSV range is similar in design to the RGB 
range described above. Note that Hue is expressed as an angle between 
0° and 360°, Saturation and Value are measured as a percentage from 
0 to 100. 

Binarization Dialog Box 

To open the Binarization dialog box 

Choose Binarization from the Color menu or click the  button on the 
Color toolbar. 
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The controls and buttons described below are the same as the Thresh-
old and Range tabs of the Binarization dialog box. 

Preview window 

This window dynamically displays the results of binarization on an im-
age part. Note that if you choose a color sample in the preview area 
with an eyedropper, the preview window marks the position of the se-
lected pixel with a cross. The current position of the preview window is 
shown as a red frame on the image. 

Noise Reduction 

This slide sets the sensitivity of the binarization algorithm to small de-
tails in the image. If the level of noise reduction is set to maximum, the 
quantity of raster noise and holes in the obtained monochrome raster 
image is reduced. However, the high level of noise reduction decreases 
the binarization quality of small and thin details, such as texts, thin 
lines, etc, since small details can be mistaken for noise.  

By 

Depending on the chosen tab, this list allows you to select a binarization 
method. For example, if the Range tab is chosen, you can choose 
Range by Gray, Range by RGB or Range by HSV. 

Channel 

You can choose a color information channel type from this list. The term 
color information channels stands for the information on the color com-
ponents of image pixels by a certain color representation model. 

The number of available channels depends on the image type. Every 
color image has five channels: Red, Green, Blue, Hue and Gray. For 
grayscale images only the Gray channel is used. 
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Channel histogram window 
The histogram of the selected channel is displayed in the Channel list. A 
histogram is a graphic representation of a color component value distri-
bution by image pixels, defined by a selected channel. A component 
value is measured along the horizontal axis of the histogram. Along the 
vertical axis a normalized number of pixels with the specified color com-
ponent value are placed. Thus, histogram extremes correspond to the 
most frequent component values, and the minimums correspond to the 
least frequent values. 

Depending on the selected binarization method, either one or three tri-
angular sliders may appear in the bottom part of the histogram. These 
sliders allow you to adjust parameters of the current binarization 
method, i.e. to specify range parameters and a threshold level. 

Layer 

This allows you to specify the name and color of the layer, on which a 
monochrome image will be placed after binarization. 

Apply 

Starts the binarization procedure. 

Template 

This is used to store and load all the parameters for all the binarization 
methods. 

Dialog box tabs 
There are two tabs in the Binarization dialog box: Range and Threshold. 
The first one is used to specify parameters for the binarization range 
methods; the second is used to specify parameters for threshold meth-
ods. 

Range tab 
This is used to tune the following range methods: Range by Gray, 
Range by RGB or Range by HSV. 

Colors  
This list shows information about the central colors of a specified range 
and allows you to select a range for correction and deletion. The left 
part of the list shows a sample of the selected color (or gray tone), and 
the right part shows the color component values in the current color 
model (gray level for grayscale images). To select a range, specify its 
appropriate color in the Colors list. 
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Above this list there are three eyedropper buttons, these allow you to 
create new ranges. 

 
Color selection allows the creation of a new range by select-
ing a color in the image.  

RasterID creates a new range, using the color of the specified pixel as 
the central range color. 

 
Averaged color selection allows you to create a new range 
by choosing an average color in the area around the se-
lected pixel. 

RasterID calculates the average color value in the area of the specified 
pixel and creates a new range, using the calculated color as the central 
range color. The half-lengths of the created range are automatically ad-
justed to take the close colors, found in the specified pixel area. 

 
Area averaged color selection allows the creation of a new 
image by calculating the average color of an arbitrary area 
in the image. 

Click this button and specify the boundary of a polygonal area. Com-
plete the area selection with a double-click. RasterID calculates the av-
erage color value in the specified area and creates a new range, using 
the calculated color as the central range color. The half-lengths of the 
created range are automatically adjusted to close colors, found in the 
specified pixel area. 

Ranges 
Using this box you can change the half-lengths of a range, selected from 
the Colors list. The type, name and number of sliders and boxes depend 
on the current conversion method. For example, if you choose Range by 
HSV, the following sliders and boxes are displayed: hue – H, saturation – 
S and brightness – V. 

If you choose Range by Gray, there is only one slider and one box to 
enter the half-length of the brightness range. 

Sliders of channel histograms 
This tab has three triangular sliders on the histogram channels corre-
sponding to the selected binarization method. These sliders allow you to 
change the central color components (gray central level) and the half-
length of the range selected from the Colors list. 

If you choose Range by HSV, the sliders on the channel Hue histogram 
appear, the selection of Range by RGB causes the appearance of slid-
ers on the Red, Green and Blue histograms. If you choose Range by 
Gray, the sliders appear on the histogram of the Gray channel. 
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Threshold tab 
This is used for binarization with Threshold by Gray or Threshold by 
RGB. 

Threshold 
This tab displays the specified threshold values of the current method of 
threshold binarization. To modify a value, move the corresponding 
slider.  

 

Sliders of channel histograms 
One triangular slide appears on the channel histogram corresponding to 
a certain binarization method. This slider allows you to modify the 
threshold value of a color component or gray level. 

If you choose Threshold by HSV, the sliders appear at the Red, Green 
and Blue histograms. If you choose Range by Gray, the slider only ap-
pears at the histogram of the Gray channel. 

Tuning Binarization  
To fine-tune the binarization procedure you should choose an appro-
priate method. The selected method type defines a customizing method. 
For each of two threshold methods you should specify one or three 
threshold values at the histogram. You should also specify a set of 
ranges of the corresponding types that contain the extracted colors. 

Besides, for any method you should also specify a layer to place an 
image, obtained after binarization. 

To tune threshold binarization 
1. Choose the Threshold tab from the Binarization dialog box. 
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2. From the By list choose an appropriate method. 
3. Tune the threshold values for the selected method. 

When tuning, use the preview window of the Binarization dialog box 
to observe the results of parameters modification. Note that an im-
age preview in scale 1:1 provides the most reliable results.  

 
If you selected the Threshold by Gray method, choose Gray in the 
Channel list to see the gray level histogram. Specify a threshold 
value with triangular or G sliders. 

If you selected the Threshold by RGB method adjust the R, G, B 
threshold values. For this purpose you can also use the triangular 
sliders on histograms of Red, Green, and Blue channels. 

4. Use the Noise Reduction slider to adjust noise reduction and im-
prove binarization quality. 

 By default this parameter is specified as an average value. If you 
binarize large filled areas, decrease this parameter value (close to 
Lo mark) to reduce the quantity of raster speckles and non-filled 
holes when binarizing objects. 

 If you try to get a monochrome layer, containing images of small or 
thin objects – texts, characters, isolines, or a grid, increase this pa-
rameter value to prevent these small objects, caused by noise reduc-
tion, from being thinned and distorted. In this case, the noise level of 
the obtained image increases. 

5. Select a name and monochrome image color for the layer on which 
the binarization results will be placed. 

 Enter a name in Layer. To define a color, click on the color pattern 
and choose a color from the box, click OK.  
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To tune binarization using the range method 
1. From the Binarization dialog box, choose Range. 

2. From the By list, choose the required type of range method. 

 Set the parameters of the chosen method. 

When tuning, use the preview window of the Binarization dialog box 
to observe the effect of changing the parameters. Note that you ob-
tain the most reliable results on viewing the image at a scale of 1:1.  

3. Specify a set of ranges capturing the colors (gray levels) of the color 
image objects that you want to move to a separate monochrome 
level. 

 To do this, create the required number of ranges, using the eyedrop-
per buttons and watch the result of adding each range in the preview 
window. If the range addition results in unwanted image pixels being 
captured, try to modify the range parameters using the Ranges box 
or the channel histogram sliders. If you cannot obtain acceptable re-
sults, delete the range using the Remove Colors button. 

To add a range 

Click the  or  button and point to a pixel you want to bi-
narize. 
- or - 

Click the  button and choose an area on the image that you 
want to binarize. 
An element related to the created range appears in the Colors list. 

To change the created range parameters 
Use the sliders and boxes of Ranges, or channel histogram sliders.  

To delete a range 
Click on an element corresponding to the range you what to delete in 

the Colors list and press the Remove Color  button. 

Adaptive Binarization 
Binarizing images on which the noise and speckles are spread un-
evenly, such as on aged or dirty blueprints, produces poor results. The 
Adaptive Binarization tool from the Color menu combines binarization 
with smoothing. The program analyses the level of noise in the proc-
essed area and does its best to extract the useful data.  

This command is only applicable to grayscale images. 
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This tool only has three controls: 
1. Radius – sets the radius in which the program analyses the level of 

noise to be cleaned. Generally the best results can be attained by 
setting the Radius value approximately two times thicker than the 
thickest linear object on the image. 

2. Binarize – binarization using Threshold value. The method used – 
Threshold by gray – is described in the previous section. 

3. Smooth – the smoothing process is described in the “Smoothing” 
section (see page 49). Using smoothing with the Binarize checkbox 
set to off produces a cleaner image with the background evened 
and line objects revealed. 

There is no general rule for obtaining the best results. It is recom-
mended that several combinations of these controls be explored on 
each image. 

Color Separation Procedure 
This procedure is used to separate color image dots in non-overlapping 
sets. The objects of one sort are usually marked with the same color; 
therefore we are able to separate image objects using their color proper-
ties.  

The first step of specifying separation parameters is to define a set of 
object categories in the original image. Each category is based on a set 
of basic colors. The dots that have these colors or colors close to these, 
fall in the same category (at least one basic color for each category must 
be specified). For example, a category set may be the following: back-
ground, isolines, roads, railways, buildings, vegetation, rivers, etc. You 
can specify up to 255 categories. Each category has two properties: 
name and symbolic color. 

A symbolic color is used to display dots, belonging to a certain category.  
This color is shown in the preview window during the adjustment of sepa-
ration parameters. It is also assigned to the monochrome layer to which 
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the dots of this category are transferred. A symbolic color does not need 
to correlate with the color of extracted objects. 

On layering, the program places the dots of each category in a separate 
monochrome image. The program assigns the specified new color to all 
dots belonging to the same category. The original color image is left 
unchanged on its own layer.   

To perform Color Separation 

1. Click the  button on the Color toolbar or choose Color Separa-
tion from the Color menu. 

 
 

 
2. Create a category set, using the Create Category button as 

described below in this section. 

 

If you want to modify a category definition or delete a cate-
gory created by mistake use the Delete or Modify buttons. 

 Use the preview tools to view the effects of changing the parame-
ters. Note that an image preview at a scale of 1:1 provides the 
most reliable results.  

3. If you are not satisfied with the separation results, try one of the 
following suggestions: 

 Modify the basic colors in each category. Note that you should 
specify a sufficient number of base colors, describing each cate-
gory. You should select color samples both from the middle and 
the boundary of the object. 

 - or -  
 Use the Noise Reduction slider and De-speckle option to redistrib-

ute dots by categories. 
4. When you are satisfied with the quality of separation, click the Ap-

ply button. 
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Tuning Color Separation  

Category attributes and basic colors are specified in the Color Separa-
tion dialog box. The Categories section contains a list of specified cate-
gories, and buttons that allow you to create, modify, and delete category 
definitions. The Colors section displays a list of the basic colors within a 
category and buttons that allow you to add or delete the basic colors of 
a selected category. 

To add a new category 
1. Click the  – Create category button in Categories. 

2. Specify with the eyedropper tool the object in the image, the dots 
of which should fall within the new category. 

 The Layer Name and Color dialog box will be displayed. 
 Here you can specify the name & symbolic color for the category. 
3. Click OK. 
 In the Categories list a new category appears, and in the Colors list 

the color selected from the image is shown. 
 If you make a mistake when specifying a category, delete its defini-

tion or modify its symbolic color and name. 

To delete a category definition 

 1. Select a category from the list of Categories. 
2. Click Delete. 

To modify the name and symbolic color of a category 

  1. Select a category from the Categories list. 
2. Click the Edit Category button. 

 The Layer Name and Color dialog box will be displayed. 
3. Enter a new category name in Name and/or select a symbolic 

color from the palette. 
4. Click OK. 

 Note that when a category definition is modified, its set of basic 
colors does not change. 

To add a basic color to a category  
1. Select the required category from the Categories list. 

The current set of basic colors for the selected category will 
appear in Colors. 

  2. Click the eyedropper button in Colors and specify a 
point on the image. 

The selected color will be added to Colors. 
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If you make a mistake when selecting a basic color, it can be de-
leted. A mistake in color selection is detected by examining the 
separation results shown in the preview window. 

To delete a basic color from a category  
1. Select the required category from the list of Categories. 
2. Select the required base color from the list of Colors.  

  3. Click Delete. 

To adjust separation sensitivity to small objects 
Use the Noise Reduction slider and De-speckle option. 
By setting the De-speckle option to on, you can eliminate the influ-
ence of noise and small objects during the color analysis procedure. 

Color Reduction 

This procedure is similar to that of color separation, described on page 
50. The only difference is that you do not have to specify categories 
names, since color reduction does not cause the creation of additional 
layers. 

To open the Color Reduction dialog box 

Click the  button on the Color toolbar or choose Color Reduction 
from the Color menu. 

 
This procedure is performed in the same way as the color separation 
procedure. The functions of this dialog box are the same as those of the 
Color Separation dialog box. 
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Conversion to RGB, Grayscale and Indexed Colors 
Converting an image from monochrome to color or grayscale allows you 
to apply color filters such as Blur to the image or the selected layer.  It 
also allows you to prepare an image (or selected layer) for further proc-
essing in other applications. 

Blur 
This filter produces a blur effect on the image, giving the impression 
that it is slightly “out of focus”. Blur filtration reduces image clearness, 
but makes image areas with texture fills more even. This procedure can 
have a positive effect on further binarization or image color separation. 

To calculate pixel color the program replaces its color value by the av-
eraged value of the area. Area pixels color characteristics are consid-
ered with weight function; two-dimensional Gaussian distribution with 
the centre located in the current pixel is used for this purpose. 

Radius is the only filter parameter. The increase of its value produces a 
stronger blur effect. 

To blur an image 

1. Click  on the Color toolbar or choose Blur from the Color menu. 

 The following dialog box is displayed: 

 

2. Type values from 0.1 to 10.0 in the Radius box to specify the blur 
level. The increase of its value produces stronger blur effect. 

3. Choose Apply to run filtration. 

Blurring with a large Radius coarsens the image and removes details. 
The blur effect is reduced as the Radius setting is reduced. For more 
control when using the blur filter, you should run the filter several times 
with a small Radius value, using the Apply button.  
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Adaptive Blur 

1. The Adaptive Blur command is used for intelligently “de-
screening” images. This filter tries to keep sharpen borders be-
tween different colors while smoothing similar color areas. See 
pictures (Original, Blur R3.5, Adaptive Blur R3.5).  

       
 
To adaptively blur an image 

 1. Choose Adaptive Blur from the Color menu or click  the  but-
ton on the Color toolbar. 

2. In the Adaptive Blur dialog box type values from 0.1 to 10.0 in 
the Radius box to specify the blur level or use the slider.  

3. Observe the effect of the command in the Preview window. 

4. Choose Apply to run filtration. 
 

Unsharp Mask 
This filter seeks color transition boundaries in the image and improves 
their sharpness. 

The filter modifies pixel contrast on color transition boundaries, produc-
ing an overall increase in image sharpness. This filter can be used for 
correction of images that became blurred after interpolation, for exam-
ple, after such operations as scale, resolution modification or calibra-
tion. 

To increase outline sharpness 
1. Click the  button on the Color toolbar or choose Unsharp 

Mask from the Color menu. 
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 The following dialog box is displayed: 

  
2. Enter a value in the Sensitivity box or use the appropriate slider to 

specify the desired effect of the filter application in percent from 0 
to 100. The effect of the filter application becomes stronger as this 
value is increased. 

3. Enter the Radius value.  
 The higher the Radius value you specify, the more pixels surround-

ing the color transition boundary will be processed. Low radius val-
ues only increase the sharpness on the boundaries.  

 Viewing the results in the preview window should allow you 
achieve the optimum parameter value for the entire image. 

4. Choose Apply to run filtration. 

Median 
Median filtration reduces an image noise, by analyzing all pixels within 
the specified radius and giving the central pixel the averaged value of 
the reviewed pixel characteristics. As a result, the extremes of pixel 
color and brightness are depressed and the image looks slightly blurred. 

To use median filtration 
1. Click the  button on the Color toolbar or choose Median from 

the Color  menu 
 The following dialog box is displayed: 
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2. Specify a Radius value from 1 to 5. This value determines the area 

(in pixels) within which the filter is to review color values. 
3. Choose Apply to run filtration. 

Gamma Correction 
This tool is used to enhance the overall quality of an image by changing 
its so-called “color profile” - i.e. it applies an algorithm that changes the 
distribution of brightness.  

Every image has a brightest point (“white” point) and a darkest point 
(“black” point). The points that have intermediate values of color inten-
sity are usually distributed unevenly, forming a curve of arbitrary shape. 
Gamma value defines the slope of the curve halfway between black and 
white. Using the Gamma Correction tool you can make points that fall in 
the specified range of brightness brighter or darker. You can also influ-
ence the brightness of Red, Blue or Green colors. 

To change color profile 
1. Click the  button on the Color toolbar or choose Gamma Cor-

rection from the Color menu. 
 The following dialog box is displayed: 
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2. Specify white and black points using the relevant eyedropper tools. 
3. Choose Master or specify a color in the Channel list. 
4. Create Gamma curve automatically or adjust it manually (see de-

tails below). Watch the results in the preview window. 
5. Click Apply. 

Specifying black and white points 

Use the  or  buttons to pick black or white point values directly 
from the image. The Color point section of the Gamma Correction dialog 
allows you to adjust color values precisely. 

The Autoset button  calculates the black and white point values 
automatically for every color channel. The histogram in the middle of 
the dialog window reflects color brightness distribution. You can change 
the curve for every channel separately. 

Click  to reset the gamma curve. 

Changing gamma curve 
There are three methods of changing the shape of the Master gamma 
curve and curves for individual channels. These methods are interre-
lated. 
1. Check or uncheck the S-Curve box. S-curve is a form of gamma 

curve that is always symmetrical around the central point of distri-
bution range. This implies that when adding brightness to dark ar-
eas we automatically darken bright areas to the same extent, cre-
ating a more balanced brightness for the human eye. If S-Curve is 
unchecked you can create a gamma curve, shifting the overall bal-
ance of brightness in the resulting image. 

2. Enter a value in the Gamma box. This changes the curves’ slope. 
3. Drag the Master curve or curves for individual channels in the his-

togram window. 
 When Master is selected in the Channel list, all curves are shown 

(at first you see them as a single white curve since curves for color 
channels overlay).  

 When you place the mouse pointer over the curve you will see a 
bold point that you can drag to change the shape of the curve. 
While keeping the mouse pointer over the curve, you can also see 
the real distribution of color brightness on the image. 

 To change the shape of curves for the Red, Blue or Green chan-
nels, select the corresponding color name from the Channel list. 



66 

Image Classifier 
This versatile tool allows you to manage the colors within the image.  It 
is not applicable to monochrome images. You can reduce the palette by 
deleting the selected color or colors or by merging several colors into 
one. 

You can also replace selected colors and add them to the palette. 

To open Image Classifier dialog 
1. Click the  button on the Color toolbar or choose image Classi-

fier from the Color menu. 

 
 

The buttons and controls in the Image Classifier dialog win-
dow 

 Color samples 
table 

This contains color samples of the 
current palette. Select a color by 
clicking on its sample. Clicking while 
holding down SHIFT selects multiple 
colors. In the bottom of the table 
there is a progress bar. 
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 Color counter This control is used to show the 
number of colors in the current pal-
ette. You can increase or reduce this 
number. 

 
Set auto palette 
button 

By pressing this button you force 
RasterID to reset the palette. 
RasterID automatically determines 
the set of colors that most truly 
represents the image and places 
them into the color samples table. 
Their number is reflected in the color 
counter. 

 
Recalculate pal-
ette button 

Restores the native palette of the 
image. 

 View Selection  When this box is checked, the points 
of selected colors are shown on the 
image.  

 
Choose a color 
from the image 

This tool is used to obtain a color by 
clicking on a pixel in the Preview 
window or the document window. 
The color of the selected pixel will be 
highlighted in the Color samples ta-
ble. 

 
Select colors from 
the image 

This tool is used to obtain colors by 
drawing a polygon around an area in 
the Preview window or the document 
window. Double-click to finish the 
polygon. The colors contained within 
the polygon will be selected in the 
Color samples table. 

 
RGB button Opens the color selection dialog, 

which lets you replace the currently 
selected color with a new one. The 
image is regenerated with the new 
palette. 

 
Merger button Merges the colors selected in the 

color samples table to the mean 
color. The image is regenerated with 
the new palette. 
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Delete button Deletes the colors selected in the 

color samples table from the palette. 
The image is regenerated with the 
new palette. 

 Save LUT Saves the current palette in a Look-
Up Table (LUT) file. 

 Load LUT Loads the current palette from a 
Look-Up Table (LUT) file. 

 Template You can save and load color palette 
information to and from a template 
file using this button.  

To create a palette automatically 

 Press Set auto palette button . 

 - or -  
 Reduce the number of colors in the Color counter and press the 

Recalculate palette button . 

 The palette will automatically be recalculated and the image will be 
regenerated to reflect the changes. 

To recalculate the palette 

 Press the Recalculate palette button . 

 The palette will be recalculated to fit the number of colors set in the 
Color counter spin-box in the best way. 

To select a color from the image 

1. Click the  button to select a color. 

2.  Click on a point in the image. The color of this point will be high-
lighted in the Color samples table. 

To select several colors within an area 

1. Click the  button to select an area in the image. 

2.  Draw a polygon around the desired area in the image. Double-click 
to close the polygon. The colors within the polygon will be selected 
in the Color samples table. 

To delete a color from palette 
1. Select the color(s) to be deleted in the color samples table clicking 

on them with SHIFT pressed. 
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2. Press the Delete button . As each color is deleted the image is 
automatically regenerated. 

 You can also reduce the number of colors by setting the number of 

colors in the Color counter and pressing the  button. 

To add or replace a color in the palette 
1. To replace a color, click on the color sample to replace, or to add a 

color select an unoccupied space in the color table. 

2. Press the RGB button  and choose a new color from the color 
selection dialog. 

 - or -  

 Pick the color from the image with the eyedropper tool . 

To merge colors 
1. Select the colors to be merged in the color samples table by click-

ing on them with the SHIFT key pressed. 

3. Press the Merge Colors button . As the colors are merged the 
image is automatically regenerated. 

Drawing on a Raster Image 
RasterID has special drawing tools that enable you to make minor 
changes to the graphics on a raster image. These tools are applicable 
to both monochrome and color images. 
Choose the Draw command from the Tools menu. 
The buttons and controls of the Draw toolbar:  
Using the Fonts dialog you should specify the text parameters for en-
tering text. This dialog is displayed automatically after selecting the text 
tool. 
Using the Line Widths dialog you should specify the line width for draw-
ing. This dialog is displayed automatically after selecting the drawing 
tools. 

 
To draw an arbitrary line with the pencil tool: 
§ Specify the line width. 
§ Press the mouse button (left or right – see below), 

specify the first endpoint and keep it pressed while 
drawing a line; release the button at the other endpoint 
of the line. Using the left mouse button causes your line 
to be drawn with the foreground color, while the right 
mouse button produces the background color. 
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Erasing with the current background or foreground color. 

 
To floodfill with the current foreground or background color: 
§ You should specify a closed area to floodfill. 

 
To select colors on the image: 
§ Specify a point with the required color on the image.  
§ Press the left mouse button to select the foreground 

color; or the right button – to select the background 
color. 

 
Drawing a line by two points. 

 
Drawing an arc by two points. With the opthogonalization 

mode  turned on your arc will be half a circle. 

 
Drawing a rectangle by two points. 

 
Drawing a rectangle with the foreground color floodfill. 

 
Drawing a circle by two points. 

 
Drawing a circle with the foreground color floodfill.  

 
The orthogonalization mode. 

 
To enter a text: 
§ Press this button and set the text parameters in the 

displayed Fonts dialog; 
§ Specify the text position on the image – an insertion 

point and a rotation angle with the mouse button 
pressed.  

§ Type a text from the keyboard. 
§ Press Enter. 

 
To set the text size on the image: 
§ Specify the text size with a rectangle area on the im-

age; 

§ Press the  button. 
§ Set the text position (insertion point and rotation angle). 
§ Type a text from the keyboard. 
§ Press Enter. 

 
Setting the line width on the image. 
Press this button and specify a point with desired size on 
the image with the mouse button pressed; then RasterID 
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will be drawing with the size you have specified.  

 

A foreground color is displayed in the front square; a back-
ground color is displayed in the back square. 
 
 
The Color palette for selection.  
To select a foreground color you should pick a required 
color and press the left mouse button. 
To select a background color you should pick a required 
color and press the right mouse button. 

 





 

 

Chapter 5 
BATCH PROCESSING AND INDEXING 
Batch image processing makes it possible to apply a sequence of opera-
tions to a number of images unattended. RasterID can automatically 
process a group of images and then re-save them to the same file or to 
separate files. All you have to do is create a batch job and then run it. 

The purpose of indexing is to obtain unique information about each im-
age to enable automatic identification of them, and to add this informa-
tion to your database. 

Indexing is a two-step process of searching and recognizing title blocks 
on raster images and transferring this recognized data to an external 
database, EDM-system or user defined file. For example, if you have 
MS Excel on your computer RasterID can transfer the title block con-
tents to an Excel table.  

A title block is a set of fields that contain text strings and is usually lo-
cated at one of the corners of the raster image. RasterID can find title 
blocks and recognize texts in the fields through the internal OCR engine. 
RasterID also has the capability of connecting to an external OCR-
Engine (see “Programming guide”). 

Before running indexing you have to create a title block template. If your 
images contain different types of title blocks you will have to create a 
unique template for each one. Every title block must be saved as a 
named template for further use when indexing. 

Creating Title Block Templates 
To create a new title block 
1. Open an image file containing the title block you want to train. 

2. The image must be oriented correctly. Use the Rotate command to 
change the image orientation. 

3. Check that orthogonal lines are parallel with the image margins. If 
necessary apply the Deskew command. 

4. If the image is “dirty” you need to apply the Speckle/Hole remover. 

5. Set the zoom level so that all fields of the title block are visible on 
the image. 

6. Choose the Train Title Block command from the Tools menu. The 
Train Title Block dialog box appears (see next page). 
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7. Click the  button and draw a rectangular area on the image 
containing the entire title block. If RasterID is able to recognize the 
title block topology it creates a list of fields and defines its location 
and geometrical parameters. RasterID detects the corner position 
of the title block automatically. To change the title block position you 
should click on one of the corner buttons. The fields are automati-
cally named as “Field+Number” and sorted into order, starting with 
the top left corner. Title block fields are highlighted by colors speci-
fied in the Preferences dialog. 

Recognizable fields are highlighted in color; unrecognizable fields 
are filled with a cross hatch. You can toggle recognizable/ unrecog-
nizable field status by clicking directly on the field. 

8. To correct the title block topology you may delete the selected field 
or draw a new one. You should first delete all incorrectly recognized 
fields, then draw in any unrecognized ones. 

9. To delete a field, select it and click the  button. Repeat this op-
eration for each incorrectly recognized field. 

10. To draw a new field click the  button, click on the top left corner 
of the field and then the bottom right corner. RasterID tries to snap 
to the intersections and nearest points of the neighbouring fields. 
When such a point is found the cursor changes type and becomes 
U-shaped.  

11. When you have created the correct title block topology you have to 
fill in the title block name field in the dialog box. This name will be 
used for identification of the recognized title block during the index-
ing process. 

12. The checkbox in the header row of the 
Fields list is used to select or unselect 
all fields with one click. If the title block 
has a lot of recognizable fields, you 
should check this box and then ex-
clude unrecognizable ones. If the title 
block has a lot of unrecognizable 
fields, you should uncheck this box 
and then add recognizable ones. 
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13. Measure or input manually the maximum Text Height into the field. 

This parameter is equal to the largest upper case letter in the title 
block and will be used for text recognition. To measure the Text 
Height click the  button and then draw a line through the largest 
raster character on the image. The Text Height value will be equal to 
the distance between the first and the last points of the image within 
the drawn line.  This value should not be more than the maximum 
vertical size of the title block fields. Set the Letter Angle or measure it 
with the  tool. Use this option when recognizing italic or skewed 
text, if the chosen OCR engine cannot parse such text. A Letter Angle 
of 90 degrees corresponds to text rotated to a vertical position.  

14. You can mask out areas of the title block, which contain text that 
you do not want RasterID to recognize. Press the Set Text Mask 

button  and draw a rectangle around the unwanted texts in the 
title block. Each field can contain several text masks.  

15. Commands Draw Field and Set Text Mask are cycled to draw a few 
of rectangles. When Draw Field command is running you can turn 
on/off snapping using CTRL button and mouse.  
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For example, if your title block contains standard fields named 
“DwgNo”, “Sheet” and “Data” and you do not want to recognize and 
export these texts, you should set masks for these areas (see the 
hatched areas in picture below). 

 
The recognition results will be as follows: 

 

Use the  button to delete unnecessary text masks. 

16. Select the OCR template. This is a file of character template librar-
ies, which is used when recognizing text. Character templates are 
topological models of text characters (letters, special symbols etc.), 
with which raster text characters are recognized. The list contains 
the DEFAULT.OCR file, included in the standard RasterID package. 
Using the "default" file, the OCR module can recognize characters 
of the English alphabet, digits, signs, punctuation marks and spe-
cial symbols (the first half of ASCII table). You can also create your 
own OCR template file (see OCR training). 

17. Each field of the title block can be renamed. (This name may be used 
as the heading of a column in a MS Excel spreadsheet or the name of 
a database field). You can change the field orientation if it contains 
non-horizontal text. 

18. To recognize the text in the field you should turn on the checkbox 
for this field and specify a set of word patterns. If you turn off this 
checkbox, any text in the field will not be recognized. Word patterns 
must be specified if you want to use the built-in OCR engine. A 
word pattern is a rule specifying the allowed sequence of characters 
within one recognized word. If you do not specify any word patterns 
for the field but turn on its checkbox, the OCR engine will apply de-
fault patterns. This is “%D” – digits, “%E” - English capital letters 
and “%1E%e” – names. Use Add and Delete to edit the list of word 
patterns definitions. To add a new pattern you need to fill in the Pat-
terns field in the Dialog box or right click the mouse button while 
over the Patterns field. The Right-button menu appears and you 
can select the required patterns from the list (see picture).  
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Note If you want to ignore some of the words when recognizing text, 

you should add the ignored word with the prefix %K (means key-
word). For example, if a field contains the text: DWG NO 12345 
but you only need to recognize the number you should add the fol-
lowing patterns: %D – to recognize numbers, %KDWG, %KNO – 
to ignore these keywords. RasterID will try to recognize these 
words but it will not export them to your database. 

Here is a formal description of word pattern definitions: 
" [% [length] character type] || [letter]] … " 

 [%] Beginning of character sequence definition 
[length] Any decimal number; absent if length is variable 
[type] Character type (D,E,e,N,n,S,K) 
[letter] Standalone letter 

Symbol type is specified in the following way:  
D Digits 
E Upper case letters of the English Alphabet 
e Lower case letters of the English Alphabet 
N Capital letters of national alphabets, for example 

Russian 
n Small letters of national alphabets, for example 

Russian 
S Special characters (signs plus and minus, sign 

of equality and etc.) 

Kword Ignored word.  

%% Standalone characters "%" 
[characters] Standalone characters  
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For example: 

� The template "DWG%D" allows generation of words that start with " 
DWG", followed by any sequence of digits, for example, 
"DWG400", " DWG22", " DWG7000023". 

� The template "%1N%n" allows generation of words of the national 
alphabet with a capital first letter. 

� The template "%E%D" allows generation of words containing any se-
quence and number of English capital letters, followed by any se-
quence of digits, for example, "R400", " C22", "NUMBER283". 

19. If you are not sure whether all your images have the correct orienta-
tion, turn on the checkbox Arbitrary Oriented Paper. RasterID will 
search for your title block at each corner of the image. 

20. To save your title block template to file, choose Template / Save 
and specify the file name. This name will be used during the index-
ing process. To edit the existing template choose Template / Load 
and select the required template from the list. Repeat the required 
operations. 

 

 

 

Other Options of  Train Title Block dialog 
 

Using an External OCR Engine 

If you have a RasterID package containing a third-party OCR engine 
and you want to use it, turn on the checkbox Use External OCR Engine.  

 

 

Press the  Setup OCR Pro button and the OCR Engine Setup dia-
log box will appear. Use of the external OCR engine is controlled in the 
Preferences dialog box. The  button opens the training dialog, if 
training is supported by the OCR module. 
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Non-Rectangular Topology Options 

 

This is used for title blocks that have 
structures similar to those shown in the 
pictures below. For example, title blocks 
containing fields with rounded corners or 
title blocks consisting of horizontal lines 
only. Do not use this mode for title blocks 
that have a simple regular topology. 
If the title block is aligned to the corner of 
the drawing frame, checking the Drawing 
has frame checkbox will increase the 
quality and precision of the recognition 
process. If the Arbitrary Oriented Paper 
option is selected, RasterID checks if the 
title block is located in another corner as 
the sheet might have been incorrectly 
positioned in the scanner. Search Isolated 
Texts checkbox  is useful if the drawing 
contains text areas outside the title block, 
and you want to recognize them in index-
ing process.  

  

Examples of title blocks with non-rectangular topology 

Right Button Menu 

The context sensitive right button menu aids the input of field names 
and patterns. This menu contains the twenty most recently used names 
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and patterns. To display the field list, select a field and right-click. From 
this list you can select the required name (if shown), and the field name 
and pattern will be filled automatically. 

 

Set Title Block Position Option 

Sometimes you may want to use an existing title block template as a 
basis for a new (but similar) title block. In this case you may have to 
reposition the existing title block to line up with the new one. This exam-
ple shows an existing title block template overlaid on a new image, but 
incorrectly positioned. 

 

Using the  button you can drag a title block template to a new posi-
tion, as indicated with the arrow on the picture, so that it will overlap the 
title block on the image.   



 

81 

Training OCR Templates 
Using the standard RasterID OCR features, you can recognize the 
characters of the English alphabet, digits, punctuation marks and spe-
cial symbols (first half of ASCII table). These character templates (topo-
logical models) are stored in special files called character template li-
braries. These files are by default allocated in the OCR folder of the 
RasterID root folder. 

The internal OCR module within RasterID can be trained to recognize 
any character. This means you can add new character templates to one 
of the available libraries, or create your own library from scratch. 

The training process creates templates (topological models) of text 
characters and places them in the open library of character templates.  

You can replace any template in the existing library by one of your own. 
Several templates can correspond to one text character. 

To create a new library or change the existing character tem-
plate library 

 
1. Choose Train OCR from the Tools menu or press the 

button on the Tools toolbar. 
The following dialog box appears:  

 

 
2. If you want to create a new library of characters, press 

the New button. 
- or – 

 
If you want to add new templates to an existing library, 
press the Open button, select from the dialog box the de-
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sired library file and press OK. 
3. Create new, replace or delete character templates. 

 4. Save the library in its own file, or in a new one, using 
the Save button. Click OK. 

 

The creation, replacement and deletion of library templates are made 
with the help of the buttons on the dialog box toolbar and the Character 
input box. 

   Raster character selection tools 

  Add and Delete buttons 

Before beginning the training, open the Train OCR dialog box and load 
an existing library or create a new one. 

To create a new character template 

1. Enter a character into the Character input box. 

2 Select a raster symbol that represents the specified character with 
one of the selection tools. 

 Select by picking. Click on the standalone raster character. 

 Select by frame. Draw a frame around the raster character. 

 Select by polygon. Specify the vertices that encompass the 
raster character; press ENTER to complete the selection. 

If you make a mistake, repeat the procedure. 

3. Click the Add button. 

The program will create a topological template of the character and add 
it to the appropriate category of the template library. 

The left part of the dialog box displays the contents of the current tem-
plate library: digits, English capital letters, English small letters, special 
symbols, national capital letters, and national small letters. Closed and 
nonblank sections are marked with "+". 
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If you put a checkmark to the left of the 
section name, all templates located in this 
section will be on-line. An unchecked box 
cancels the link to all templates of this 
section. You can open any section by 
clicking on "+" and turn on/off all neces-
sary templates located in this subfolder, 
by setting / removing the checkmark lo-
cated to the left of the template name. 

You can set several templates for each character. The example for “a” is 
shown in the figure below. In this case the character is marked with "-". 
You open a set of templates relating to a character by clicking on "+". 
Then you can select a template by clicking on it. After you have chosen 
a template, its graphical representation is displayed in the right part of 
the dialog box. 

 
Character templates can either be turned off – in this case they will not 
be used for recognition, or deleted altogether. 
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To delete a character template 
1. Select a template. 

2.  Click the Delete button. 

Save the prepared template library back to the same file or use a differ-
ent file name for further text recognition when indexing.  To use a tem-
plate you have to choose the appropriate template name in the Train 
Title Block dialog box. You may prepare some of the template libraries 
for different character styles. 

Recognizing and Previewing Title Blocks 

To check the quality of title block searching and text recognition you can 
apply the Recognize Title Block command. To do this you should load 
an image file, then load the title block template prepared for this file. 

Choose this command from the Tools menu or click the  button. If 
RasterID recognizes the title block on the currently loaded image, you 
will see a colored title block and the recognized texts overlaid on the 
image, so you can check the recognition results. You may repeatedly 
apply this operation to a selection of images to check the recognition 
quality and to correct templates before running the indexing process 
automatically. If the title block is recognized RasterID will show the Edit 
Title Block dialog box: 

 
Right-click on the dialog heading to change its position on screen. 
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You can check the contents of each field and if necessary correct the 
recognized text strings (the required field can be selected by clicking 
directly on the image). You can fill in each field manually. To correct the 
text string position, click button  and specify a new point in the title 
block. If you accept the recognition results you can click Export and 
transfer the title block contents to your indexing output destination (see 
Indexing Output). If you want to make alterations to the title block tem-
plate you can click Back to Trainer button, and return to the Train title 
block dialog to make your changes. After that you may repeat the Pre-
view operation until the results are acceptable. This sequence of opera-
tions is a manual indexing process to get the ID of each image. 

You can choose the font used to preview recognized text strings by 

clicking the  button. 

The  button allows you set the title block position manually for a 
better recognition precision. 

The  and  buttons allow you to recognize information in areas 
defined by rectangle or by field.  

Press the  button, to recognize all fields in a title block.  

RasterID also supports a semi-automatic recognition procedure. When 
the output database is defined and the Stop to check recognition results 
option in the Indexing Output dialog box is checked, you can recognize 
fields in the title box manually. When you finish recognizing the fields 
(by pressing Export or Skip), the resulting record is added to database 
automatically. 

If the Stop to check recognition results option is not selected, during the 
batch indexing or indexing through Virtual Scanner process, error mes-
sages in the log window will notify you of any faults during title box rec-
ognition, the process is not interrupted.  By selecting this option you 
force RasterID to temporary switch to manual recognition mode for 
processing the erratic titles. 
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Use the Zoom to Title Block command or click the  button to display 
the title block area. To show / hide the image and title block preview use 

the buttons  and . You can use all zoom commands to control 
the required viewing area.  
 
 

Recognizing Text to File 
This operation is only available for distributives supplied with ABBYY 
FineReader Engine 5.0 or other supported External OCR Engines. 

The Recognize Text To File feature designed to extract text from the 
drawing and save it to a separate file. With FineReader 5.0 you can 
recognize text on monochrome raster images being saved to PDF, XLS, 
RTF, HTML and TXT files. With other supported External OCR Engines 
texts can be only saved to TXT files.  

To use Recognize Text To File feature choose the appropriate command 

from Tools menu or press the  button on the toolbar.  

 
The Recognize to File dialog has the following options: 

The Output File Type option allows you to choose the file type to store 
the results of recognition procedure. Preview pane uses native layout for 
selected file type. 
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Press the  button and set the External OCR Options. The dialog 
depends on the engine currently used. 

Using the  button you can add patterns to the OCR library for the 
used engine or create a new library having specified a rectangular area 
on the image. 

Press the  button to select a rectangle area, containing text to be 
recognized immediately. Meanwhile, you may recognize all the text con-

tained in a raster image, to do that press the  button. 

The  button allows you to specify the output filename and location. 

To create a new layout and clear existing window content use the  
button. The recognized file is preserved. 

Press the OK button to add pages to the current file. The dialog will be 
closed. To open a new page of the multipage TIFF file of a new raster 
image you should call the Recognize Text to File command again. 

To preview the recognition results in the Recognize Text to File dialog 
RasterID uses a program registered in the system as an associative file 
editor of given extension. 

Important! You cannot edit texts in the preview window.  

Press the Template button and save the settings you made to the tem-
plate file for use while batch processing. 

To edit the recognize text you should press the Chose & Ran Editor but-
ton which starts an external engine corresponding to the selected file 
type (e.g, Microsoft Excel for XLS format). The Recognize Text to File 
dialog will be closed and you will not be able to add new pages to the 
current file. 

Recognizing Text to File in Batch 

When including this Recognize Text to File in the script file you should 
set the following parameters: 

In the Template field open the template file containing the recognition 
parameters created in the Recognize Text to File dialog. 

The Output File name parameter defines the names of files to be saved 
in batch. 

• If the Output File name parameter is empty, then the names of 
output files are generated using the current image name with 
the selected extension. 
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Test.tif   Test.rtf 

The pages of multipage tif-files will be saved as separate 
pages to a file of specified format.    

• If the Output File name is specified, then all processed files 
(multipage tif-file pages as well), will be saved as separate 
pages in a single format under a specified name. 

 
Test.tif (page 1) 

     TEXT.rtf (1+n pages) 

Mpage.tif (n pages) 

Important! You should add new pages to the existing file within one 
work session. Otherwise RasterID will create a new file under the name 
TEXT_ХХХ.rtf; ХХХ – index. 

 

Batch Processing 

To create a processing scenario (script file) 

A Processing scenario is a sequence of operations for each image (for 
example, to increase the image quality). Before running batch process-
ing or indexing you have to create one or more processing scenarios 
and save them to a script file. RasterID script files have the extension 
“.CSF”. To create a draft of the processing scenario you have to check 
the image quality visually. To do so you should load a selection of im-
ages and look at each of them. Try to estimate the image orientation, 
flip, contents and title blocks contained in them. Keep the required proc-
essing actions in your mind. The recommended sequence of operations 
is as follows:   
1. If all images have incorrect orientation or flip you should include the 

Rotate or Mirror command in the processing scenario.  
2. If images are negative, include Inversion command. 
3. The images contain a lot of vertical and horizontal lines (for exam-

ple, in the case of mechanical and architectural drawings). If these 
lines are not parallel to the image margins, the Deskew command 
should be applied. 

4. If the images have linear distortions and contain a bounding frame, 
you may include the Four Point Correction command. RasterID will 
try to find the frame and the closest paper size for it and will correct 
these distortions. 
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5. If the images are “dirty” (meaning they contain a lot of small spots 
and holes), you should use the Speckle / Hole Remover and/or 
Smoothing commands. If you cannot estimate the speckle size 
yourself, RasterID will do it for you, just turn on the AutoEstimate 
flag parameter. 

Note If the image does not contain small speckles, Speckle Remover 
may delete texts, dashes or any small symbols from the image 
when AutoEstimating mode is turned on. In this case it is better to 
use your own specified speckle size setting. 

6. If you intend to run the indexing process you should create a Title 
Block template (see Train Title Block). You have to run the indexing 
process before cropping to get the best results. Include the Recog-
nize Title Block command in the processing scenario before crop-
ping. 

7. To change the image size, include the Crop by Frame command if 
the image contains a bounding frame, if it does not contain one use 
the Crop by Black command. After cropping you can apply Fit to 
Closest Paper to resize the image to one of the standard paper 
sizes. 

8. To print the processed image include the Print command in the 
processing scenario. 

To create the processing scenario and save it to a script file choose the 
Script Studio command from the Tools menu. 

 
The left part of the dialog box contains the sorted list of commands that 
you can use in your processing scenario. The right part of the dialog box 
represents the Script window. It contains the sequence of required 
commands for each image and shows the contents of your processing 
scenario. Error messages are output in the lower-right field. 
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1. To add a required command to the processing scenario select this 
command item from the left part and move it to the Script window 
using standard mouse-dragging techniques. Alternatively you can 

click the  button to include a command in the script. 

2. If the selected command contains parameters, you can specify its 
values. To do so click on the required command item in the right 
part and you will see the parameters list for this command. Click on 
the parameter item and specify its value. If you do not specified pa-
rameter values, RasterID uses default values. 

3. Repeat these operations for each command of your processing 
scenario. 

4. To change the order of commands you should select the command 
item in the right part and drag it to a new place. You can also use 

the buttons  or . 

5. To remove a command item from the processing scenario you 
should select and drag it outside the right part of the dialog box or 

click the delete button . 

6. Click the Save or SaveAs button to store the processing scenario to 
the named script file for use during batch processing. 

7. To edit an existing script file click Load and select the required file 
name from the files list. 

8. To apply the processing scenario to the currently loaded image click 
Run. This enables you to check the results of running the process-
ing scenario for a selection of typical images prior to batch process-
ing a complete group. 

 Edit the script using the following buttons and controls: 
Button Description 

 Makes a copy of selected com-
mand. 

 Deletes selected command. 

 Moves selected command up in 
the script. 

 Moves selected command down 
in the script. 

 Clicking on the plus sign reveals 
command options.  
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Button Description 

 

Clicking on “+” opens the com-
mand parameters tree.  By click-
ing on command option values 
you can enter required values. 

Run Launches script. The error or pro-
gress messages are shown in the 
lower right section of the dialog 
and written to the log file. Press 
Cancel to stop script execution. 

New Clears the Script window and be-
gins a new script. 

Open Opens a saved script. 

Save/Save As Saves the script. 

Script commands and parameters: 

Command Description 

 

Acquires images from a 
scanner specified in the 
Scanner Name parame-
ter. With Create Multi-
page Image set to on, 
RasterID scans a group 
of images for saving to a 
single multipage tiff-file, 
otherwise RasterID gen-
erates an incremental 
name for each image. 
Use the Image Name 
Prefix parameter to spec-
ify the output file names. 
The other options are 
used to control scanning. 
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Command Description 

 

Applies the adaptive bi-
narization procedure using 
Radius and Threshold val-
ues.  
If the Binarize box is not 
checked and Smooth is 
checked, the command 
produces a smoothing 
effect using the Smooth 
Value. 

 

Applies the binarization 
procedure using options 
from the Template file. 

 

Changes the image resolu-
tion to the specified DPI 
value by re-sampling the 
image. The image size will 
be changed. 

 

Used for intelligently “de-
screening” images. Set the 
Radius value. 

 

Add a new page to a mul-
tipage file. 

 

Set Brightness, Contrast, 
Hue and Saturation values 
(in percent) for color and 
grayscale images. 

 

Changes the image size to 
the specified Width and 
Height (in pixels). The 
AutoOrietation box deter-
mines if the program will 
try to fit the image to the 
paper size in the best way. 
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Command Description 

 

Closes the current im-
age. There is also a Do 
not save image option. 

 

Erases the color ranges 
specified in the Template 
parameter. 

 

Separates the image onto 
layers by the color ranges 
specified in Template. 

 

Conversion options for the 
image. 

 
Converts a color image to 
indexed colors automati-
cally. 

 
Converts a color image to 
true color. 

 

Searches for a drawing 
frame, if it exists, and 
tries to find the nearest 
paper size then corrects 
image contents by this 
paper size automatically. 
The paper size can also 
be specified manually. 

 
Crops images to black 
pixels. 

 
Crops images by a 
bounding frame. 

 

Crops an image by a 
specified rectangle, 
which is defined in the 
current units (mm or 
inch).  

 
Applies the AutoDeskew 
command. 
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Command Description 

 
Launches the automatic 
equalizing procedure. 

 
Fits an image to the clos-
est standard paper size. 

 

Fits an image to the se-
lected standard paper 
size. 

 

Applies the Blur filter with 
the specified Radius. 

 

Removes the specified 
hole size (<10 mm). 
RasterID can also be set 
to automatically estimate 
the hole size. 

 

Manages the palette for 
color images (by deleting, 
merging or replacing col-
ors). 

 
Inverts raster images. 

 

Applies the Median filter 
with the specified Radius. 

 

Applies horizontal or ver-
tical mirroring to images.  

 

Specifies the images for 
processing. 
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Command Description 

 

Prints images. If FitTo-
Paper is checked the 
image will be scaled to 
printer paper size. If not 
Scale and Margins pa-
rameters will be used. 
PrintCopies defines the 
number of copies. 
PrinterName specifies the 
current printer to print 
images to. This is the 
system printer name 
specified in the Printers 
folder. 

 

Calls another script from 
within this script. 

 

Runs the indexing proc-
ess with the defined Title 
Block templates. 

 

Performs the Recognize 
Text To File operation. 
Output File Name – de-
fines the name of file to 
be saved. If empty – the 
original filename will be 
used with alternative file 
extension. Template – 
Defines the template file 
containing recognition 
parameters. 

 
Reopens the open image 
from file. 

 
Resets work area on the 
image. 
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Command Description 

 

Changes the image size 
to the specified Width 
and Height (in pixels).  
The AutoOrietation box 
setting determines if the 
program will try to fit the 
picture to the paper size 
in the best way. Resam-
ple flag defines whether 
the image dimensions (in 
pixels) will be changed. 

 
Resizes images to one of 
the standard paper sizes 
from the Papers list. 

 

Rotates images by 
90cw/90ccw/180 de-
grees, allowing you to 
rotate images by 
90cw/90ccw on specified 
conditions for Paper 
name and/or Orientation. 

 

 

Saves images. 
Saves images to other 
files and folders. 
JPG Quality sets 
size/quality balance with 
JPEQ file. 
Format values are Intel 
and Motorola providing 
you with the option of 
cross-platform export. 
Use the options Com-
pression, Organization, 
Tiff Stripe Size, Tiff Tile 
Size and Tile Preview 
Page to optimise TIFF 
files.  
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Command Description 

 

Removes all objects 
greater than the Minimal 
Object Size and smaller 
than the Maximal Object 
Size to a separate layer, 
which is displayed in the 
Output Raster Color. 

 

Changes the image resolu-
tion to the specified DPI 
value without any process-
ing. The image will remain 
unchanged. 

 

Specifies the file name of 
the log to output the batch 
report to. 

 

Sets work area to process. 

 

Applies the smoothing 
filter with the specified 
Medianing (0-100) and 
Threshold (0-127) parame-
ters. 

 

Removes black speckles 
from images. Use the Auto 
Estimating flag or set the 
maximum speckle size 
manually (<10 mm). 

 

Applies the Thickening 
filter by the specified 
Number of Passes. The 
Thick in direction parame-
ter can be Vertical, Hori-
zontal or All (in vertical, 
horizontal and diagonal 
directions). 
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Command Description 

 

Applies the Thinning filter 
by the specified Number of 
Passes. Checking Thin up 
to skeleton converts all 
objects to one-pixel lines. 

 

Applies the Unsharp Mask  
filter with the specified 
Sensitivity and Radius. 

  

To Create Batch Job 
A Batch job is a sequence of operations for a group of images. To cre-
ate a batch job you should specify the input images or set location of a 
folder or a set of folders to be processed, the script file (which contains 
the processing scenario), and output images. You can save processed 
images back to their original files or to new files; you can also select 
different file formats for the destination files.  

You may apply more than one processing scenario to the selected images 
in your batch job. To prepare a batch job and tune the input and output 
options choose Batch Studio from the Tools menu. The Batch Studio dia-
log box appears (see next page). 
1. The Select File or Directory tree shows existing files and folders; 

you can use the format list option to show appropriate files. 
2. To specify those images to process, select the input files (or an 

entire folder) and move them to the Input files or directories section 
using the standard drag-and-drop technique. 

3. Select one or more script files and place them into the Script Files 
list. This specifies the processing scenario when running a batch. If 
you click on a script list item, the Script Studio dialog (described 
above) opens, and you can check or edit the processing scenario 
contents. 
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4. To save the images to new files you should select an output folder 

and file type. If you do not do this, the images will be saved back 
to the same files. 

5. Press Run to launch the batch. The input files are processed with 
the selected scripts from Script files list and the results are put into 
the Output folder. The error or progress messages are shown in 
the lower right section of the dialog. Press Cancel to stop the script 
execution. 

The buttons and controls in the Batch Studio dialog are as follows:  

Button Description 
Select File or Directory  

 
Opens the list of folder 
shortcuts (to see the list, 
place the mouse pointer on 
this item and wait a bit) 

 
Adds the selected folder to 
the folder shortcuts list 

 
Refreshes the folder tree 

 
Folder tree files filter 
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Button Description 
Input files and Script files list  

 
Creates a new item manu-

ally 

 Removes the selected item 

 Moves the selected item up 

 Moves the selected item 
down 

 
Check Use output to redi-
rect output of processed 
files. 

 
Check Ignore Open/Save 
in scripts if the script file 
includes the Open and 
Save commands; other-
wise they may be executed 
twice. 

 

 

Use output Options button. 
Opens a dialog that saves 
settings for the specified 
file format. 

For example, to change 
TIFF options for output 
files you should click this 
button and set the required 
options. 
 

 

Selects format of output 
files. 

 This control allows you to 
set not only single folder to 
be processed, but a com-
plete list of files in all the 
subfolders from a desig-
nated path. 
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Button Description 

 
and 
Errors in Input files and directories 

These controls enable 
batch cycling. When the 
Rebuild box is checked, the 
Name list obtains the files 
that were not processed by 
the batch and the Errors 
field shows which opera-
tions failed for each un-
processed file. 
This reduced list is pre-
served and after making 
the required amendments 
you can apply the same 
batch to the remaining 
files. 
If the Rebuild box is un-
checked the Names list will 
remain unchanged. 

Reset Cleans all batch content. 

Run  Launch the script and 
watch the output results in 
the lower right section of 
the dialog. This report will 
be written to the log file. 
Press Cancel to stop script 
execution. 

To Run Indexing 

You should perform the following operations:  

1. Create a Title Block template with the Train Title Block command 
described above, then save the created template to a template file. 
If you intend to use different templates for indexing you should cre-
ate all of them before running the batch process. 

2. Choose the Script Studio command from the Tools menu and cre-
ate your processing scenario. Add the Recognize Title Block com-
mand to this scenario and choose a previously created title block 
template for the Templates parameter.  Save the created scenario 
to a script file. 



102 

 
Note: You can use more than one title block template file when index-

ing. To do this, simply select all the required templates as the pa-
rameter. For example, in the script – MYSCENARIO.CSF (see the 
picture above) you can see a string of three templates: ANSI_A; 
ANSI_B; ANSI_C; In this case RasterID will analyse the title block 
in each image and try to apply the most appropriate of the three 
templates for each one. This is a typical processing scenario that 
includes both image processing operations and the indexing 
command Recognize Title Block. 

3. You can control the indexing output by choosing one or more des-
tinations. RasterID has three standard options. These are Comma-
Separated Text file, MS Excel table and MS Access database. 
RasterID has the capability of attaching an external destination but 
it requires programming (see Programming guide).  Choose the In-
dexing Output command from the Tools menu. The Indexing Out-
put dialog box appears: 
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You should place a check against each required destination. Out-
put options such as the output file name or separator type are de-
fined in Setup. To specify these options click the Setup button, 
then click OK. The selected destinations will be used when index-
ing.  

Now you should select the following actions for RasterID in two 
cases: 

If the title block is found: 

Stop to Check – to interrupt the indexing process and open the 
Check Recognition Results dialog box (see more information 
on page 85), so you could check and edit the recognized field 
contents. 

Export Auto – to export the indexing results to the selected 
destination without checking. 

If the title block is not found: 

Skip -  don’t export anything;  

Export Auto – to add only the filename field to the database;  

Stop to Check – to open the dialog for manual editing (see 
more information on page 85).  Using this dialog you can rec-
ognize selected fields one by one and edit the contents. After 
you are finished, this information will be automatically ex-
ported to the selected databases. 

 



104 

 

4. In the Auto File Naming tab you can set up a scheme for automatic 
naming of files. It is a useful feature to support batch scanning or 
scanning through the Virtual Scanner. 

The auto-naming scheme is simple: you set the path and name of 
the file and a field name as the auto-numbering variable, such as 
<Drawing Number> in the example below. 

The Enabled  option should be checked. 

The  button opens a dialog where you can set the <PATH> and 
<FNAME> values. 

The next figure shows the auto-naming scheme in action. The bot-
tom of the dialog shows that the <PATH> is represented by “Soft-
ware\RasterID 3.5\Samples”, and “Navy_01” represents the 
<FNAME> variable. Then, following the underscore, the rest of the 
string is the contents of the “Drawing number” field of the title block 
and the “.tif” extension. 

In the Error Correction section you must define how RasterID 
should handle problems with file names such as duplicate file 
names. Select the desired option from the If file already exists and 
If filename is invalid action combo-boxes: 

 
Autocorrect filename - applies the auto-naming scheme and saves 
the file. 

Overwrite file - ignores the auto-naming scheme and saves the file. 
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Skip saving file -  proceeds to the next file without saving. 

Ask user - opens the same dialog every time the conflict occurs 
and lets you set the filename manually. 

Select one of the following options from the If invalid characters in 
filename action combo-box:  

Delete 

Replace with dashes 

Ignore 

Fail 

In the COUNTER macro section you can tune mask macros and in-
dexes numbering.  

5. In the Mapping tab you can specify a macro to make the required 
database field contents. It can be a sequence of predefined key-
words (for ex. FileName, DrawingDPI), custom RasterID objects 
properties (for ex. Raster:ActiveRasterPage, Title-
Block:Fields:Sheet), or text symbols. As a result, you will get the 
specified value transferred to your database. 
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You can edit the string in the File Name box before exporting data 
to the selected databases. 

 
6. Choose the Batch Studio command from the Tools menu. Select 

the input image files, the created script file and specify the output 
files or folder. Then click Run in the Batch Studio dialog box.



 

 

Appendix  
INDEXING OUTPUT 

Output to MS Access 

If you choose MS Access Output in the Indexing Output dialog box, 
RasterID launches MS Access or uses its DAO Engine. It loads the ex-
isting MDB-file or creates a new database file using the file name speci-
fied in the Setup dialog.  

 
If you turn on Clear old Records... RasterID will delete all records in the 
specified database file before indexing. If you turn off the checkbox, 
RasterID adds new records to the existing database when indexing. 

If you turn off the checkbox Export turned off fields, RasterID will not 
export the name and contents of unrecognizable fields. 

Pressing the  button embeds a Quality Checker for Access into 
your MDB file. The Quality Checker is an add-on VB application that 
works in the Access environment and allows you to view the indexed 
images and edit the field contents.  
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MS Access with Quality Checker application 

RasterID exports the extracted data to DAO database (usually version 
35 for MS Office 97 or version 36 for MS Office 2000). The information 
on DAO version can be found in Windows register as the key value 
HKEY_CLASSES_ROOT \ DAO.DBEngine.version. 

MS Access dialog with indexing results 

 

The Quality Checker toolbar contains the following functions: 

Button Description 

 
Launch RasterID to edit current image file. 

 
View controlling toolbar. 

 
Show/Hide Raster/Vector buttons. 

 
Add/ Rename/Delete record. 

 
Previous/Next record. 

    
Checked/Unchecked state. 
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If the  button is not pressed, RasterID uses the DAO Engine ver-
sion (usually it is 35 for MS Office 97 or 36 for MS Office 2000) to 
transfer the indexing results to your database file. You can look this up 
in the Registry: HKEY_CLASSES_ROOT \ DAO.DBEngine . version).  

MS Access output results 

Output to MS Excel 

If you choose the MS Excel Output option in the Indexing Output dialog 
box, RasterID launches MS Excel. It loads the existing xls-file or creates 
a new table using the file name specified in the Setup dialog.  

 
RasterID will create a new sheet for each different title block type. This 
sheet has field names corresponding to those specified in the Train Title 
Block dialog. RasterID will add a new record for each processed image. 
The first field - Image contains the full path to the processed image file. 
The second field Preview contains a cropped area of the image that 
contains the recognized title block. Any other fields contain the recog-
nized text strings. If you turn off the checkbox Export turned off fields, 
RasterID will not export the name and contents of unrecognizable fields. 
Insert full title block preview checkbox allows you to implement a com-
plete title block preview into your Excel worksheet. Insert preview for 
each field will implement the preview of each field into your worksheet to 
ease the manual checking of recognition procedure. In the Width field 
you should set the preview width of the image fragments. The format of 
the FileName field is set in the Insert FileName as field. 
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Results of indexing output to MS Excel file. 

Output to Text File 

If you choose the Comma-separated Text Output option in the Indexing 
Output dialog box, RasterID loads the existing txt-file or creates a new 
one using the file name specified in the Setup dialog.  If you choose Use 
new file, RasterID will create a new text file for each processed image, 
which is named as the image file name with a txt-extension. If you turn 
off this checkbox, RasterID will add a new record for each processed 
image. 

 
The created comma-separated text file has the structure:  

File Name – image file name (string) 

Table Name – title block name (string) 

Frame Left, Frame Top, Frame Right, Frame Bottom – recognized 
title block bounding frame (real) 
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Origin X, Origin Y, Angle – title block origin and skew angle (real) 

Probability – title block recognition quality (real 0.0 – 1.0) 

Graphs – fields start 

Graph Name – field name (string) 

ID – field number (integer) 

Frame Left, Frame Top, Frame Right, Frame Bottom – recognized 
field bounding frame (real) 

Texts – texts start for each field 

Text – recognized text (string) 

Base X, Base Y, Height, Angle – recognized text base point, height 
and skew angle (real) 

You can import this file to any database that supports text files. 

ODBC Output 
There is a set of ODBC drivers that provide you with the means to save 
indexing results in a variety of database formats. You can find a de-
scription of formats and OBDC usage in the documentation for the cor-
responding drivers or databases. 

 
In the Path box you should enter the destination folder for the indexing 
results.  

The Driver list contains the available OBDC drivers. The  button 
opens the Driver Setup dialog box for the selected driver. 

The Name field contains the name of the data source. The  button 
opens the Select Data Source dialog box. 
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The  button opens the Details window, which contains the con-
nection string that is used to activate the OBDC driver. You can edit this 
string, to add your login and password for example.  

Pressing the Test button lets you test the validity of all settings before 
starting the transaction of indexed information to the database. 
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Exporting to EDART Application 
EDA[RT] has seven buttons on its toolbar. They are “Drawings”, “Tem-
plates”, “Archives”, “Search”, “Import”, “New Printing Template” and 
“About”. By clicking the first four of them you jump to one of four 
EDA[RT]’s views developed for drawings management, templates man-
agement, archives management and search wizard respectively. The 
fifth button activates the file import dialog. 

First, you need to run and set up EDART to be able to import data from 
RasterID.  

1. Run EDART, press the Template button and then choose Create. 
Create fields to import the information (which should be defined in 
the Mapping tab of the Indexing Output dialog of RasterID). Press 
the Finish button. 

 
2. Type a name for Template; then fill in the Author and Purpose 

fields. 

3. Press the Archives button, and then choose Create. Type a name 
for a new Archive in the Name field; then fill in the Author and Pur-
pose fields. Select the created Template in the Template field. 
Press the Create button. 
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The archive with the name you’ve specified will appear in the 
Archives manager list. 

Select the archive by double-clicking on its name. 
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Now EDA is prepared to receive files. 

 
4. Do the following actions in RasterID 3.5: 

Go to the Indexing Output  dialog (the Tools menu), choose the Map-
ping tab to create macros for the fields in the EDART template, or press 
the button Template > Load and load the previously created ones.  

 
Mapping is a set of triples: 
• Source Macro – one of predefined macro function (see below for 

the full list of Macros) or predefined user string. 
• Destination Name – the attribute name used during data exporting. 
• Current Value – the value of “Source Macro” that depends on the 

processed file as well as on its contents. 
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You can add, remove or modify these triples. 

5. After the Recognize Title Block command is executed, the defined 
information will appear in the specified fields. 

 
A list of available macro functions 
<RasterID> - the reference to CSRaster Control. Can be very help-

ful for advanced data manipulation.  
<FileName> - the fully qualified name of currently loaded file 

(PATH\FNAME.EXT). 
<BaseFileName> - the file name only (FNAME). 
<FilePath> - the full path to file (PATH). 
<FilePage> - the current page number for multipage files. 
<DrawingWidth>,<DrawingHeight>,<DrawingDPI> - the loaded 

raster image attributes. 
<TitleBlock> - Title Block template name. 
<TitlBlock:Name>,<TitleBlock:BoundMinX>,…,<TitleBlock:BoundM

axY> - recognized template attributes. 
<TitleBlock:Fields> - a collection of recognized title block fields. 
<TitleBlock:Fields:[Field_Name]> - the text value of a recognized 

field. 
<TitleBlock:Fields:[ Field_Name]:[Property]> - the recognized field 

property. 
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You can combine any sequence of above macro functions and strings to 
create more complex mappings. 
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