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WiseImage Installation 
System Requirements 

To work with the program you need the following: 
• Pentium processor  
• 128 MB RAM 
• Microsoft Windows NT 4 /98 / 2000 / ME / XP 
• Hard disk with 70 MB of free space. 

Software or Hardware Protection 
WiseImage uses the software or hardware protection system. It offers 
the flexibility to use the program in a single user or in a network 
environment. To use WiseImage you need to set up the license for 
the program. The procedure of obtaining and setting up the license is 
described in the Installation chapter. 

Installation 
1. Insert CD-ROM with the WiseImage in the CD-ROM drive. If 

the auto start function of your computer is on, the dialog box of 
the program product list will be displayed. 

2. To open the installation dialog manually, start the SETUP.EXE 
file from the CD ROM root folder. 

3. Select an appropriate product from the list. 
4. You will see the WiseImage image first, then the Customer 

Information dialog box. 
5. Enter your name into the User Name box, then enter your 

organization name into the Company Name box, and enter the 
serial number of your product copy from software CD-ROM or 
Box into the Serial Number box. Check the correctness of the 
information entered, as after the installation is completed, there 
is no possibility to change these data. Click on the Next button to 
continue. The Choose Destination Location box will appear. 

6. It specifies the folder name and the disk, where the WiseImage 
program will be installed. You can accept the default path or 
specify a location for the installation to be made with the Browse 
button. Click on the Next button to continue. 

7. You can change a type of installation in the displayed box. If 
you do not want to make changes, click on the Next button. The 
Program and the example files will be installed. If you do not 
want to install examples files, select the Compact type and click 
on Next. 

8. The product can have other types of installation depending on 
its version. Their description is provided in the lower box of the 
dialog box. 

9. After selecting a type of installation, the Select Program Folder 
box will appear prompting to change the folder name of the 
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system menu where there will be a shortcut of WiseImage start. 
The Program Folders already has a name, which you can accept 
by clicking on the Next button. If you want to change this name, 
enter another one and then click on the Next button. 

10. The Setup Status box will appear and the copying of the 
WiseImage files on the computer will begin. After the copying is 
completed, you can start the program from the folder to the 
system menu with the name you specified in the previous 
dialogue. 

11. The installation program creates on the hard disk a folder for 
the WiseImage program where all necessary files are copied and 
it places a shortcut for WiseImage in the Windows system menu. 
Licensing 

After the installation is completed, you need to obtain the license to 
use WiseImage.  
There are two different cases: Single-user environment and 
Installation on network. 
Single-user environment 
To setup the license for the first time you have to use the 
Registration Wizard. 

• Click Start on the taskbar, then choose Programs. 
• Click WiseImage, then choose the Registration Wizard menu 

item. 
• Follow the instructions. If you have already got the license – 

attach it, in another case - ask for the license by e-mail. 
Installation on network 
The network installation procedure is described in the LANSETUP.PDF 
file on Consistent Software CD. 
Using Hardware Lock (optional) 

• If you are using Windows NT or Windows 2000, you must have 
SENTINEL driver installed. This can be found on the WiseImage 

installation disk. 
• Insert hardware lock in the printer or USB port of your computer 

and start installation. After completing the installation start 
Registration Wizard and choose I want to get the license. Click 
Next. Follow instructions on the screen. 

• When Registration Wizard finishes, copy registration information 
highlighted in dialog window and sent it to getlicense@csoft.com 
or just click Send e-mail button. 

• Depending on the installation type you will get additional 
information on using your license. 

mailto:getlicense@csoft.com
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WiseImage Document 
Brief description: This section is devoted to WiseImage documents 
and document properties. You will learn how to customize the 
document and set a user coordinate system. This lesson also 
demonstrates the main dialogs – Inspector, Image manager, Layer 
manager, and Block manager. 

WiseImage Document 
A WiseImage document can contain both raster images and vector 
objects at the same time; its workspace is unlimited. You can load an 
unlimited number of color, greyscale and monochrome raster images 
(of course, capability and work speed depend on your computer 
resources). The document also stores tool settings, which are used in 
the working process. 
If the document contains several raster images, you can work 
simultaneously with them. 
WiseImage supports multi-document interface (MDI), i.e. the 
program can have several documents loaded, and you can 
simultaneously run different operations in all of them. 
WiseImage document files have a CWS extension. 

How are raster images stored in the document? 
There are two different ways to store raster images in WiseImage: 
1. Linked raster images – are stored separately from the document 

file 
2. Embedded raster images– are stored in the WiseImage 

document file 

WiseImage Document Properties 
If you start working with a new WiseImage document, you can set its 
properties. The tuned document can be saved as template for further 
use. 

See section Customizing Program Parameters on page 80 for 
information on template selection 

You can set up font type and height, color, current layer; line type 
and width, etc. as properties of a document. 
The properties of WiseImage objects may be set By layer. (in this 
case the properties of created objects inherit the properties of the 
layer they belong to); or By block (in this case, the objects 
comprised in the block inherit this block’s properties). 

See section Layer Manager on page 8 for information on setting 
layer properties. 

How to set up document properties 
• Open the Inspector (choose Inspector from the Tools menu) 
• Make sure, that no object is selected – otherwise the Inspector 
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displays its properties. To unselect all you can press the UnSelect 
All button, located on the Select toolbar (utmost right). 

 

• Make sure that no command is being 
executed – otherwise the Inspector 
displays its parameters. Press Esc to 
cancel all commands. 

• Select desirable values from the 
combo-box or enter them in the 
corresponding fields of the 
Inspector. 

IMPORTANT: You can save the tuned 
document as a template for further 
use. 

Document Coordinate System 
You can work in World Coordinate System or set up multiple User 
Coordinate Systems (UCS). 
How to set up a UCS 
• Choose Coordinate System from the Tools menu. 

 

• In the Units tab, specify linear 
and angle measurement units 
and their accuracy 

IMPORTANT: You can specify 
units for measuring line width 
separately in the User field of the 
Units tab. 
• In the Coordinate System 

tab, click on  button to 
create New Coordinate System  

• Choose UCS axis direction 
using one of the four 
corresponding radio buttons. 

• Define UCS parameters – 
origin, skew angle relative to 
Х-axis, and scale. 

IMPORTANT: You can specify the origin relative to another point 
which coordinates are known to you, for example – points with known 
coordinates on a map. To do so, use the rulers of Origin to specify a 
point with known coordinates on the screen, and then enter its real 
coordinates in To: 
In case you also need to specify a new scale, first specify the desired 
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scale, press Apply, and then specify the relative origin position as 
described above. 

Inspector 
Using the Inspector you can view and edit the following information: 
• WiseImage document settings 

See page 6 for detailed information on setting document 
properties. 

• Properties of selected object(s) 
• Run command parameters 

How to open the Inspector 
 Choose Inspector from the Tools menu  

 
Or press the Inspector button, located on the Properties 
toolbar  

Image Manager 
Using the Image Manager you can: 
• view all images loaded in the document 
• get information on image properties and edit some of them 
• save, delete and create new raster images 
• turn on/off visibility and lock (unlock) raster images 
• change the way of storing raster images in the document (in a 

separate file – linked, or in the document file - embedded) 
• change the page order in a multipage TIFF-file. 

IMPORTANT: 

 

To embed a raster image saved in a separate file to the 
document, select this image from the Image Manager list, 
and then press the Embedded button 

 

To save the embedded raster image in a separate file, select 
this image from the Image Manager list, and then press 
either Save or Save as button 

 

To change the page order in the multipage TIFF-file, select 
the image and move it up or down using Move  Up or 
Move Down button 

How to open Image Manager 
 Choose Images from the Tools menu  

 
Or press the Image Manager button located on the 
Properties toolbar  

By pressing the Details button of the Images dialog you will get all 
information on the selected image properties, some of which can be 
edited. 

Layer Manager  
A WiseImage document consists of layers on which all objects are 
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placed. Layers have properties (color, line type and line width, font, 
etc.). Objects can have their own properties or inherit properties from 
the layer on which they are placed. 
Using the Layer Manager you can: 
• view and edit information on layer properties 
• set the current layer – on which new objects will be placed 
• Create new layers and delete existing ones. 

IMPORTANT: You can only delete a layer if it does not contain any 
object and it is not current. 

• Turn on/off layer visibility; allows or prevents the selection or 
modification of objects that belong to a certain layer. 

How to open Layer Manager 
 Choose Layer from the Tools menu. 

 
Or press the Layer Manager button located on the 
Properties toolbar. 

By pressing Details of the Layers dialog box you get full information 
on the selected layer properties, some of which can be edited. 

Block Manager 
Using the Block Manager, you can: 
• get information on all blocks and their insertions in a document 
• view blocks in the Preview window 
• edit block properties (if a block has only one insertion) 
• save blocks as separate files. 
How to open Block Manager 
 Choose Blocks from the Tools menu  

 
Or press the Blocks Manager button located on the 
Properties toolbar  

Line Style Manager 
Using the Line Style Manager, you can get information on all lines 
styles in a document and create new style patterns. 
How to open Line Style Manager 
 Choose Style from the Tools menu  

Text Style Manager 
Using text styles, you can change text properties for a number of 
objects on the fly. Just modify any parameter of the required text 
style, and every WiseImage text in this document which inherits the 
value for this property from the modified text style will be changed 
immediately 

How to open Style Manager 
 Choose Text Style from the Tools menu  
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Getting Started 
Brief description: This section provides you with a basic knowledge 
of WiseImage – opening, saving, file export and import, navigating in 
document, drawing with precision, clipping raster images and 
printing. You will also learn how to create and work with WiseImage 
clipbooks. 

Opening Files 
Using the Open command of the File menu you can load: 
• WiseImage documents(*.cws) 
• AutoCAD files (*.dwg, *.dxf) (including hybrids, which contain 

raster images, – only for versions AutoCAD R14 and higher). 
• Raster images: formats: TIF (include Multipage Tagged Image 

File); RLC; BMP; IPG; IPEG; PCX; C4; CAL; TG4; MrSID 
IMPORTANT: if you open raster images using the Open command 
of the File menu, each of them is loaded in a new document. If 
you want to open raster images in the current document, use the 
Image command of the Insert menu. 

• Multipage TIF-files. All file pages are loaded in the document. 
IMPORTANT: If you need to load several pages from a multiple 
TIF-file, use the Image command of the Insert menu. You can 
view and load only the desired pages using the Load Page 
dialog box. 

• Hybrid and vector files, created in previous versions of the 
program (*.ws, *.aws, *.vc6, *.vc5). 

IMPORTANT: You can open files using special tool – Explore. It 
meets and exceeds the requirements for file operations within 
WiseImage for every exacting user. It gives all possibilities to 
operate with files presented in Windows Explorer and even more. 
Some required features like Filter by Extension, Bookmarks, 
Favorites and much more, decreases the time of file operations 
dramatically. To launch it – select appropriate command from the 
Tools menu. 

Saving Files 
Saving WiseImage documents 
• Specify in the Image Manager the way you want to store raster 

images contained in the document – either in separate files or 
embedded in the document file. 

See section Image Manager on page 8 for detailed information on 
the ways to store raster images in the document file. 

• Choose Save As from the File menu. Specify the document name, 
choose extension *.cws from the Save as type list. 

Saving document in AutoCAD format 
• Choose Save As from the File menu. Specify the document name, 

choose extension *.dwg (*.dxf) from the Save as type list. 
• Press the Options button and specify AutoCAD version for the 
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saved document. 
IMPORTANT: If you save data: 

in format of 
AutoCAD R14 
(AutoCAD LT 97) 
versions and 
higher 

Program saves the hybrid document, which 
contains vector objects and raster images. 
If the document contains embedded raster 
images, the program suggests saving them in 
separate files (as AutoCAD hybrid document 
is always linked). 

in format of 
AutoCAD R13 
(AutoCAD LT 95) 
versions and lower 

Program saves vector data only. 

Saving raster image 
If you want to save only the raster image: 
• Open Image Manager by choosing Images from the Tools 

menu. 
• Select a raster image to save and press the Save or Save As 

button. Specify the image name, format, and additional options for 
the specified format. 

Saving multipage raster TIF-file 
• Select images to save in multipage raster TIF-file. 

See page 26 for detailed information on raster image selection. 
• Choose Save As from the File menu. Choose Multipage Tagged 

Image File from the Save as type list 
• Specify the name and additional options for TIF format. 

Import and Export 
To import a file, choose Import from the File menu. Specify the 
vector file and press Open. 
Table of import formats and imported objects. 

Import format Imported object 

• Microstation format (*.dgn). Vector objects 
To export in the specified formats: 

• Select data, if you want to export only selected objects. 

See page 25 for detailed information on raster and vector 
selection. 

• Choose Export from the File menu. Specify the name and 
additional options for the specified format. 

• If you want to export only selected objects select the Selection 
Only checkbox.  

• Press Save. 
Table of export formats and exported objects. 

Export format Exported object 
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• WiseImage format (*.cws) 
• AutoCAD format (*.dwg, *.dxf) of R14 

(AutoCAD LT 97) versions and higher  

Vector objects 
and/or raster 
images 

• AutoCAD format (*.dwg, *.dxf) of R13 
(AutoCAD LT 95) versions and lower.  

• MapInfo format (*.mid). 
• ESRI shape format (*.shp). 

Vector objects 

Navigating in a Document 
Navigation tools are designed to help you work within a document. 
You can choose navigation tools from the View menu or from the 
Main toolbar. 

Standard navigation tools 

 Zoom All – displays a whole document. 

 Zoom Previous – returns to the previous display. 

 Zoom Selected – displays selected objects. 

 
Zoom Window – increases a fragment selected with window, to 
full screen size. 

 Zoom In – doubles an image size. 

 Zoom Out – decreases an image size by half. 

 Zoom 1:1 – displays the document in real scale. 

 
Pan – moves a document within program window in specified 
direction. 

 

Zoom Dynamic – turns on the mode in which you can increase 
scale by moving the mouse up and decrease scale by moving the 
mouse down. 

Birds Eye 

 

When working with a large document you can use the overall 
window to display an entire document and the border(s) of 
current views.  

To open the Birds Eye window, choose Birds Eye from the View 
menu. 

Turning on/off visibility of vector object width 
You can toggle the visibility of vector object widths. If turned off, all 
vector objects are displayed with zero width (i.e. 1 pixel of display 
resolution). 
To turn on/off visibility of vector object widths choose Show Width 
of the View menu turned on/off.  

Turning on/off visibility of raster and vector graphics 
For convenient work you can turn toggle the visibility of all vector 
objects or raster images in the document. The buttons are located in 
the View menu and on the Main toolbar. 
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To turn off (on) the vector visibility press (release) the Hide Vectors 
button  

 
To turn off (on) the raster visibility press (release) the Hide Raster 
button  

Changing object display order 
You can change the object display order (vector objects and raster 
images), moving selected objects to front and back, or backward and 
forward. 
Select objects and use the corresponding command from the Display 
Order list of the View menu. 

See page 25 for detailed information on raster and vector 
selection. 

Named views 
You can specify views of different fragments of your document and 
save them with specified names. The program remembers the current 
document scale and position on the screen. 
To create a new named view: 
• Locate a desired image fragment on the screen using the 

navigation tools described above. 
• Enter the view name in the field, located in the right part of the 

Properties toolbar.  
 

 

• Press the  button, located next to the Named new field. 

To delete a named view, select it from the list and press the  
button. 

Precise Drawing Tools 
The following drawing tools are available to aid precise drawing: snap 
to characteristic points of vector and raster objects, polar snap, grid 
display, snap to grip nodes; orthogonal drawing mode. 

 

To turn on/off a tool you can 
use the buttons located in the 
lower-right part of the screen. 

Object snap 
WiseImage allows you to snap to characteristic points of vector and 
raster objects. Furthermore, you can snap to vector and raster 
objects at the same time. You can also use running snap and snap on 
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demand. 
You can choose snap on demand by right-clicking with the Ctrl key 
pressed. 
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Tuning object snap 

Choose Snap Setup from the Tools menu  
In the Snap Setup dialog box: 

• Choose snap option – raster and/or 
vector 

 

• Choose snap type(s) 

 
• Set snap on demand – type of objects 

to snap to. 
If you have not selected any checkbox in 
Snap On Demand, the program will 
execute snap to the data selected in the 
Object Snap option. 

 

Tuning raster snap  

IMPORTANT: Raster snap quality is influenced by your image 
geometry. 
You can tune raster snap using the R2V Conversion Options dialog 
box or Raster Properties toolbar. 
Choose Conversion Options from the Convert menu, and then go 
to the Options tab. 
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Specify the following values: 
 
Max Width – maximum width 
of a raster object, to which 
characteristic points you want 
to snap. Specify this 
parameter value slightly 
greater than the maximum 
width of the raster line. 
 
Accuracy – parameter 
corresponding to your raster 
image accuracy. Use greater 
values for images of good 
quality and smaller values for 
images of poor quality. 

Polar snap 
Choose Snap Setup from the Tools 
menu. Select the checkbox in the 
Polar Snap field of the Snap Setup 
dialog box, and then specify angle for 
polar snap. 

 

Grid snap 
Choose Grid Setup from the Tools menu. 
In the open Grid Setup dialog, specify the grid size in horizontal and 
vertical directions. Select (clear) the checkboxes for display of grid 
and grid nodes. 

Orthogonal drawing mode 
You can switch to orthogonal drawing mode by pressing the ORTHO 
button, located in the lower-right part of the screen. 
INFORMATION: The direction for ORTHO mode is defined in 
correspondence with the document coordinate system axis direction. 

Image Clip 
You can set a clip area for a raster image. Setting a clip area saves 
computer resources, speeding up command execution, preventing 
modification of the image part located outside of the clip. 
There are two types of clip – rectangular and polygonal. You can set 
only one clip on the same image. 

How to set or reset clip? 
• If there are several images in your document select one to clip. 

See page 26 for information on raster image selection 
• Choose Image Clip from the Image menu, and then 

Rectangular (for rectangular clip) or Polygonal (for arbitrary 
shaped clip). 
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• To reset clip choose Image Clip from the menu Image, and then 
Reset. 

WiseImage Clipbooks 
You can store raster, vector and hybrid objects in WiseImage 
clipbooks. You can copy any unit comprised in the clipbook and place 
them anywhere in your document. 
Clipbooks are stored in separate files; their component units can be 
used in different documents. You can open several clipbooks at the 
same time. 
• To open a new clipbook choose Clipbook from the Tools menu 
• To open an existing clipbook choose Clipbook from the Tools 

menu, and then press the Open button , located in the 
clipbook window. Find the file of the desired clipbook, and then 
press the Open button. 

• To add a new unit to the clipbook: 
§ Choose raster, vector or hybrid unit 

See section Selection on page 23 for information on raster, 
vector and hybrid selection methods. 
§ Drag the selected objects to the clipbook 

or copy the selected object using the Copy command of the 
Edit menu or with the Ctrl+C acceleration keys. Then place 
cursor on the clipbook field and right-click; choose Paste from 
the appeared context menu. 

§ To save the new or modified clipbook press the  Save 
or Save as button. 

Print 
To open the Print dialog, choose Print from the File menu. 
INFORMATION: If raster images and vector objects are located one 
over another, before printing you should set up raster images 
visibility in Image Manager and the object display order using the 
Display order command of the View menu. 

See section Changing object display order on page 13 for 
information on object display order. 
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• Using the Printer field you can 
select the printing device 
installed on your computer and 
change its current parameters. 

• Using the Area field you can 
specify the print area – whole 
document, visible document 
part or rectangular window, 
which can be specified on the 
screen or by corners’ 
coordinates. 

• You can also specify scale, 
margins and paper alignment. 

• Specify pages to print 
• You can preview printing 

results on the screen. 
INFORMATION: By turning off 
visibility of layers in the Layer 
Manager you can print only 
specified layers. 

 

WiseImage Objects 
Brief description: This section illustrates the different objects with 
which WiseImage works – raster images and vector objects. 
Scanning, loading existing and creating new raster images. Creating 
vector objects, assigning and editing their properties. Creating user 
markers and symbols for floodfilling. 
WiseImage can simultaneously work with vector objects, raster 
images, and selected fragments of raster and hybrid graphics. 

Raster Images 
You can scan raster images directly from the program, load existing 
images and create new raster images. 
Scanning with WiseImage 
You can scan directly from WiseImage, if you use a scanner provided 
with TWAIN-driver or a CONTEX scanner.  
If several supported scanners are installed, choose one with the 
Select Source command of the File menu. Then start the Acquire 
command. The displayed dialog depends on the scanner and driver 
version. After scanning is finished, a new document with scanned 
images will be created. 
IMPORTANT: If you want to scan an image and load it to the current 
document, use the New Image from Scanner command of the 
Insert menu.  
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IMPORTANT: For CONTEX and HP scanners special plug-in – 
WiseScan is also available. Read more about this feature in WiseScan 
documentation. 

Inserting raster images 
To insert a raster image to a new document, choose Open from the 
File menu. 
To insert a raster image into the current document, choose Image 
from the Insert menu.  

Creating new raster images 
You can create a new raster image in the current document. Choose 
New Image from the Insert menu. Specify type, size, resolution 
and other properties for the new image in the New Image dialog. 
Press OK. 

Vector Objects 

Creating vector objects 
With WiseImage you can create different types of vector objects. The 
draw vector commands are located in the Draw menu and on the 
Draw toolbar. 

You can specify point coordinates, angles and distanced when you 
create vector objects on the screen or enter their values in the 
corresponding fields of the Inspector window. While vector objects 
are being drawn the program status line (on lower-left corner) 
displays tooltips. 

Vector object properties 
Every vector object has a set of properties (belonging to a certain 
layer; color, line width and line type; markers, etc.) and geometry; 
which can be specified, viewed and modified in the Inspector. 
• Default properties of newly created vector objects are set 

according to the document’s properties. 

For infirmation on setting document properties see page 6 
• After creation, vector object properties can be changed in the 

Inspector (or the Properties toolbar).  
The next created object inherits the properties of the previous one. 

INFORMATION: The next created 
object will have the properties of the 
previously created one – if the 
Document Transparent radio button 
of the Properties mode section of the 
Inspector is on. 

The next created object will have the default document properties, if 
the Command sensitive radio button is chosen. 
INFORMATION: The created vector object can inherit properties of 
the layer, on which it is created, if you specify By Layer in the 
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corresponding fields. 

See section Layer Manager  on page 8 for information on layers. 
INFORMATION: Vector objects included in a block can inherit the 
block properties, if you specify By Block in the corresponding fields.  

Basic vector objects 
The commands used for creating vector objects are located in the 
Draw menu or in the Draw toolbar. 
Point – is created by specifying on the screen or entering its 
coordinates in the corresponding fields of the Inspector  
Line – is created by specifying two points or angle and length 
Arc – is created by specifying three points; or center, start and 
angle, or by center, angle and radius 
Circle – is created by specifying center and radius; or diameter; or 
three points 
Ellipse – is created by specifying center and radiuses; or diameter 
and radius; or elliptic arc 
Elliptic arc - is created by specifying center, radiuses and angles 
Rectangle – is created by specifying three points or two opposite 
corners 

Polyline 
You can create a polyline, which consists of line and arc segments. To 
draw an arc segment press the SHIFT key. To complete drawing a 
polyline choose the command End Polyline from the context menu, 
which appears if you right-click when drawing a polyline. The 
commands of the context menu also allow closing polyline and undo 
the latest drawn segment. 

See section Editing Vector Polyline on page 33 for information on 
editing polyline. 

Hatch  
A hatch is created in a closed 
area, limited by vector entities 
(entity). The program hatches 
inward from the outer boundary. 
If it encounters an internal 
intersection, it turns off hatching 
until it encounters another 
intersection. 
Thus, areas separated from the outside of the hatched area by an 
odd number of intersections are hatched, and areas separated by 
an even number are not. 
How to create hatch. Select objects – hatch boundary and start 
the Hatch command of the Draw menu. 

Hatch types:  
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Hatch Fill Cross Fill Shape Fill Solid Fill 
Hatch Fill and Cross Fill are characterized by line width, step (distance 
between lines) and skew angle. 

Shape Fill is characterized by the shape, distance between shapes (or 
hatch step) and skew angle of lines, along which hatch shapes are 
placed. 
You can set the hatch type in the Inspector. 
INFORMATION: A closed vector object (rectangle, circle, closed 
polyline) can have the Fill property.  
How to fill a closed vector object. Select a closed vector object 
and in the Inspector set Fill to True, after that you can choose a fill 
type and properties in the corresponding fields that will appear. 

Text 
How to enter text. Choose the Text command from the Draw 
menu. Texts are entered from the keyboard. The entered text string 
is completed by pressing ENTER. 
The entered text parameters correspond to the default, set up in the 
document. 

See page 6 for information on setting document properties. 
You can also edit text parameters in the Inspector or the Font 
dialog. 

 

You can open the Font dialog by 

pressing the  button, which 
appears if you click in the Text Font 
field of the Inspector. 

 

Multiline text 
You can create, import and save multiline texts. 
How to create multiline text. Choose the Multiline Text command 
from the Draw menu. Enter text in the window. Press OK. Insert the 
text in the document by specifying the insertion point. 

See section Vector object properties on page 18 for information 
on Multiline text properties. 

How to import multiline text. Press Load  of the Edit 
multiline text window. Select and open the *.txt text file. Specify an 
insertion point for this text in the document on the screen or in the 
Base Point field of the Inspector. 
How to export multiline text. Choose Multiline Text. Open the Edit 

multiline text dialog. Press the Save  button. 
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Dimensions 

 

With WiseImage you can create the 
following dimensions: linear – vertical, 
horizontal and aligned; angular, radial 
and diametral  

You can create a dimension object to specify distance and angle, 
radius and diameter of vector and raster objects. 

How to create dimensions 
Method 1 
1. Select an object to create dimension. 

See section Selection on page 23 for information on object 
selection 

2. Choose a corresponding button on the Dimension toolbar. 
3. You can tune the dimension parameters in the Inspector – while 

rubber line for specifying dimension position is displayed. 
4. Specify the dimension position on the screen by left-mouse click. 
5. If needed, edit the position of dimension lines and text using 

grips. 
Method 2 
(You can use this method to specify all dimensions except angular 
dimensions between two lines.) 
1. Choose the corresponding button from the Dimension toolbar. 
2. Follow the next table instructions: 
 

For 
Dimension: 

Specify on 
screen by click:  

Specify on screen 
by click: 

Linear – 
Vertical, 
Horizontal and 
Aligned 

Two points to 
measure distance 
between them 

Dimension line 
position  

Angular 
Vertex angle and 
its two sides 

Angle – outer or 
inner and 
dimension arc 
position 

Radial and 
Diametral 

Arc center or 
circle center E
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Point on the arc 
(circle)  

IMPORTANT: When specifying points you can use object snap to 
raster and vector objects. 

See page 13 for information on object snap 
3. If needed, edit the position of dimension lines and text by using 

the grips. 
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Blocks 
Block – is a named group of vector objects (block definition). 
Unlimited number of blocks can be inserted in the document. 
When inserting, you can rotate a block and change its scale. 
Program supports unlimited block nesting (a block can not include 
itself). 
You can create blocks with attributes. Attributes in blocks 
revolutionary ease the block management and collaboration with 
existing CAD formats.  
When exploded, the block is broken into its component objects. 
If you want to change all block insertion in the document, create a 
new block definition with the same name. 
How to create block 
• Open the Inspector toolbar. 
• Select vector objects.  

See page 26 for information on vector selection 
• Choose Create Block from the Draw menu. 

• Enter a name for the block in the Block Name field of the 
Inspector. 

• Enter the insertion point coordinates in the Base Point field or 
specify it on the screen. 

How to insert block? 
• Choose Block from the Insert menu. 
• Open the Inspector. Choose the block name from Block Name 

list of the Inspector. 
• Enter the insertion point coordinates in the Base Point field or 

specify them on the screen. 

Creating user markers 
You can create your own markers, which will be placed on the 
endpoints of such vector objects as lines, arcs and polylines. 
How to create a new marker. 
• Draw a marker of the desired shape. You can fill it with solid 

floodfill. 
• Select the marker’s elements. 
• Choose the Create Marker command from the Tools menu. 

• Press the button  in the open dialog box and specify a point to 
connect the marker to the line. 

• Specify a name for the marker and save it by pressing Save or 
Save As button. 

• The created marker appears in the lists of Start Marker and 
End Marker of the Inspector. It can be assigned to selected or 
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created vector objects. 

Creating shapes for floodfilling 
You can create your own shape to floodfill closed vector objects or 
Hatch objects. 
How to create a symbol for floodfilling. 
• Draw a shape for floodfilling. You can use solid floodfill to fill it. 
• Select the shape. 
• Choose the Create Fill Shape command from the Tools menu. 
• Save the shape with name using Save or Save As button. 
• The created shape appears in the Hatch Shape of the Inspector. 

You can select it from the list when creating hatch or Shape Fill. 

Raster Drawing Mode 
The Raster drawing mode enables you to draw raster representations 
of vector objects.  

 

To turn on the raster drawing 
mode choose the RDRAW button, 
located in the right-lower screen 
corner. 

IMPORTANT: There should be a raster image under the objects that 
you draw in raster drawing mode; otherwise the created objects will 
disappear. 
 

Selection 
Brief description: To perform different operations – such as edit, 
modify an object’s properties with the Inspector, and others – you 
need to select data to apply commands to. In this section we consider 
raster and vector data selection technology. You will learn about 
different selection modes, methods of data selection, and tuning 
raster selection. 
You can select raster, vector and hybrid (both raster and vector) data 
in WiseImage. Selection technology and data selection methods for 
all data types are extremely close to vector object selection 
technology. 
WiseImage allows selection of the following data and their 
combinations: 
• Vector objects (raster images are included) 
• Raster data: 

§ Raster objects (raster lines, arcs, circles, selected with object 
selection methods, which have “grips”, properties and precise 
geometry). 

§ Area fragments of the raster image. 
§ Selected with window or polygon.  
§ Raster line segments of arbitrary shape. (A segment 
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represents part of a raster line of arbitrary shape, 
limited by points of intersection with other raster lines 
or endpoints). 

§ Isolated raster fragments. 
• Hybrid data (both raster and vector data selected). 

You can use the Selection, More Selection and WiseObject 
Selection toolbars to select data. 
IMPORTANT: When selecting data, you need to define three 
parameters: 
• Type of data to select– raster, vector or hybrid 

See section Type of Data Selected on page 24 
• Selection modes – add to selection, remove from selection, 

single selection. 

See section  
Selection Modes on page 25 

• Selection method – by picking, within window, crossing polygon 
and others. 

See section Raster Selection Methods on page 25 

 Type of data selected Selection mode 
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Table 1. Type of data selected, selection modes 

Type of Data Selected 
You need to define the type of data to select (raster, vector or 
hybrid) by pressing the corresponding button on the Select toolbar. 

 
To select vector objects and raster images, choose 
Vector Selection 

 To select raster data, choose Raster Selection  

 To select hybrid data, choose Hybrid Selection 
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Selection Modes 

 New data is added to selection 

 Selected data is removed from selection 

 Every new selection deselects previously selected data 

  
Selects all vector objects in WiseImage document (except 
raster images) 

 
Selects the contents of all raster image in WiseImage 
document 

 
 

Selects all objects in WiseImage document (raster images 
are included). 

 To deselect all selected data choose Deselect All 

Raster Selection Methods 
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Table 2. Selection methods 
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Object selection methods of vector and raster data  
You can select vector and raster objects (raster lines, arcs, circles) 
using object selection methods (green buttons): 

You can also select raster objects by reference objects: 

 

raster line or its 
segment by 2 
points 

 

raster arc or its 
fragment by 3 
points 

 

raster circle 
by two 
points  

How to obtain the raster area selection using object 
selection methods 

IMPORTANT: If you need to obtain an area 
selection when selecting raster objects press 

Raster Area Selection , located on the 
Select toolbar.  

Raster Image Selection 
If you need to select the raster image, specify (cross) its frame, 
choosing vector (hybrid) type of data selection. 
If the document contains several raster 
images and you need to select some of them 
use Select Raster on the Select toolbar. 

 
Choose Select Image  button, located 
on the Select toolbar 

• Select desired raster images from the list 
• Close the Select Raster window  

Selecting raster area fragments 

Selecting inside rectangle or polygon 

You can select rectangular or polygonal fragments of the raster image 
area using Select by Rectangle or Select by Polygon button, 
located on the Select toolbar. You can select: 

 

rectangular 
fragment of raster 
image 

 

polygonal 
fragment of raster 
image 

Selecting raster segments 

Segment represents part of a raster line of arbitrary shape, 

 
By Picking 
(Auto)  

By Crossing 
Window 

 Within Window  
By Crossing 
Polygon 

 
Within Polygon 

 
By Fence  
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limited by intersection points with other raster lines or endpoints. 
You can select raster line segments (blue buttons): 

 
Within 
window  

By crossing 
window 

 
Within 
polygon  

By crossing 
polygon 

   By fence  

Selecting isolated raster fragments 

You can select isolated raster objects (red buttons): 

 By picking  By crossing window  

 
Within 
window   

By crossing 
polygon  

 
Within 
polygon  By fence  

Tuning Raster Selection 
You need to tune the geometry of raster data to obtain the best 
results when selecting raster objects and raster segments.                      
How to tune the raster selection. 
The selection geometry is tuned using the R2V Conversion Options 
dialog or Raster Properties toolbar. To open this dialog, choose 
Conversion Options from the Convert menu. 
Specify the following values in the Options tab: 

 

 

Max. Width – maximum width of 
raster object to select. Specify this 
parameter value slightly greater 
than maximum width of raster 
objects or raster line segments. 
 
Max. Break – length of ignored 
break in raster lines. 

 
Accuracy – your document 
accuracy. For example, if when 
selecting a raster circle by picking, 
the program only selects its 
fragments (arc), reduce the 
accuracy value.  

Filter for Data Selection 
You can select data, grouping them by type, color, and layer.  
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To select a group of objects, choose Select Objects with Filters  
button on the Select toolbar. 

 

• Select a desired object type from 
the Type list 

INFORMATION: Type includes only 
those types of objects, which are 
contained in the document. 
• You can group objects of a selected 

type by color and layer. 
WiseObject Selection 
The brand new selection engine, called WiseObject selection tool 
added with its new toolbar. This tool allows you to select all text 
areas and hatches as well as speckles and linear objects with the new 
advanced method. 

You can select hatches, linear 
objects, text areas and speckles 

 

 
All the indicated objects in the current image will be selected  

 
You can select the indicated objects within window 

 
You can select the indicated objects within polygon 

 

Editing WiseImage Objects 
Brief description: In this section you will learn different methods of 
editing selected data – raster, vector and hybrid, and also the 
commands designed for editing raster images and vector objects, 
including vector polylines. 

Editing Data, Selected with Object Selection  
If you select data with the object selection methods: 
• You can view and edit the properties of objects using Inspector. 

  

Selected raster 
object 

Modified raster 
object 
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• You can change the geometry of raster and vector objects and also 
the location of selected objects on screen using “grips”. 

• You can apply the following edit commands to selected objects: 
The commands are located in the Modify and Correct menu. 

Edit 
commands: 

You need to specify: 

 Move 
• Shift – by 2 points on the screen or in the Shift 

field of the Inspector. 

 
Copy 

• A number of copies – in Copy field of the 
Inspector. 

• Distance between copies – by 2 points on the 
screen or in the Shift field of the Inspector. 

 
Duplicate  

 
Rotate 

• A number of copies– in the Copy field of the 
Inspector. 
Specify “0” to set no copies.  

• Rotation center (if it differs from the selection 
geometric center) and rotation angle –on the 
screen or enter the values in the corresponding 
fields of the Inspector. 

 Scale 

• A number of copies– in the Copy field of the 
Inspector. Specify “0” to set no copies. 

• A base point by which to scale (if it differs from 
the selection geometric center). 

• Scale factor – in the Scale field of the 
Inspector or specify a base distance and 
desired distance on the screen.  Distances are 
specified between the base and reference 
points. 

 
Mirror 

• A number of copies– in the Copy field of the 
Inspector. 
Specify “1” to keep the original object, “0” – to 
delete it. 

• Mirror line – directly on the screen or by 
specifying the first point and angle for the 
mirror line in the corresponding fields of the 
Inspector. 

 
Flip 
Horizont 

 

 
Flip 
Vertical 
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 Align 

• A number of copies– in the Copy field of the 
Inspector. 
Specify “1” to keep the original object, “0” – to 
delete it. 

• The first source and destination points. 
• The second source and destination points. 

Array 

• A number of Rows и Columns in the 
corresponding fields of the Inspector. 

• The angle of array rotation relative to the X-axe 
in the Inspector or on the screen (if needed). 

• The distance between Rows and Columns – in 
the corresponding field of the Inspector or 
directly on the screen. 

 
Duplicate 
by vector 

• A number of copies– in the Copy field of the 
Inspector.  

• The insertion point for the duplicated object (if 
it differs from the selection geometric center). 

• The vector object along which copies will be 
placed – on the screen. 

Edit 
commands: 

Executive order: 

 

Correct 
to 
intersecti
on 

• Select objects to edit, and then start the 
command. 

• Move cursor to a pair of vector objects. If you 
are satisfied with the rubber line position, press 
the left mouse button. 

 
Offset 

• Offset Distance in the corresponding field of the 
Inspector toolbar.  

• Offset position (inside or outside) – on the 
screen  

 
Create 
Chamber 

• Select objects to edit, and then start the 
command. 

• Choose the way to create Chamber in the 
Inspector– by either two distances or one 
distance and angle. 

• Enter the command parameters (distances, 
angle) in the corresponding fields of the 
Inspector. 

• Moving cursor, choose the right position for the 
rubber line and press the left mouse button. 

 
Create 
Fillet 

• Select objects to edit, and then start the 
command. 

• Specify a radius for the Fillet in the 
corresponding field of the Inspector  

• Moving the cursor, choose the right position for 
the rubber line and press the left mouse button.  
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Align 
Angle 
and 
Distance 

• Select objects to edit, and then start the 
command. Set in Inspector. 

To align angles between the lines: 

§ AutoResizing – FALSE, Distance – “0” 
To align angles and specify a distance between the 
lines: 

§ AutoResizing – FALSE, enter a desired value 
in the Distance field 

To align angles and distance between the lines: 
§ AutoResizing – TRUE 

• Move the cursor to the line, relative to which 
you want to align the others. If you are satisfied 
with the rubber lines position, press the left 
mouse button. 

Editing Vector Objects 

Trim, extend, break vectors 
You can use the following objects as a cutting edge – for trimming, 
extending, or breaking vector objects: 
• Vector or raster object; 
• Pre-defined Edge. 
In case you use a vector or raster object as cutting edge: 
1. Select the object(s)you want to use as cutting edge. 

See page 26 for information on raster and vector selection 
2. Choose the command – trim, extend or break from the Correct 

menu or on the Vector Correction toolbar. 
3. Specify the vector objects one by one to apply the command to. 
In case you use pre-defined Edge as cutting edge: 

Define Edge 
• Select vector objects to form Edge.  
• Choose Group/Ungroup Edge command from the Correct 

menu. 
1. Select vector objects to edit 
2. Choose the command – trim, extend or break from the Correct 

menu or on the Vector Correction toolbar. 

Editing Raster Images 
The commands from the Image menu are designed for editing raster 
images. 
The commands from the Image menu modify the raster image 
contents – resolution, real size, size in pixels, points’ positions. 

IMPORTANT: You should know the difference between the editing 
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commands of Modify menu (see section on page 28), and those of 
the Image menu. 

Unlike the commands of the Image menu, the commands of the 
Modify menu do not change the raster image contents. For example: 
• The Scale command of the Modify menu only changes the scale of 

raster display in the document; the raster image contents 
(resolution, number of points and location), is the same. 

• Using the Scale field of the Resample dialog box, you can modify 
the raster image contents – resolution and/or the number of points 
the image is composed of. 

Change image size 
Choose Change Size from the Image menu. 
Using the Change Size dialog box you can: 
• Change the image size to the desired format. 

§ Choose the desired format from the list of Standard Paper 
Size. Set orientation – Portrait or Landscape. 

• Change the image size to the closest standard format.  
§ Press the Find Closest button. 

You can edit the list of standard formats using the Preferences 
dialog box. See section Customizing Program Parameters on 
page 80. 

• Add (cut) image margins.  
§ Specify values to add (cut) margins in the 

Alignment/Margins section. 

You can also align the image position relative to its margins: 
• Using one of the nine buttons of the Alignment/Margins field. 
• Entering the margins values in the Alignment/Margins section 

with the Fixed Size checkbox set to on. 

Resample 
Choose Resample dialog from the Image menu. Using the 
Resample dialog you can: 
• Proportionally change the image size with fixed resolution. 

§ Choose measurement units from the list; you can choose 
pixels as measurement units. 

§ Enter the new values in the Width and Height fields. 
§ The Fixed size in pixels checkbox is off. 

• Change the image size according to specified Scale value with fixed 
resolution. 
§ Enter the new scale value to the corresponding field.  
§ The Fixed size in pixels checkbox is off. 

• Change the image resolution with fixed size. 
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§ Enter the new resolution value to the corresponding field. 
§ The Fixed size in pixels checkbox is off. 

• Change the image resolution (size) with fixed number of pixels. 
§ Select the Fixed size in pixels checkbox. 
§ Enter the new resolution (size, scale) value. 

Cropping image 
Cropping commands are located in the Crop submenu of the Image 
menu. 
You can: 
• Crop blank margins of the raster image. 
• Crop the raster image by its frame. 
• Crop the raster image by a rectangle specified on the screen. 

• Crop the raster image by pre-defined clip. 

Information on Image Clip is provided on page 15. 

Rotate and mirror 
These commands located in the Image menu, allow you to rotate an 
image by 900, 1800, 2700, or by an arbitrary angle; and also mirror 
an image about X-axis or Y-axis. 

The other commands for editing raster images are provided in 
section Enhancing Scanned Images on page 34 

Editing Vector Polyline 
The polyline editing commands are located on the Edit Polyline 
toolbar, and also in the context (right-button) menu. Select a polyline 
to edit. 
You can apply the following commands: 

 
Close polyline by joining end nodes 

 
Close polyline with a new segment, which connects end 
nodes 

 
Add a new vertex at a specified point 

 
Break polyline at a specified point or node 

 

IMPORTANT: The following operation requires the 
selection of polyline nodes. For this, you need to press the 
Node Selection button of the Select toolbar.  
Now you can select polyline nodes by mouse click. 

 
To delete a polyline node, select it and press the Delete 
node button 

 tw o
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l by connecting specified end nodes with linear 

segment 
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by connecting specified end nodes with arc 
segment 

 
by joining specified end nodes 

 

Transforming a specified arc segment to a linear segment. 
To specify a segment, click on its first node; nodes are 
numerated from the polyline start. 

 

Transforming a specified linear segment to an arc. To 
specify a segment, click on its first node; nodes are 
numerated from the polyline start. 

Search and Replace 
Search and replace operations allow you to: 
• Find raster fragments and replace them with other fragments or 

vector objects. 
• Find vector objects (which can consist of lines, arcs, circles, and 

polylines) and replace them with other vector objects. 
How to perform search and replace 
• Choose Search - Replace from the Edit menu. 
• Define a sample for searching – raster or vector fragment, and 

then place it in the Find What field of the Search - Replace 
dialog box. 

• Define a sample for replacing – raster or vector, if you search for 
raster fragment; and only vector, if you search for vector 
fragment. 

• Set the accuracy value. 
The position of the Accuracy slider defines the deviation of found 
objects from the sample for searching. 

• Select the Erase checkbox to erase original elements. 
• Select the Only Standalone Symbols checkbox to search for only 

standalone raster objects or vector symbols. 
• Press the Find button to search and replace symbols one by one. 

Press the Replace All to search and replace symbols in automatic 
mode throughout the entire document. 

 

Enhancing Scanned Images 
Brief description: This section demonstrates ways of enhancing 
scanned monochrome images – deskewing, filtering, and eliminating 
distortions using calibration and four-point correction. Also, we give 
you some recommendations about restoring poor quality images. 

Deskewing 
When paper is fed through a scanner the direction of the paper often 
deviates from the orthogonal, therefore the resulting scanned image 
is skewed, sometimes rather considerably. 
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The special command – Deskew is used to deskew an image.  
The command works in two modes: 
1. Auto Deskewing – program automatically estimates the skew 

value, and then performs deskewing. 
Choose Deskew from the Image menu, and then –Auto 

2. Manual Deskewing – you can use this mode, if the result of 
Auto Deskewing is not satisfactory. 
In this mode you can specify a skew angle by specifying a line, 
which must be horizontal or vertical. 
Choose Deskew from the Image menu, and then –Manual. 

  

Press the 
Measure Angle 
button in the 
displayed dialog, 
and then specify 
the deskew line 
with two points. 
You can use snap 
tools during this 
operation. 

Manual deskewing After deskewing 

Filtering Monochrome Images 
There are a number of different filters available within WiseImage, 
which allow you to considerably enhance the scanned monochrome 
raster image. You can apply filters to the whole image or to a 
fragment. You can also apply filters to several raster images 
simultaneously. 
Using the filters, you can:  
• Remove raster speckles 
• Remove holes (white points in black raster lines or filling) 
• Invert images 
• Smooth raster objects 
• Thin and thicken raster objects 
• Transform filled raster area to one-pixel contour 
All commands for filtering monochrome images are located in the 
Filters menu. 

Speckle Remover 
Choose Speckle Remover from the Filters menu. 
You can specify the size of raster speckle on the screen using the 
measure buttons of the Speckle Remover dialog.  
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If the Auto 
Estimating 
checkbox is on, the 
program 
automatically 
estimates the 
speckle size. You 
can apply the filter 
several times. 

Before applying 
Speckle Remover  

The result of applying 
Speckle Remover 

When applying the filter to the image of very poor quality some data 
may be lost. To avoid it, you can use the operation of Separation by 
size. 

See page 38 for information on separation by size for the 
monochrome image. 

Hole Remover 
Choose Hole Remover from the Filters menu. 
You can specify the size of raster speckle to remove on the screen 
using the measure buttons of the Hole Remover dialog box. 

 

If the Auto Estimating 
checkbox is on, the 
program automatically 
estimates the speckle 
size. Before applying 

Hole Remover 
The result of applying 
Hole Remover 

Inversion 
Choose Inversion from the Filters menu  

  

This filter reverses 
the color of the 
monochrome image: 
After applying this 
filter the background 
dots become the 
image dots and vice 
versa. Before applying 

Inversion 
The result of applying 
Inversion 

Smoothing 
Choose Smoothing from the Filters menu  
This filter smoothes 
raster object 
outlines, fills edge 
and inner 
background droplets, 
and partially   
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Before applying 
Smoothing 

The result of applying 
Smoothing 

 
Tuning Smoothing filter  

The Smoothing filter is 
tuned by setting optimal 
values of Medianning and 
Threshold. You can 
estimate the result before 
applying the filter in the 
preview window. 

Thinning and Thickening filters 
Choose Thinning (Thickening) from the Filters menu  

  

Thinning filter makes 
raster objects thinner 
in the specified 
directions; by one 
pixel for one pass. 
You can specify a 
number of passes.  

Before applying 
Thinning 

The result of applying 
Thinning 

If needed, you can apply the mode of thinning raster objects up to 
skeleton – i.e. only pixels in the middle are left. 
Thickening filter makes raster objects thicker in the specified 
directions. You can specify a number of passes and choose any 
combination of thickening directions. 

Contour (4-coupling and 8- coupling) 
Choose Contour from the Filters menu 
Contour filters convert filled raster areas to one-pixel contours. 

 
Before applying Contour  The result of applying Contour  
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Separating Monochrome Images by Size 
This operation is effective in the following cases: 
• If you want to prevent important small objects from being removed 

while applying the Speckle Remover filter (e.g., dots in dashed-
dotted lines; lines which consists of multiple small fragments, 
delimiters, etc). 

• If you work with an image of very poor quality. 
The principle of the separation by size operation is similar to speckle 
removing, except speckles are not removed but transferred to a new 
raster layer; and then the user can select fragments incorrectly 
transferred to this “speckle” layer and bring them back to the 
drawing. 
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The significant elements have 
been brought back from the 
“speckle” layer to the basic layer; 
the “speckle” layer is removed 

Eliminating Distortions Using Calibration 
Calibration – is applied to eliminate arbitrary (both linear and non-
linear) distortions of monochrome, grey-scale and color raster 
images. 
IMPORTANT: You should calibrate the raster image before 
vectorization (tracing), because if you vectorize a distorted image you 
will obtain distorted vector data that is impossible to correct later. 
Calibration terms 
The original image must contain points with known coordinates. 
These points are called real points. You can use nodes of a 
rectangular grid as real points (if you work with mapping materials) 
and/or other points, which coordinates are known or can be 
calculated. 

The points, which correspond to the real ones on the distorted image, 
are often located with some displacement (i.e. they have different 
coordinates). These points are called measured point, as their 



 
39 

coordinates value can be measured on the raster image. 
By applying calibration, the raster images is transformed so that the 
measured points coincide with or are extremely close to the real 
points. 
TIPS: before applying calibration you should set the User Coordinate 
System by specifying its origin and scale. 

See section Document Coordinate System on page 7 for 
information on setting Uses Coordinate System. 

How to calibrate an image 
Choose Calibration from the Image menu. 
Step 1. Defining real points 
We can define rectangular grid nodes and points with known 
(estimated) coordinates. 
Defining grid: Grid is defined by the three parameters: start point 
(coordinates of lower-left node), cell size (by X and Y axis), and grid 
size (by X and Y axis). 

• Press Define Grid  on the Calibration toolbar. In the 
Calibration Grid dialog: 

• Specify the coordinates of the lower-left grid node in Origin. 
You can enter the coordinate values of the lower-left grid corner 
in the corresponding field or specify it with the cursor on screen. 

• Enter the number of grid cells along X and Y axis in Size field. 
• Enter the cell size along X and Y axis in Cell field. 
• If the grid is rotated about the coordinate axis, enter the skew 

angle relative to X-axis in Angle field. 
TIPS: Use the Preview button to make sure that the grid is properly 
specified. 
Specifying points with known coordinates: 

• Press Add point  button from the Calibration dialog. Enter the 
point’s known coordinates in Real field (use separating character 
between X and Y values). 
You can enter a name for the point in Label field; alternatively the 
program numbers the points consecutively. 

• Do the same for all points. 

Step 2. Specifying measured points 

To begin step 2 you can press Next Point . WiseImage places 
the first point from the list in the screen center and highlights it with 
grips. 
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You see the real (correct) 
coordinates of the first point 
with grips. 

Drag grips to the grid node on 
the scanned image – so you 
specify the “measured” point. 

To shift to the next (previous) point, use Next (Previous) point. 
You can also use the acceleration keys: N (Next) or Tab – to shift to 
the next point and P (Previous) – to the previous. 
Step 3. Choosing calibration method 
Choose the optimal method from the pull-down list of 
Calibration Method field. 

 

What method to choose? 
• If you are sure of the proper method, 

choose it from the list. Estimate the 
accuracy of this method by pressing 

Estimate  button. 

• If you are not sure of the proper method, 
select Choose automatically from the 
combo-box of the calibration method.  

Step 4. Running Calibration 
• IMPORTANT: If you have several raster images in your document, 

select one(s) that need calibrating using the specified set of 
calibration pairs. 

See page 26 for information on raster image selection. 
• Run calibration by pressing the Apply button. 

Four-Point Correction 
You can use this operation for quick correction of scanned technical 
drawings, which contain a frame. This operation assumes that both 
frame and contents of the image have the same distortion. 
How to correct an image by 4 points. 
• IMPORTANT: If you have several raster images in your document, 

select the one to calibrate by four points. 

See page 26 for information on raster image selection. 
• Choose 4 point correction from the Image menu. 
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• Enter the frame size in the Width and Height fields of the 4 point 
correction dialog. 
You can also choose a standard frame size from the list of Frame 
Size or find the closest by pressing Find Closest paper. 

The list of standard formats is set in the Properties dialog. See 
information on page 80  

• Press Find Frame  – the program finds and highlights the 
image frame. 
If the frame is defined correctly: 
§ Press OK. 
Alternatively: 

§ Press Measure frame  button, and then specify four points 
of the frame on the screen. 

§ Press OK. 

Autocorrecting Image 
Autocorrect runs a set of predefined operations. 
How to apply autocorrection. 

 

• Choose Preferences from the Tools 
menu.  

• Specify a set of commands to apply 
with autocorrection using the 
Preferences dialog. Close 
Preferences. 

• If you have several raster images in 
your document, select the one(s) to 
apply autocorrection to. 

See information on raster image 
selection on page 26. 

• Choose AutoCorrect from the Image 
menu. 

NOTE: The parameters of the commands included in the 
autocorrection list (except Rotate) are automatically defined. For 
example, deskewing with auto definition of rotation angle, removing 
speckles with auto definition of speckle size, etc. If you want to 
specify the parameters of executed commands precisely, use the 
batch process. 

See information on batch process on page 76. 

Editing Raster Text 
You can edit raster texts –original text under the defined rectangle is 
erased and replaced with new text. 
• From the Draw menu, choose Raster, and then Edit Raster text. 
• Draw a frame over the text to be modified. 
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While drawing, you can specify the frame angle in the 
corresponding field of the Inspector.  

• Enter new text in the Text field of the Inspector. 
You can set text parameters in the corresponding fields of the 
Inspector. 

   
Original raster text Selected text area After editing 

Restoring Images of Poor Quality 
How to work with a raster image of very poor quality. 
There isn’t much choice – either redraw it in the document with the 
corresponding program, or restore it with a hybrid editor 
(vectorization of such document produces poor results).  
The purpose of this section is not to discuss the plus and minus points 
of these choices, but to provide you with some methods to restore 
scanned documents of poor quality. 
• Separating an image by size – can be used for blueprints, images 

on dark backgrounds, with lots of speckles. 

Information on separating image by size is provided on page 38. 
• Editing selected raster objects (modifying their properties, 

geometry using «grips» and others.) 

Information on editing selection is provided on page 28. 
• Tracing in smooth mode. 
• Tracing in vector producing mode. Editing and rasterizing the 

obtained vector object. 

Information on tracing is provided on page 55. 
• Drawing missing raster lines in Raster drawing mode. 

Information on Raster drawing mode is provided on page 23. 

• Editing raster texts 

Information on editing raster texts is provided on page 41. 

Example of restoring an image  

 

Original image fragment 
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Choosing and editing the axe 
line 

 

Result of editing the axe line 

 

Tracing the curve in smooth 
mode 

 

Hatch on the original raster 
image 

 

Tracing the hatch in Create 
Vector and Erase Raster mode 

 

Rasterizing the vector hatch 

Then you can apply the following actions: 

  

Edited raster image Selecting the whole raster image 
(or fragment) 
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Deleting isolated raster fragments 
from the selection  

Removing speckles, which were not 
selected. 

 

Editing Color Images 
Brief description: This section is devoted to methods of enhancing 
color and greyscale raster images – correcting image brightness, 
contrast, hue, and saturation; correction by histogram, and filtration. 
You will also learn about converting images to RGB, 8-bit indexed and 
greyscale; layering color and greyscale images to monochrome 
layers. 

Correcting Image Brightness, Contrast, Hue, and 
Saturation 

You can tune brightness, contrast, hue and saturation of color and 
greyscale images. 
Choose Brightness/Contrast from the Image menu. 
Using Brightness/Contrast dialog, you can tune: 
• Brightness of color and grayscale image 
• Contrast of color and grayscale image 

• Hue of color image 
• Saturation of color image 
You can tune the parameter value using the sliders or entering the 
values in the corresponding fields. 

Correction by Histogram 
Using correction by histogram you can tune the image brightness, 
hue and contrast. You can apply automatic correction by histogram or 
tune the parameters manually. 
Choose Equalize from the Image menu. 
To correct an image by histogram automatically, press the Auto 
button of the Equalize dialog.  
To correct an image manually you need to specify three values: 
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lightest and darkest levels, and image gamma – for each channel or 
for Master channel. 

• darkest level (the left slider position) 

is set using the dark eyedropper , 
using which you can specify the colors 
to turn black 
All pixels included in the histogram 
area from 0 to the left slider, will turn 
black. 

• lightest level is set using the light 

eyedropper , using which you can 
specify the colors to turn white. 
All pixels included in the histogram 
area from the right slider to 256, will 
turn white. 

• Using the middle slider, specify the value of image gamma. 
Moving the middle slider to the left increases the gamma value; the 
image becomes lighter. 
Moving the middle slider to the right reduces the gamma value; the 
image becomes darker. 
• When you achieve satisfactory results in the Preview window, press 

the Apply button. 

Color Filters 

Blur 
This filter produces a blur effect on an image. For example, you can 
apply the Blur filter to an image which has texture fills. 
Choose Blur from the Filters menu. 

 

• Set Radius for the filter. 
Increasing the radius value also 
increases image blurring. To 
modify the Radius value use the 
slider or enter the value in the 
field. 

• When you achieve satisfactory 
results in the Preview window, 
press the Apply button. 

Adaptive Blur 
This tool is designed for blurring not uniform color areas inside the color 
transition boundaries in the image. It works on grayscale and color images. 
The blurring makes an impression that an image is slightly «out of focus». 
The Adaptive Blur filter in contrast to the Blur filter tries to recognize color 
transition boundaries in the image and leave them unchanged, without 
smoothing. 
Start the command Adaptive Blur from the Filters menu. 
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• Sets the Radius value, which 
determines the depth (in pixel) of the 
filter effect on the color area. 

• When you achieve satisfactory 
results in the Preview window, 
press the Apply button. 

 

Unsharp Mask 
This filter is designed to increase the sharpness of color boundaries, 
producing an overall increase of image sharpness. For example, this 
filter can be used to correct images that became blurred after 
interpolation – e.g., after such operations as rotate, scale, alignment, 
calibration or four-point calibration, and also resize and resample. 
Choose Unsharp Mask from the Filters menu. 

 

• Set Radius – “level” of the filter 
effect. Increasing the radius 
value increases the number of 
pixels surrounding the color 
boundary that are to be 
processed. 

• Set Sensitivity for the filter 
using the slider or enter the 
value in the corresponding 
field. Increasing this value 
provides a stronger effect. 

Applying small Radius values results in an increase of sharpness only 
on color boundaries. 
• When you achieve satisfactory results in the Preview window, press 

the Apply button. 

Median 
This filter reduces image noise, analyzing all pixels within the 
specified radius and assigning the central pixel the averaged value of 
reviewed pixels. As a result, pixel color and brightness are evened. 
For example, Median filter can be used to eliminate image “grain”. 
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Choose Median from the Filters 
menu. 
• Set Radius for the filter – area 

within which color values are 
to be to analyzed.  

• When you achieve satisfactory 
results in the Preview window, 
press the Apply button. 

Convert to RGB, Greyscale, 8-bit indexed 

Convert to RGB (greyscale) 
• If your document contains several raster images, select the one(s) 

to convert to RGB (greyscale). 
• From the Image menu, choose Convert to, and then Convert to 

RGB (Convert to greyscale) 

Convert to Indexed colors 
You can convert full-color images (24 bit per pixel) and monochrome 
images to 8-bit-indexed (8 bits per pixel).  
This operation can be used to reduce the size of a full-color file, and 
therefore speed up working with it. Note that in some cases the 
converted image might have lower quality due to some information 
loss. 

• If your document contains several raster images, select the one(s) 
to convert to 8-bit indexed. 

• From the Image menu, choose Convert to, and then Convert to 
Indexed colors. 

 Execution order 

Calculating the 
optimal palette 
for the selected 
image(s) 

• Press Set auto palette  

Recalculating of 
palette for 
specified color 
number 

• Specify the color number in the Colors 

 field 

• Press the Reset Palette  button 

Selecting colors 
from the palette 

• Press Shift, select colors from the palette by 
clicking on them (if only selecting one color 
there is no need to press Shift) 

NOTE: Select the Light Paint checkbox 

 button to view selected colors in 
the Preview window 

Merging selected 
colors  • Press Merge Colors  button 
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Deleting selected 
colors  • Press Delete Colors  button 

Changing 
selected color(s)  

To Change selected color(s):  
• to the specified color– Press Get color to set 

 and choose a desired color from the Color 
box.  

• to one color of the image – press the button 

with eyedropper , and then specify a 
desired color on the screen. 

Adding color(s) 
to the palette 

• Enter desired number of colors in the Colors 
field. 

Press Set auto palette  
  – or  – 

• Click on a blank palette cell. 
Click on the added field, and assign the color 
as described above in section Changing 
selected color(s). 

Separating Color & Greyscale Images to 
Monochrome Layers 

This section describes the operation of separating color or greyscale 
raster images to monochrome layers. 

Binarization allows you to extract pixels of specified colors (or close to 
them) to a monochrome layer. For example, when you binarize a 
map, first you get a monochrome layer that contains isolines; then a 
layer that contains roads, etc. 
Color Separation allows you to separate a color or greyscale image to 
several monochrome layers with a single operation; each image pixel 
is transferred to one of the resulting monochrome layers. 

Binarization 
Using binarization you need to specify the color range(s) for a created 
layer, e.g., for hydrography layer – from light-blue to dark-blue.  
• Choose Binarization from the Image menu. 
• Choose binarization method – Range or Threshold. Set the 

parameters for the chosen method (Color model (RGB, HSV, Grey), 
channel (grey, red, green, blue, hue)). 

• Specify a layer and its color to place the new monochrome image 
to. 

• Using one of these eyedroppers  specify the colors on 
the screen; they are added to the list of the Colors list.  
The estimated binarization results are highlighted in the preview 
window. 
You can choose any incorrectly selected color from the colors list, 
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and then remove it using the Delete  button. 
• Tune the results using the sliders located in Ranges (Threshold). 
• You can delete small speckles that appear using the slider Noise 

Reduction. 
• When you achieve satisfactory results in the Preview window, press 

Apply. 

Color separation 
To execute Color separation set color categories (thematic layers), by 
which you want to separate the image, and then set a list of colors 
for each category. 
• Choose Color separation from the Image menu. 
• Specify the first category color on the image using the eyedropper 

Add category . Choose a standard color; specify a name for 
the category in the displayed Category name and color dialog. 

• Using the eyedropper Add color, specify all colors of the image, 
which should fall within this category.  

• Repeat the previous two steps for all categories, which you want to 
set on a new layer. 
Incorrectly defined categories and colors can be selected and 

deleted from the list using the Delete  button. 
• Using the Noise Reduction slider you can adjust the sensitivity of 

Color separation – smooth contours. 
• Deleting small-sized speckles is executed when the Despeckling 

checkbox is set to on. 
• When you achieve satisfactory results in the Preview window, press 

Apply. 

Advanced Color Tools 

Color Classifier 
This versatile tool allows you to manage the colors within the image.  It 
is not applicable to monochrome images. You can reduce the palette by 
deleting the selected color or colors or by merging several colors into 
one. You can also replace selected colors and add them to the palette. 
To open Color Classifier dialog - choose Color Classifier from the 
Image menu. 
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The buttons and controls in the Color Classifier dialog window 

 Color 
samples 
table 

This table contains color samples of 
the current palette. Select a color by 
clicking on it. Clicking while holding 
down SHIFT selects multiple colors.  

 
Color counter This control is used to show the 

number of colors in the current 
palette (from 2 to 256). You can 
increase or reduce this number. 

 
Set auto 
palette 
button 

By pressing this button WiseImage 
will automatically determines the set 
of colors that most truly represents 
the image and places them into the 
color samples table.  

 
Recalculate 
palette 
button 

By pressing this button you force 
WiseImage to reset the palette up to 
the number specified in the counter 

 View 
Selection  

When this box is checked, the points 
of selected colors are shown on the 
image.  

 

Choose a 
color from 
the image 

This tool is used to obtain a color by 
clicking on a pixel in the document 
window. The color of the selected 
pixel will be highlighted in the Color 
samples table. 
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Select colors 
from the 
image 

This tool is used to obtain colors by 
drawing a polygon around an area in 
the document window. Double-click 
to finish the polygon. The colors 
contained within the polygon will be 
selected in the Color samples table. 

 

RGB button Opens the color selection dialog, 
which lets you replace the currently 
selected color with a new one.  

 

Merger 
button 

Merges the colors selected in the 
color samples table to the mean 
color. 

 

Delete 
button 

Deletes the colors selected in the 
color samples table from the palette.  

 
Save LUT Saves the current palette in a Look-

Up Table (LUT) file. 

 
Load LUT Loads the current palette from a 

Look-Up Table (LUT) file. 

 Template You can save and load color palette 
information to and from a template 
file using this button.  

When the palette will be build – press OK. 
 

Adaptive Binarization 
Adaptive Binarization tool eases the conversion of scanned Grayscale 
images with difficult background. This brand new tool makes a 
workflow while operating with a drawings and sketches on a rough 
colored background (i.e. blueprints and sepias) fast and easy.  
Choose Adaptive Binarization from the Image menu. 
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• Set Radius – “level” of the filter effect. Increasing the radius value 
increases the number of pixels surrounding the color boundary 
that are to be processed. Generally, the best results can be 
attained by setting the Radius value approximately two times 
thicker than the thickest linear object on the image. 

• Set Smooth checkbox (if required) and adjust the parameter. 
Using smoothing with the Binarize checkbox set to off produces a 
cleaner image with the background evened and line objects 
revealed 

• Set Binarize checkbox (if required) and adjust the parameter. 
Binarize – binarization using Threshold value. The method used – 
Threshold by grey – is described in the previous section. 

 
 

Rasterizing; Merging Raster Images 
Rasterizing Vector Data 

You can rasterize vector data on raster images, and either retain or 
delete the original vector objects. 
Select the vector objects to rasterise; must be located over the raster 
image. 
Choose Merge (Rasterize) from the Modify menu. 

   

Original vectors Rasterizing on 
monochrome raster 

Rasterizing on color 
raster 

Vector objects located outside the boundary of the raster image 
disappear. 
If vector objects are located over several raster images, they are 
rasterized on all visible images, located on unlocked layers. 
TIPS: If you want to rasterize vector objects without removing the 
vector originals, use the command Merge a copy (Rasterize) from 
the Modify menu. 

Merging Raster Images 
You can merge a raster image or raster selection with another raster 
image. 
Select a raster image (or its fragment) and choose Merge 
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(Rasterize) from the Modify menu. 
If the selected raster data (or part of it) is placed outside the 
destination raster image area, it disappears. 
If the selected raster data is located over several raster images, it is 
rasterized on all visible images, located on unlocked layers. 
TIPS: If you want to merge a raster image without removing the 
original image, choose Merge a copy (Rasterize) from the Modify 
menu. 
 

Tracing 
Tracing is an interactive (or semi-automatic) vectorization procedure. 
During the tracing procedure raster objects are specified one by one, 
these are then recognized by the program and converted to 
corresponding vector objects. 
In the process of tracing the original raster objects can be deleted, 
smoothed or left intact. 

Tuning Tracing 
You should tune the tracing parameters before applying this 
procedure. 
Tracing is tuned in the R2V Conversion Options dialog or by the 
Raster Properties toolbar (for quick preview). 
Raster Properties toolbar quick preview 

 

• Tune the parameters in the 
same manner as will be 
described below  

• Select Draw R2V preview 

 button  
• Draw by rectangle the preview 

zone of the image. 
To specify all the conversion setting for tracing - choose 
Conversion Options from the Convert menu. 

Tuning geometry of traced objects: 
Open the Options tab of the R2V Conversion Options dialog.  
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Max.Width – maximum width 
of traced raster objects. 
Measure width of the widest 
traced lines. Set this parameter 
value slightly greater then the 
measured width. 
Max. Break – length of ignored 
break of raster lines. 
If you trace dashed lines, set 
the value of this parameter 
slightly greater then the 
maximum gap between dashes. 

Accuracy – set the accuracy value for tracing polylines to high (for 
more precise approximation of raster curves with vector polylines). In 
other cases increase the accuracy value for images of good quality; 
and reduce the value for images of poor quality. 

Layering resulting vector objects 
You can place resulting vector objects on different layers: 
• Create the desired layers in Layer Manager. 

See section Layer Manager on page 8 for information on Layer 
Manager. 

 

• Open the Separate tab of 
the R2V Conversion  
Options dialog. 

• From the pull-down list of 
Layer select one to place 
the traced vector object. 

• Select the Use Table 
checkbox. 

Orthogonalization mode with tracing 
When tracing lines and polylines, you can use orthogonalization 
mode, which allows you to obtain orthogonal vector lines and 
polylines that consist of orthogonal segments (the base angle can be 
calculated automatically or specified). 
• Tracing lines with orthogonalization 

IMPORTANT: The operation can only work if the raster line you 
want to trace deviates from the orthogonal (or specified) direction 
by no more than 20. To turn on line orthogonalization mode: 

Open the Options tab of the R2V Conversion Options  
§ dialog. 

Select the Orthogonalization checkbox. 
§ If necessary enter the base angle value in the Base Angle 
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field, and then clear the Auto Estimate base angle 
checkbox. 

• Tracing with resulting polyline of orthogonal segments  

This information is provided in section Tracing polylines with 
orthogonal segments on page 58 

Tracing Modes and Commands 
Before executing tracing, you should choose a tracing mode. 
Tracing modes: 

 
Original 
fragment      

 
Produce vector 
and keep raster      

 
Produce vector 
and erase raster  

     

 

Erase raster 
without 
producing 
vector 

 

 

Smooth raster 
without 
producing 
vector 

  

Tracing command: 
You can trace: 

 
Lines, arcs, circles with 
auto recognition  

Hatches which consists of 
lines 

 
Lines by two points 

 
Raster symbols 

 
Arcs by three points 

 
Polylines 

 
Circles by two points 

 
Outlines 

How to Trace 
• Set the tracing parameters 

Information on setting tracing parameters is provided on page 
53. 

• Choose from the Raster to vector toolbar or from the Trace 
menu: 
§ Tracing mode 
§ Tracing command 
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Information on tracing modes and commands is provided on 
page 55. 

Tracing Lines, Arcs, Circles, Outlines 

 

You can trace raster lines, arcs, circles, and 
outlines with automatic recognition of their type – 
click once on the desired object. 

 

If you work with a complicated image, or an 
image of poor quality, or you need to vectorize 
only part of a raster entity, you can apply forced 
tracing. 

Auto extension mode: When tracing lines or arcs you can use the 
Auto extension mode – you only need to specify a fragment of the 
object, but the program recognizes the whole object. To switch to this 
mode select the Auto extend vectors checkbox in the Trace tab of 
the R2V Conversion Options dialog. 

Tracing Hatches 
To trace a hatch, you need to intersect all its lines with a crossing 
polyline. 
TIPS: raster lines that cross the hatch interfere in the recognition 
operation, so before tracing the hatch, it may be useful to trace these 
lines and erase the original raster. 

    

Original hatch 

Tracing lines that 
intersect hatch 
(with erasing the 
original raster) 

Tracing hatch – 
intersecting 
hatch lines 

Result of hatch 
tracing (in 
Produce Vector 
and Erase Raster 
mode) 
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Tracing Polylines 

 

Tracing polylines produces 
vector polylines which 
approximate raster curves. 
To increase accuracy of 
approximating vector polyline 
to the original raster curve 
increase the Accuracy slider 
in the Options tab of the 
R2V Conversion Options 
dialog. 

See page 54 for 
information on tuning 
tracing. 

How to trace polylines 
• Select tracing mode (e.g., Produce Vector and Keep Raster). 

You can see the information of section Tracing Modes and 
Commands on page 55. 

• Run the Linefollowing command. 
• Specify a point on the raster curve – the program tracks this curve 

up to the nearest intersection and waits for you to indicate the 
direction in which tracing should continue. 
You can also use the Autodetect direction mode: 
Open the Trace tab of the R2VConversion Options dialog.  
Select the Autodetect direction checkbox. 
Set the waiting period (in sec) in the Pause field. 

• If you turn on the Autodetect direction mode, and you are 
satisfied with the autodetected direction, indicated by a cross, 
press the Space key (alternatively, the program continues tracing 
after the waiting period expires). If you are not satisfied with the 
direction suggested by the program, specify the right direction on 
the screen. 
If Autodetect direction mode is off, you must specify the next 
fragment of the raster curve on screen (fragment between two 
nodes or between node and end point of the raster curve). 

• If you need to change the tracing direction, chose Change 
direction from the context menu. 

• To cancel the last segment of the vector polyline, press 
Ctrl+Backspace. 

• To cancel the last step, press Backspace. 
• If needed, you can draw segments in Free Hand Drawing mode. 

Press Shift and specify the new nodes of the vector polyline on the 
screen. 

• When you have completed tracing the polyline, press Enter. 
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TIPS: You can use the Centralize View command from the context 
menu for convenience. 

Tracing polylines with orthogonal segments 
When tracing, you can obtain vector polylines with orthogonal 
segments. For example, this mode can be used to trace buildings on 
scanned maps. 
The direction of the first segment can be estimated automatically or 
specified. 

 

To obtain polylines with orthogonal 
segments: 
• Open the Trace tab of the 

R2VConversion options dialog. 
Select the Line Follow 
Orthogonalization checkbox. 

• Select the Autoestimate Base 
Angle checkbox or specify the 
angle for orthogonalization in the 
Base Angle field or by the 
measure button. 

TIPS: You can reduce the Accuracy value to avoid creating 
unnecessary segments. 

See page 54 for information on tuning tracing. 
If needed, you can create a vertex at each point of intersection on 
the polyline. – Select the Place vertex on nodes checkbox in the Trace 
tab of the R2VConversion options dialog 

Tracing Outlines 
You can trace raster outlines. Tracing results depend on the 
parameters and mode of tracing. Tracing parameters are set in the 
Trace tab of the R2V Conversion Options dialog.  

Setting parameters of tracing outline 

Auto Extend 
vectors – Off 

Creates vector on two colors 
boundary. 

 

Auto Extend 
vectors – On 

Creates vector at the center of 
raster line. 
IMPORTANT: Raster line width 
is specified with the Options tab 
of the R2V Conversion Options 
dialog. 

 

Export single 
contour – Off 

Creates outer and nested 
outlines. 
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Export single 
contour – On 

Creates the outer outline only. 

 
Auto Extend 
vectors – On 
Export single 
contour – On 

 Trace 
mode – keep 
raster  

Raster data inside the outline is 
kept. 

 

Auto Extend 
vectors – On 
Export single 
contour – On 

 Trace 
mode – erase 
raster. 

Raster data inside the outline is 
erased. 

 

How to trace outlines 
• Set the trace outline parameters. 
• Specify the tracing mode (for example, Produce Vector and Erase 

Raster). 

You can see information of section Tracing Modes and Commands 
on page 55 

• Run the Trace Outline command. 
•  Specify a point inside the outline. 

Tracing Raster Symbols 
See section Polylines collecting 
The Collect Polylines command is designed for assembling vector 
polylines obtained as a result of the trace or automatic 
vectorization. When checking the results it is best to use the 
raster image as a substrate. 

To perform polylines collecting do following: 
• Choose the Collect Polylines from the Correct menu to start this 

command. 
• Click the first polyline. 
• While the cursor is moving, you can see which polyline will be 

added to the current one and what you will have as a result. 
Choose the next polyline by clicking on it. Click the next polyline. 
The program automatically pans to the end point of the resulting 
object. 



 
60 

Use right-button menu during command running: 

Back step Cancels the latest step. 

Cancel Cancels the command and current polyline creation. 

Continue Continues the command. 

End Finishes current polyline collecting. 

Close Closes current polyline. 

Change 
Direction 

Changes the current collecting direction. 

Centralize 
View 

Pans an image to show the latest added polyline 
nodes at the screen center. 

• Set Auto Properties item in Inspector to off value and change 
the properties of the resulting polyline (such as its color, thickness, 
markers) in during the command execution. 

• Use special modes for modifying the resulting object during 
polyline assembling process: 
Case 1: polyline1 
has a stray tail, 
and you need to 
attach it to 
polyline2 
Press CTRL and click 
a point on the 
current polyline1 in 
which it must be 
broken. You will 
continue polyline 
assembling from this 
point. 
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Case 2: polyline2, 
which you want to 
append, has a 
stray head 
Press CTRL and 
specify a point on 
polyline2 to which it 
must be attached. It 
will be broken in this 
point and added to 
polyline1. 

 

Case 3: to close a 
current polyline 
Press CTRL and click 
on one of the current 
polyline  
end points. The 
polyline will close and 
the command will be 
finished. The closed 
polylines are 
highlighted with 
rounds, instead of a 
square form for 
grips. 

 

Case 4: to draw a 
segment of a 
polyline manually 
Press SHIFT and 
draw as many 
segments as 
necessary. 
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Case 5: to add 
some vertices to a 
current polyline 
Press CTRL+SHIFT 
and add a necessary 
number of vertices. 

 

 
Working with Raster Symbols on page 71 for information on 
tracing raster symbols. 

 

Automatic Vectorization, Text Recognition 
Automatic vectorization is a procedure for converting raster data to 
appropriate vector objects. 
WiseImage recognizes the following objects when vectorizing: lines, 
arcs, circles, hatches, points, texts and symbols. Raster curves and 
filled contours are approximated with vector polylines.  
The program can recognize line styles and arrows on line and arc 
ends. 
You can train the program to recognize new symbols and texts. 
You can round vector object widths to specified values. You can also 
place vector objects corresponding to raster lines of various widths on 
different layers and/or assign different colors to them. 

Tuning Vectorization 
You can use one of the pre-defined templates or tune the parameters 
yourself. 
Vectorization parameters can be saved as a template for further use. 
Automatic vectorization is tuned in the R2VConversion Options 
dialog or by Raster Properties (for quick preview) – see Tracing. To 
open the dialog, choose Conversion Options from the rConvert 
menu. 

Select objects to recognize: 
Open the Recognition tab of the R2VConversion Options dialog. 
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Select the entities, which you want to obtain 
after vectorization – select the corresponding 
checkboxes. 
The additional parameters for recognized 
objects, such as line type, arrows, hatch 
angle, and others are located on the second 
level. Click on “+” to get access to these 
parameters. 

Setting the geometry of vectorized drawing: 
The geometry is set in the Options tab of the R2Vconversion 
Options dialog. 

 

Min Length –minimum length of a 
raster object to be recognized. 
(For example, enter 1 mm in the 
Min Length field so that raster 
fragments smaller than 1 mm will 
not be recognized). 
Max Width – maximum width of 
raster lines. Set the value of this 
parameter slightly greater than the 
measured line width on your 
drawing. 

Max Break – maximum accepted length of a break in a raster line to 
be ignored. Set the value of this parameter slightly greater than the 
distance between dashes in dash lines or the broken distance in poor 
quality lines. 
Text Height – Set the value for this parameter equal to the 
maximum height of raster text symbols of upper case. 
Accuracy – this parameter corresponds to the accuracy of your 
raster image. Use a high Accuracy value for images of good quality, 
and a low Accuracy value– for images of poor quality. 
Orthogonalization – select this checkbox to obtain orthogonal 
vector lines as a result of vectorizing raster lines, which deviate from 
the orthogonal direction by not more than 20. 
You can also align vector objects to a specified base angle; enter the 
angle value in the corresponding field. 

Separating vector objects by layer and /or by color 
The criteria for separating vector objects (by layer and/or color) is 
the width of the original raster lines. 
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In the Separate tab of the 
R2V Conversion Options 
dialog, you can: 

• Specify width of resulting 
vector objects  

• Separate resulting vector 
objects by color 

• Separate resulting vector 
objects by layer 

In the Width field you can specify widths for vector objects obtained 
after vectorization of raster objects with line widths included in the 
interval, defined with the Start and End fields. You can also define a 
layer and/or color for these vector objects in the corresponding fields. 

How to Vectorize 
• Set vectorization parameters. 

Information on tuning vectorization is provided on page 62 
• If you have several images in your document, select the one(s) to 

vectorize. 
You can also vectorize a selected image fragment or image clip. 

• Choose Raster2Vector from the Conversion menu. 

Text Recognition 
This section provides information on various algorithms for 
recognizing raster text; the procedure and parameters of setting up 
raster text recognition. 

Text Recognition Algorithms 

 

You can use the following algorithms for working 
with raster texts. You can choose them using the 
Recognition tab of the R2V Conversion Options 
dialog. 

 

None – this algorithm searches for raster text areas 
without vectorizing. 

 

Text Areas – this algorithm recognizes and creates 
text areas. You can enter text information in these 
text areas using the procedure of editing recognized 
texts. 

Information on editing recognized texts is 
provided below on the current page 

 
Polylines (Outlines) – approximating the raster 
text with vector polylines (outline). 
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OCR – recognizing the raster text and creating the 
corresponding text objects. 

How to recognize text 
• Select the Text Area checkbox in the Recognition tab of the R2V 

Conversion Options dialog. 
• Choose your required algorithm for working with the raster text. 
• In the Options tab of the R2V Conversion Options dialog set the 

Text Height value equal to the maximum height of raster text 
symbols of upper case. 

• Tune the text recognition options in the Texts tab of the R2V 
Conversion Option dialog. 

See section Text recognition options on page 65 for information 
on tuning text recognition options. 

• Editing recognized texts  
The procedure of editing recognized texts (text areas) is used after 
recognition with the OCR module or with Text Areas recognition. 
After applying automatic 
vectorization choose the command 
Edit OCR Texts from the Convert 
menu. The program displays the first 
recognized text fragment (area), the 
content of which appears in the Text 
Correction dialog.  

 

You can edit the text area contents. To accept the text and move 
on to the next one press the Accept Recognized Text button of 
the Text Correction dialog. To delete the current text, press 
Delete OCR Text button in the Text Correction dialog. 

Text recognition options 

 

Orientation – choose the 
orientation for raster texts 
contained in the image. 
Overlapped by Graphics – if 
this option is on, the program 
searches for raster texts, 
crossed with other raster 
objects. 
TIPS: It is not recommended 
to use this mode when working 
with complicated documents to 
avoid possible mistakes, such 
as incorrect recognition of 
small graphic objects as texts. 

Only Standalone Letters – allows searching for standalone text 
characters.  
TIPS: If this option is off, the program does not search for 
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standalone text characters, but you can avoid incorrect recognition of 
small objects. 
Patterns – If you use the OCR module, you should set patterns for 
text inscriptions contained in the raster document to obtain better 
recognition results. Select the Word pattern checkbox.  
If Patterns are not specified, the program uses a set of standard 
patterns. 
Height Table – if after vectorizing, you want to obtain texts of 
specific height, enter the desired text height(s) in the table and select 
the Height Table checkbox. 
If you specify several height values, texts height will be rounded to 
the nearest value from the list. 
Template file –file for storing topology models of text characters, 
which are used when performing OCR. 
You can also train the program to recognize other text characters or 
different forms of characters contained in the standard template file. 

Information on training OCR is provided on page 67. 

Setting text pattern 
Text patterns can comprise of fixed and variable parts. 

Here is formal description of word pattern definition: 
“[% [length]character type] II [ letter] ]…” 
length – number of letters (you do not need to specify this, if length 
will be different), 
character type – type of letter sequence 
Types of letters are presented in the following table: 

D Digits 

N Capital letters of national alphabet 

n Small letters of national alphabet 

E Capital letters of Latin alphabet  

e Small letters of Latin alphabet  

S Special characters (signs of plus, minus, equality, degree, 
and others) 

For example, 5V, 220V, 13.8V: 5,220,13.8 – variable part, V – fixed. 
Therefore, the pattern can be defined as %DV. The length is 
different, so it is not specified). 
Examples: 
Symbol sequence Pattern 

5    25     5559     22.9 %D 

R25     R15     R13 R%2D 

Moscow     Hanover %1E%e 

project     design %n 
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5V     220V     13.8V %DV 

120     300     450 %2D%1S 

Training OCR 
You can train the OCR module to recognize new characters. You can 
add a new character to one of the standard template libraries or 
create your own. 
TIPS: In some cases it is more convenient to use the standard library 
(e.g., DEFAULT.OCR) as basis, having saved it with a new name. 

 

To train the program to recognize a 
new character or different forms of 
existing characters: 
• Choose Train OCR from the 

Conversion menu. 
• Open (create) OCR-file. 
• Enter a character to recognize in the 

Character field.  
• Select the corresponding character 

on the raster image using one of the 
selection buttons. 

• Press “+” to add the new pattern to the OCR-file. 
• Save the OCR-file. 

Automatic Raster to Contours vectorization 
Performs a Raster to Contours conversion by polylines which 
duplicates selected closed areas on the image. At the same time, if an 
area has a mutual border (example shown below), every area 
(parcel) of polylines will have its own segment. 

 
Setting up the Raster to Contours parameters can be performed in 
R2V Conversion Options. 
Increasing the Radius parameter causes more places to be treated 
as area borders 
To perform conversion to contours do following: 
• Open the monochrome raster image. 
• Choose Raster to Contours from the Convert menu or click the 

 button on the Raster to Vector toolbar. 

• If you are not happy with Raster to Contours conversion try 
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changing the parameters in Conversion Options and re-run the 
command. 

Automatic Color vectorization 

 

The Color Conversion intended 
for recognition of the linear 
objects on the color schematic 
raster images (plans, 
schemes, topographical 
maps). It combines such 
operations as binarization, 
vector color separation and 
color vectorization. As a 
result, you get polylines 
broken in places of mutual 
crossings.  
This command works on 
grayscale and color images. 
 

To start Color Conversion command choose Color Conversion 

Options from the Convert menu or click the  button on the 

Raster to Vector toolbar. 

To tune the color conversion parameters do following steps: 
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Step1: 
• Adjust the binarization 

parameters (similarly to 
Adaptive Binarization): 

• Switch on the Export Raster to 
Layer checkbox. 

• Switch off the Show Vectors 

button  of this dialog and 

switch on the Show Raster 

button . 

• Move the Radius slider to its 
minimum position (equal to 4). 

• Gradually increase the 
Threshold value until the 
required objects appear. 

• Use the Smoothing filter if the 
objects have rough borders. 

At the same time, closely 
positioned lines might 
conglutinate and small objects 
might disappear. 

 

Turn off the Export Raster to Layer checkbox after adjusting the 
binarization settings. If you think this monochrome raster is 
necessary, you can switch this checkbox on after all the other 
settings adjustment are complete 
Step2: 
Set the Recognition parameters: Max Width, Min Length and 
Accuracy. 
Those parameters are equal to those for monochrome images in the 
raster to vector Conversion Options dialog and the Raster 
Properties toolbar. 
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Step3 
• Switch off the Separate by 

Color checkbox and define a 
preview area so that you can see 
all the objects of all the colors 
resented in the raster image. 

• Visually check up the quality of 
the recognized objects, their 
color and a degree of conformity 
to the raster image. Recustomize 
parameters if necessary. 

• If you want to see lines of 
different colors on separate 
layers, switch on the Separate 
by Color checkbox. 

• After defining the correct number 
of colors you can define another 
target color and a layer for each 
real color. 

• If you do not want to export a 
line of a certain color, switch off 
the Export checkbox at the 
beginning of this string. 

 

Step4: 
Click the Apply button to start vectorization or save the parameters 
to a file for further use. 

You can also launch vectorization with current settings through 
the Raster2Vector command (chose the Raster2Vector from 

Convert menu or click the  button on the Raster to Vector 
toolbar). 

Correcting Vectorization Results 
Vectorization results usually need further editing and correcting. The 
program has both an automatic and interactive correction procedure 
intended for this purpose. It has also polylines correction command. 

Automatic correction of vectorization results 
This operation restores contact of arcs and circles, “merges” vector 
fragments; removes vector “speckles”, aligns lines to regular 
directions (angle 00, 300, 450, 600, 900, etc.), if their deviations do not 
exceed the angle specified by user. 
How to correct vectorization results automatically 
• Choose Vector Correction Options from the Conversion menu 

or press the  button on the Vector Correction toolbar. 
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• Using the displayed Vector Correction Options dialog, specify 
the autocorrection operations and parameters. Close the dialog by 
pressing OK. 

• Select vector objects to apply autocorrection. 
• Choose Vector Autocorrect from the Conversion menu or press 

the  button on the Vector Correction toolbar. 

Interactive correction of vectorization results 
After applying automatic correction, it is recommended that you also 
use the manual correction (interactive). The commands for 
interactive correction are located on the Vector Correction toolbar. 
Using interactive correction you can: 

Commands for interactive vector correction 

 Join selected vector fragments to a polyline 

 Join selected vector fragments to a circle 

 Join selected vector objects to an arc 

 Join selected vector objects to a line 

 
Join selected vector objects to create the closest matching 
(in terms of geometry) single vector object 

 Trim vector objects 

 Expand vector objects 

 Break at specified point 

 
Correct to intersection 

 
Align Angle and Distance 

See more detailed information on editing vector objects on page 
30. 

Polylines collecting 
The Collect Polylines command is designed for assembling vector 
polylines obtained as a result of the trace or automatic vectorization. 
When checking the results it is best to use the raster image as a 
substrate. 
To perform polylines collecting do following: 
• Choose the Collect Polylines from the Correct menu to start this 

command. 
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• Click the first polyline. 
• While the cursor is moving, you can see which polyline will be 

added to the current one and what you will have as a result. 
Choose the next polyline by clicking on it. Click the next polyline. 
The program automatically pans to the end point of the resulting 
object. 

Use right-button menu during command running: 

Back step Cancels the latest step. 

Cancel Cancels the command and current polyline creation. 

Continue Continues the command. 

End Finishes current polyline collecting. 

Close Closes current polyline. 

Change 
Direction 

Changes the current collecting direction. 

Centralize 
View 

Pans an image to show the latest added polyline 
nodes at the screen center. 

• Set Auto Properties item in Inspector to off value and change 
the properties of the resulting polyline (such as its color, thickness, 
markers) in during the command execution. 

• Use special modes for modifying the resulting object during 
polyline assembling process: 
Case 1: polyline1 
has a stray tail, 
and you need to 
attach it to 
polyline2 
Press CTRL and click 
a point on the 
current polyline1 in 
which it must be 
broken. You will 
continue polyline 
assembling from this 
point. 
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Case 2: polyline2, 
which you want to 
append, has a 
stray head 
Press CTRL and 
specify a point on 
polyline2 to which it 
must be attached. It 
will be broken in this 
point and added to 
polyline1. 

 

Case 3: to close a 
current polyline 
Press CTRL and click 
on one of the current 
polyline  
end points. The 
polyline will close and 
the command will be 
finished. The closed 
polylines are 
highlighted with 
rounds, instead of a 
square form for 
grips. 

 

Case 4: to draw a 
segment of a 
polyline manually 
Press SHIFT and 
draw as many 
segments as 
necessary. 
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Case 5: to add 
some vertices to a 
current polyline 
Press CTRL+SHIFT 
and add a necessary 
number of vertices. 

 

 

Working with Raster Symbols 
The new algorithm of WiseImage allows you to recognize, select and 
vectorize not only raster entities such as lines, arcs, circles, and 
others, but also raster symbols. For example, units of electric and 
technology schemes, labels of windows, staircases, sanitary 
equipment on premises plans, and more. 
Raster symbols are recognized in accordance with patterns stored in 
special template libraries. A raster symbol can be rotated and have a 
different scale. You can train the program to recognize new symbols. 
Before selecting, tracing, and vectorizing a raster symbol, you need 
to include the corresponding template in the Symbols tab of the R2V 
Conversion Options dialog box. 

Training to Recognize Symbols 

  

1. To recognize a raster symbol you 
need to create the corresponding 
vector template. This can be 
performed using vectorization, 
tracing, or simply by drawing 
vector objects over the raster 
symbol. 

INFORMATION: You can group 
vector objects to a block and use 
this block as a template.  

Raster symbol  Vector 
template 
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2. Save the template in a special library. 

• Select the vector template. 

Information on vector selection is provided on 
page 26 

• Choose Train Symbol from the Convert menu. 
• If the symbol has connection lines specify them 

with the Select connection lines  button of 
the Train Symbols dialog. 

 
Connection 
lines 

Connection line – line of variable length, with which a symbol is 
connected to other objects. Set a corresponding name for further 
convenient use. 
• Save the symbol using the Save As button of the Train Symbols 

dialog. 
INFORMATION: The location of the root folder for storing templates 
is defined with the Preferences dialog. As each template is stored in 
a separate file, it is wise to group symbols files into sets of 
subfolders. 

Tuning Symbol Recognition Options 
The parameters of selecting, tracing and automatic vectorizing of 
raster symbols are set in the Recognition and Symbols tabs of the 
R2V Conversion Options dialog. 
Choose Conversion Options from the Convert menu. 
• Open the Recognition tab and select the Symbols 

checkbox. 
• Open the Symbols tab. 

 

Select the checkboxes of the 
required categories (includes all 
symbols of category) or 
standalone symbols 
Strategy – this parameter 
influences the speed and quality 
of symbol recognition. Set 
Standard or Smart. 
Accuracy – this parameter 
defines acceptable deviation of 
the raster symbol from the 
template. Use a higher accuracy 
value for raster images of good 
quality, lower – for images of 
poor quality. 

Fixed Scale –if the Fixed Scale checkbox is on, only those raster 
symbols, which size coincide with the size of corresponding templates 
or different from them by specified scale factor are recognized. 
If the Fixed Scale checkbox is off, raster symbols of different scale 
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will be recognized. 
Orientation – specifies the raster symbol orientation relative to the 
templates’ orientation (choose Horizontal, Horizontal and Vertical or 
Arbitrarily oriented). 
Standalone Symbols – select this checkbox, if you have only 
standalone symbols on your image. 

Selecting, Tracing, and Vectorizing Raster Symbols 
1. Tune the symbol recognition options. 

Selecting raster symbols 

 
2. Set raster (hybrid) type of selected data 

 

3. Press the Select Raster Symbol button on the Select 
toolbar  

4. Specify a point inside the raster symbol to select. 

TIPS: It is recommended that you click a point near the 
geometric centre of the symbol. 

More detailed Information on data selection is provided on page 
23 

 

Tracing raster symbols 
2. Choose tracing mode 

Information on tracing modes is provided on page 55 

 

3. Press the Trace Symbol button on the Raster to Vector 
toolbar 

4. Specify a point inside the raster symbol to select. 
TIPS: It is recommended that you click a point near the 
geometric centre of the symbol. 

More detailed Information on tracing is provided on page 53 

Vectorizing raster symbols 
2. If you have several images in your document, select the one(s) 

to vectorize. 
You can also select an image fragment or image clip to vectorize. 

3. Choose Raster2Vector from the Conversion menu. 

 

Batch and Script 
Script Studio 

Script – is a sequence of operations, which can be executed 
unattended. 
Let us consider an example of creating a Script on the basis of raster 
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image calibration. 
Prepare data to start Script: 
• Prepare document (*.cws): open the raster image, customize 

the User Coordinate System (UCS), save the document (Map.cws) 
• Prepare calibration template: set calibration pairs – grid and 

measured points, save the calibration pairs in file (map.tpl) 
INFORMATION: You can also set calibration pairs and save them in 
the document file. 

Prepare, save, and start Script (*.csf): 
Define the calibration execution order:  
1 – open document (*.cws); . 
2 – start calibration using calibration template (*.tpl);  
3 – save document with calibrated image with a different name. 
• Choose the command Script Studio from the Tools menu.  

1. Choose File from the 
Category list; choose 
Open Document 
from the list of 
commands of the File 
category;  

 

and move the selected command to the Script field. 

• Click on “+” to open the sub-category, which contains the chosen 
command options. 

• Specify name and folder for the document file - Map.cws  
2. From the Category 

list, choose Image; 
from the list of 
commands choose 
Calibration; and 
move the selected 
command to the 
Script field. 

 

• Open the sub-category of calibration options and specify the pre-
defined calibration template file - map.tpl 



 
78 

3. From the Category 
list choose File; from 
the list of commands 
choose Save as 
Document. 

• Open the sub-folder of 
the command options 
and specify in the File 
Name field - the 
location and name of 
the resulting file, and 
in the File Type  

 

field – the type of the resulting file,for all needed fields. 
• To save the Script (*.csf) file press the Save As button of the 

Script Studio dialog. 
• To start the Script  

§ Press the Run button of the Script Studio dialog. 
§ If the script file has been previously saved, choose Run Script 

from the Tools menu, then choose the required script file from 
the open Script File dialog. 

When starting a Script, 
the lower-right corner of 
the Edit Script dialog 
displays a report on the 
command execution. 

 

TIPS: Save the report to file, specify Set Log File as the first Script 
command, selecting name and location of the report file as 
parameters. 
TIPS: For fast navigation, you can set All Commands in the list of 
categories of the Edit Script dialog, and then you can choose a 
command by pressing its first letter. 

Batch Studio 
Batch – is a specified sequence of Scripts to process files. 
It is convenient to use the Batch option when you need to apply 
regular operations to several raster images. 
Before creating a Batch, you need to prepare a set of Scripts, which 
describe commands for processing. You do not need to describe the 
commands for opening, inserting and saving files in Scripts, 
prepared for Batch, as these operations are performed with the Batch 
studio tools. 
Look at the following example of creating a Batch: 
Prepare data to start Batch: 
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Prepare script, which perform the 
commands: Deskew, Crop, 
Rotate by 900 and save it as 
Deskew_Crop_Rotate.csf 

 

Prepare script, which performs the 
4-point correction for images of 
format ISO A4 and save it as 
4p_correction_ISO_A4.csf 

 
  
You can create and save scripts in Script studio. 

Information on creating Scripts is provided above on page 76. 

Prepare and start batch 
Choose the Batch Studio command from the Tools menu  
• From the list of folders, located in the left part of the Batch 

Studio dialog, choose the files, or folders with files to process and 
using drag & drop move them to the Input files or directories 
field. 

INFORMATION: You can use * to specify names for files, e.g., if 
you specify …\Images\*.tif, only files with extension tif 
(contained in the Images folder) will be processed. 
• From the list of folders, located in the left part of the Batch 

Studio dialog, select the prepared Scripts files, and drag and drop 
them to the Script files list field. 

 
• If you want to save the processed files in a different folder (with 

different name or extension), select the Use output directory 
checkbox. Specify a name for the folder. Otherwise, the processed 
files will overwrite the originals. 

• Press the Run button. 
 
When starting a Batch, The lower-
right corner of the Run Batch dialog 
displays a report on the command 
execution. 

 

 

Customizing WiseImage 
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Brief description: In this section you will learn how to customize the 
interface and various parameters of WiseImage. 

Customizing Program Parameters 
Choose Preferences from the Tools menu. 

 

Using the Preferences 
dialog box you can customize 
the following parameters: 

• Cursor’s appearance, color 
and size. 

• Size and color of “grips”, 
which appear when 
selecting objects. 

• Colors of interface 
elements;(e.g., color of 
selected raster objects, 
color of the program 
window background, etc.). 

• Preview window style for Binarization. 
• Scroll Settings (scroll step, arrows step, Mouse Wheel scale 

factor) 
• Snap settings (aperture size, snap markers’ size and color, 

tooltips display). 
• Filter usage mode; setting limit for displaying object properties. 
• Modifying the existing standard paper formats and adding new 

ones. 
• Defining the path to OCR template files, symbols to external 

filters folders. 
• List of operations for autocorrect. 
• Default properties for new raster images. 
• Settings for the New raster from selection command (keep or 

erase the original raster object). 
• Properties (width and color) of clipping edge used for vector 

correction. 
• Style and size of markers for vector point display. 
• Templates usage. 
• Settings for batch script (linear and angle units, default file name 

and report name). 
• Mode of monochrome raster display. 
• Turning on/off the use of World-file. (For GIS’s users) 

This general information includes the description of WiseImage 
parameters, which can be customized by the user. For more detailed 
information see the corresponding sections of User’s guide and Help. 

Customizing Interface 
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You can easily customize the WiseImage interface. 
To start modifying the interface choose Customize from the Tools 
menu. 

Creating a new toolbar 

• Press New on the 
Toolbars tab  

• Specify a name for the 
new toolbar in the 
Toolbar Name dialog 
that appears in the list. 

 

• Go to the Commands 
tab. Select the required 
group of commands from 
the Categories list, and 
then choose a command 
from the Commands list 
and drag it to the newly 
created toolbar.  
Repeat this operation for 
all commands, which you 
want to place on the new 
toolbar. 

Modifying a toolbar 
Working in this mode, you can rename toolbars, add buttons from the 
list located in the Commands tab, delete and move buttons to other 
toolbars. 
How to modify a toolbar 
Choose Customize from the Tools menu. 
To rename (delete) a toolbar select it from the list of the Toolbars 
tab and press Rename (Delete). 
You can move (delete) buttons using the drag and drop technique. 

Information on adding commands from the list of Commands is 
provided on page 81. 

IMPORTANT: If you want to reset a modified standard toolbar to its 
original state, select it and press the Reset button in the Toolbars 
tab.  
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Turning on/off toolbar display 
You can turn on/off the display of toolbars on the screen. For this you 
can choose Show Toolbar from the View menu and then select 
Check Mark for desired toolbars. 

Creating a new menu item 
Choose Customize from the Tools menu. 

 

• From the Categories list of 
the Commands tab choose 
New Menu. 

• Place the cursor on the 
New Menu string of the 
Commands list, click and 
drag cursor to the menu 
item string where you want 
to place the new item. 

• You can select commands 
for a new menu item in the 
same way as for a new 
toolbar. 

Information on adding commands from the list of Commands is 
provided on page 81. 

Modifying a menu 
You can rename menu items, add, delete, move and group menu 
commands. 
How to modify a menu 
Choose Customize from the Tools menu. 

 

• To rename a menu item: place the cursor 
over it, right-click and choose Rename from 
the right-button menu. 

 

• If you want to group some menu commands, 
choose Begin Group from the right-button 
context menu. 

• You can move (delete) commands using the drag and drop 
technique. 

Information on adding commands from the list of Commands is 
provided on page 81. 
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IMPORTANT: If you want to reset all menu items to their original 
state press the Reset All button, located in the Toolbars tab. Note 
that pressing this button resets all interface modifications made by 
the user. 

Assign acceleration keys 
Start customizing the interface by choosing Customize from the 
Tools menu. Open the Keyboard tab. 

 

• Select the desired group of 
commands from Category, 
and then the command from 
the Commands list. 

• Enter a desired key 
combination in Press new 
acceleration key field. 

• If this key combination has 
already been assigned, the 
name of the command for 
which this combination is 
already used appears in the 
Assigned to field. 

• Press Assign, if this combination is not already used (message: 
Unassigned in the Assigned to field). 

• To delete the existing acceleration keys, select them from Current 
keys and press Remove. 

Modifying context (right-button) menu 
You can modify the list of commands contained in context (right-
button) menu.  

 

• Choose Customize from the 
Tools menu, and then the 
Menus tab. 

• Select a command from the 
list, for which you intend to 
modify the context (right-
button) menu. 

• Press the Customize button. 
• Modify the appeared context 

menu. 

NOTE: If you want to reset modified context menu to the original, 
select it from the list and press the Reset button. 

Custom Button Size 
Button sizes can be tuned freely and styles are completely 
remastered to achieve a better performance while operating in a wide 
range of screen resolutions. 
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• Choose Customize from the 
Tools menu, and then the 
Options tab. 

• Modify the appeared settings. 

User Defined Buttons 
From now user can create custom toolbars and buttons and assign 
scripts or command sequences to this new buttons. 

• Choose Customize from the 
Tools menu, and then the 
Commands tab. 

• On the left bottom corner click 
on the harmer symbol and 
drag to the desired toolbar 

• By right mouse click on the 
new button enter Tool Setup 

• To modify button image select 
Edit in Tool Setup 

Multiple Preview Windows 
It is a possibility to open several preview windows at a time, during 
any image enhancement procedure. To launch a new preview window 

press  button under the active preview window. 

Transparency 
Dialog boxes and palettes can be set semi-transparent.  To do it 
press Ctrl + Right mouse button on a desired dialog box  and set 
Window Transparency. 

Raster Border Control 
You can switch off raster border frame, for convenience. To do it, go 

to Preferences , and unselect Draw Raster Frame in Display 

View  


